Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: LCD Modul Pin3 spinnt (Kontrast)

  1. #1
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    562
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, ich werd heut noch verrückt !

    vor einer woche habe ich folgende schaltung nachgebaut + VB-Proggi auch.
    ( Interfacing Example - 16 Character x 2 Line LCD)
    http://www.beyondlogic.org/parlcd/parlcd.htm
    Das ding hat auch funktioniert !

    nun hab ich es an einen PIC 16F628A angeschlossen.
    ( also alle leitungen ab- und andere angelötet )

    Das Problem: Wenn ich wieder an Pin 3 den Kontrast
    (
    +5V --- R4K7 --- Poti
    Poti --> Pin 3
    -5V --- Poti
    )

    Dann fliesst ein hoher strom von +5V (Pin 2) nach übert Pin 3 nach -5V wenn der reger ganz nach -5V gedreht wird.

    Ich bin sicher, die ersten 3 pins nicht verwechselt zu haben !

    Das Problem bleibt, auch wenn der PIC abgeschlossen ist.
    d.h. nur Pin 1,2,3 sind angeschlossen.

    Auf dem Display steht nur 0533 hinten und vorne 66-07A drauf.

    Das mit neg. Kontrast (ca. -1,7V) stimmt wohl, da es damit 2-zeilig gut funktioniert hat.

    NUR JETZT GEHT NIX MEHR. doof.

    any hints?
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)


    Zitieren Zitieren LCD Modul Pin3 spinnt (Kontrast)  

  2. #2
    Registriert seit
    02.01.2006
    Ort
    Leverkusen
    Beiträge
    51
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hi,

    bist du sicher das der Kontrasteingang deines Panels negative Spannung braucht bzw. verträgt ? Das können nämlich nicht alle LCDs.
    Ich habe beim experimentieren mit unbekannten Panels auch schon mal das ein oder andere auf so eine Weise ins Nirwana geschickt.

    Gruß Nitro
    Die Fähigkeit sprechen zu können macht nicht unbedingt intelligent. (Qui-Gon Jinn)

  3. #3
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    562
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard

    Zitat Zitat von Nitrozin Beitrag anzeigen
    Hi,
    bist du sicher das der Kontrasteingang deines Panels negative Spannung braucht bzw. verträgt ?
    Gruß Nitro
    Einen ganzen abend hat es mit ca. -1,7V funktioniert.
    Dann hab ich es umgebaut.

    immer noch ratlos.
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



  4. #4
    Registriert seit
    19.10.2007
    Ort
    far far away
    Beiträge
    478
    Danke
    114
    Erhielt 136 Danke für 95 Beiträge

    Standard

    Bist du dir sicher das du auch den Schleifer des Potis auf Pin3 des Panels hast und nicht einen anderen Anschluß des Potis?

  5. #5
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    562
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Solaris Beitrag anzeigen
    Bist du dir sicher das du auch den Schleifer des Potis auf Pin3 des Panels hast und nicht einen anderen Anschluß des Potis?

    Solaris, ganz sicher hab ich beim Löten nicht sehr tief ins glas geschaut.

    Wikipedia: Solaris eine Rebsorte.
    http://de.wikipedia.org/wiki/Solaris

    der Schleifer ist doch der zwischen den beiden Äußeren
    und der Pin ist der b00000011 ?
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



Ähnliche Themen

  1. Analogeingang spinnt
    Von Nost im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 07.11.2010, 14:16
  2. DB spinnt ?
    Von Power_Pete im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.03.2010, 16:55
  3. OP 7 - Kontrast
    Von eisenbrandt im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 16.10.2008, 21:23
  4. Spinnt PLCSIM V5.3+SP1?
    Von Störtebecker im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.09.2006, 09:11
  5. forum spinnt...
    Von Anonymous im Forum Stammtisch
    Antworten: 4
    Letzter Beitrag: 21.10.2005, 17:21

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •