Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 32

Thema: S7 CPU defekt

  1. #11
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die hilfreichen Informationen.

    Werde direkt mal bestellen und zeitnah die oben genannten Sicherungen/Dioden prüfen, soweit es möglich ist.

  2. #12
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Der Chip ist zu weit weg von der MPI-Buchse.
    Es ist ein DC-to-DC Converter, ich vermute, der macht 5V aus 24V.


    Wenn Du entsprechende Löt-Möglichkeiten hast? Die Teile kosten nichtmal 2,- EUR.

    Das Teil mit den 4 Pins ist ein
    BCP53-16 PNP Transistor 1.5A

    Der verschmorte Chip mit den 8 Pins ist ein
    MC33063AD: Buck/Boost/Inverting Switching Regulator (DC-to-DC Converter) 1.5A
    Pin 1 ist auf dem Foto links oben bei dem 1kOhm-Widerstand zum Transistor.


    Frag doch mal Siemens, ob sie Dir die Schaltungsunterlagen verkaufen ...
    In dem Datenblatt vom MC33063AD sind Referenzschaltungen.

    Vielleicht ist noch mehr kaputt. Siemens macht üblicherweise Soll-Bruchstellen. Suche und überprüfe mal OMF (SMD-Sicherungen) und TVS-Dioden.

    Harald

    Bei den Bauteilen bist Du dir sicher? Hab die jetzt bestellt und sollten morgen kommen.


    Grüße

  3. #13
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Aus dem Datenblatt:
    Output Voltage Adjustable

    Wie wird es eingestellt? Poti? oder externe Verschaltung?
    Geändert von K.Krah (30.01.2014 um 10:30 Uhr)

  4. #14
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Zitat Zitat von K.Krah Beitrag anzeigen
    Bei den Bauteilen bist Du dir sicher?
    Ziemlich sicher. Allerdings weiß ich nicht genau die Buchstaben am Ende der Bauteilebezeichnung, weil man den Hersteller nicht erkennt. Der IC sieht für mich aus wie von ST oder TI. Es sollte aber kein Problem sein, die kompatiblen Bauteile von ON oder anderen Herstellern einzusetzen.
    siehe mein Foto von einer 315-2AH14 E-Stand/FS: 4


    Zitat Zitat von K.Krah Beitrag anzeigen
    Aus dem Datenblatt:
    Output Voltage Adjustable

    Wie wird es eingestellt? Poti? oder externe Verschaltung?
    Die Ausgangsspannung wird bestimmt nicht durch ein Potie eingestellt. Da sollten irgendwo 2 Festwiderstände sein (siehe R1 und R2 in den Referenzschaltungen). Vout = 1.25V * (1 + R2/R1)

    Ich habe mal an einer 315-2AH14 ein paar Messungen gemacht:
    - Versorgung der CPU mit 24.3 V
    - BCP53 B: 21.7 V
    - BCP53 C: 22.3 V (Ausgang der Stabilisierungsschaltung)
    - BCP53 E: 22.3 V
    - IC Pin 1: 22.3 V
    - IC Pin 2: 0 V
    - IC Pin 3: 0.8 V
    - IC Pin 4: 0 V
    - IC Pin 5: 1.25 V
    - IC Pin 6: 22.3 V (Eingang der Stabilisierungsschaltung)
    - IC Pin 7: 22.4 V
    - IC Pin 8: 22.2 V
    - IC MC33063 zwischen Pins 2 und 4: ca. 0.1 Ohm
    - IC Pin 5 gegen 0V: 1.0 kOhm
    - die beiden kleinen Widerstände an der Basis des BCP53 links vom 1kOhm-Widerstand: beide je ca. 49 kOhm

    Wenn ich mir die Meßwerte so ansehe, dann habe ich folgende Idee: die Stabilisierungsschaltung einfach überbrücken:
    - den BCP53 und den IC auslöten
    - die Lötflächen vom ehemals Anschluß IC Pin 6 mit dem ehemals Collector des BCP verbinden
    --> die CPU könnte laufen (für Deine Testzwecke), falls nicht weiteres kaputt ist

    Harald
    Angehängte Grafiken Angehängte Grafiken
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #15
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich würde es gerne probieren - nur musst Dir sicher sein das es funzt sonst warte ich lieber auf die Teile!


  6. #16
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Ooch.. ich muß mir nicht sicher sein

    Es ist Deine CPU und Du bist derjenige, der sich die Reparatur zutraut. Du mußt mithilfe der Informationen aus meinem Foto und dem IC-Datenblatt selber einschätzen können, was die reale Schaltung in der CPU wie tut. Wenn nicht, dann gib die CPU zu einem professionellen Reparaturservice - wobei die Kosten wohl die Gleichen bleiben, auch falls Du die CPU vorher noch richtig kaputt-bastelst
    Ich bin nur u.A. ein gelernter Elektronik-Bastler Ich kann Tips geben - aber keine Garantie.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    ducati (31.01.2014)

  8. #17
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    danke für deine Info's. ich baue die Dinger ein und werde berichten ob sich was tut oder nicht.

    Grüße

  9. #18
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So hab nun den DC DC Chip mal gemessen:

    Gemessen bei 24,6V

    - IC Pin 1: 22.23 V
    - IC Pin 2: 0,013 V
    - IC Pin 3: 5,07 V
    - IC Pin 4: 0,013 V
    - IC Pin 5: 0,880 V (gegenüber Pin 4)
    - IC Pin 6: 22.25 V (gegenüber Pin 3)
    - IC Pin 7: 22.25 V (gegenüber Pin 2)
    - IC Pin 8: 8,05 V (gegenüber Pin 1)

  10. #19
    K.Krah ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.04.2011
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    breiter Anschluss: 22,10 V
    BSP:B 21,49V
    BSP:C 22,10V
    BSP:E 22,17V

  11. #20
    Registriert seit
    16.11.2006
    Beiträge
    25
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn die CPU an einer gewerblichen Maschine eingesetzt ist solltet ihr die Finger von selbst Reparaturen lassen!
    Ab dem Eingriff ist es keine Siemens CPU mehr (egal was ihr tauscht!) und wenn es mal Probleme an der Maschine Anlage gibt und Menschen zu Schaden kommen muss jemand in den Knast - und das ist kein Spaß!
    Wenn Ihr die CPU für Eure Modelleisenbahn verwendet wünsche ich euch weiter Spaß beim Iden-austausch!

Ähnliche Themen

  1. Wago CPU oder Speicher defekt
    Von erdbeerschaeler im Forum WAGO
    Antworten: 20
    Letzter Beitrag: 28.10.2012, 17:37
  2. S7-200 CPU 224 DC/DC/DC Ausgang defekt ?
    Von karatom im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 24.10.2012, 19:46
  3. CPU 313C defekt suche Ersatzteile
    Von blackknights im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 25.08.2010, 18:03
  4. s5 100u cpu 102, rs232 schnittstelle defekt
    Von klammheimlich im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 09.07.2007, 06:02
  5. S5: Cpu 942 Defekt?
    Von v-max-67 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 05.06.2005, 21:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •