Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 32

Thema: Probleme mit Euchner MGB

  1. #11
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich stell die Zeit so Pi mal Daumen auf 1/4 Zykluszeit. Du kannst die Zeit natürlich auch länger machen, aber das hängt dann eben von der Anwendung ab.
    Wieviele Switche / Teilnehmer hängen im Netz vor den gestörten Teilnehmern?
    Hast du die Profinet-Topologie richtig eingetragen?
    Welche Switche verwendest du?

    Da es bei dir wohl immer die gleichen Teilnehmer sind, solltest du mal evtl. probieren einen zusätzlichen Netzwerkstrang aufzubauen und die Netzwerklast gleichmässiger aufzuteilen.

    Gruß
    Dieter

  2. #12
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Zitat Zitat von Blockmove Beitrag anzeigen
    Ich stell die Zeit so Pi mal Daumen auf 1/4 Zykluszeit. Du kannst die Zeit natürlich auch länger machen, aber das hängt dann eben von der Anwendung ab.
    Wieviele Switche / Teilnehmer hängen im Netz vor den gestörten Teilnehmern?
    Hast du die Profinet-Topologie richtig eingetragen?
    Welche Switche verwendest du?

    Da es bei dir wohl immer die gleichen Teilnehmer sind, solltest du mal evtl. probieren einen zusätzlichen Netzwerkstrang aufzubauen und die Netzwerklast gleichmässiger aufzuteilen.

    Gruß
    Dieter
    Zumindestens einer der Sorgenkinder hängt direkt am Switche. Bei dem anderen weiss ich es grad nicht aber viele Teilnehmer sind es sicher nicht. Wir haben Switche von Phönix im Einsatz. Das Netzwerk ist nicht grade klein und es sind insgesamt 3 CPUs mit drin. Aber alles läuft super bis auf diese 2 Mistkerle. Ich hab noch nicht viel Erfahrung mit Profinet. Was meinst du mit Topologie eintragen ?
    Früher gab es Peitschen .... heute Terminkalender

  3. #13
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    Zumindestens einer der Sorgenkinder hängt direkt am Switche. Bei dem anderen weiss ich es grad nicht aber viele Teilnehmer sind es sicher nicht. Wir haben Switche von Phönix im Einsatz. Das Netzwerk ist nicht grade klein und es sind insgesamt 3 CPUs mit drin. Aber alles läuft super bis auf diese 2 Mistkerle. Ich hab noch nicht viel Erfahrung mit Profinet. Was meinst du mit Topologie eintragen ?
    Topologie:
    In der Hardwarekonfig kannst du die Netzwerktopologie (Aufbau) eintragen.
    Es gibt dafür ein recht gutes grafisches Tool. Du definierst damit welcher Netzwerkanschluss eines Gerätes mit welchem Partner verbunden ist.
    Bei Profinet gibt es die sogenannte Nachbarschaftserkennung (LLDP). Wenn jedes Gerät seinen Nachbarn kennt, so ist darüber ein Gerätetausch ohne Noteboök möglich.
    Du holst ein neues, nicht konfiguriertes Gerät aus dem Lager und schliesst es an. Die Nachbarn sind Antrieb 4 und Antrieb 6. Somit ist das neue Gerät Antrieb 5 und wird entsprechend konfiguriert.
    Ausserdem ist die Onlineansicht der grafischen Topologieübersicht bei der Fehlersuche manchmal ganz nützlich.

    Switche:
    Bei Profinet setzten wir generell Siemens Scalance-Switche ein.
    Diese werden über die Hardwarekonfig entsprechend parametriert. Ich weiss nicht ob dies bei Phönix auch der Fall ist.
    Wenn nicht, dann musst die Switche entsprechend kofigurieren. Profinet sollte priorisiert werden.
    Wenn du viele Panels, Kameras oder sonstigen "Kram" am Netz hast, dann muss sich Profinet "in die Schlange stellen".
    Da aber Profinet quasi Echtzeit sein soll, muss die Priorität für Profinet erhöht sein und Profinet kann sich vorbei drängeln.
    Eure 100 Teilnehmer sind schon eine Hausnummer. Da kann schon der ein oder andere Flaschenhals auftreten und dies äussert sich in "seltsamen" Verhalten einzelner Teilnehmer.

    Wenn du die Probleme nicht in Griff bekommst, kannst du ja mal das Netz testen lassen. Es gibt eiige Dienstleister auf dem Markt.
    Bei entsprechend guter Netzwerkdoku (Topologie) hält sich der Zeitaufwand und somit die Kosten in Grenzen.

    Gruß
    Dieter

  4. Folgender Benutzer sagt Danke zu Blockmove für den nützlichen Beitrag:

    Lipperlandstern (25.04.2015)

  5. #14
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Bei Profinet-IO gibt es nicht viele Gründe für ein "falsches" bzw. nicht erwartetes Signal:

    1) Der PN-Teilnehmer schickt wirklich ein falsches Signal, d.h. Fehler im Teilnehmer
    2) Der PN-Teilnehmer fällt aus, die SPS setzt den Signalzustand die Eingänge auf Null, der PN-Teilnehmer seine Ausgänge ggf. auf einen sicheren Zustand.

    Fällt ein PN-Teilnehmer wegen ansprechen der Überwachungszeit aus, gibt es normalerweise im Diagnosepuffer der SPS einen Eintrag. Da würde ich als erstes mal nach Auffälligkeiten schauen.
    Wenn du die Aktualisierungszeit heraufsetzt, erhöht sich auch die Ansprechüberwachungszeit.

    Wenn du keinen Eintrag im Diagnosepuffer der SPS hast, bleibt eigentlich nur noch Problem 1).

    Die Ursache für Fehler 2) kann diverse Ursachen haben, wie von Blockmove aufgeführt. Aber erstmal muss festgestellt werden ob 2) überhaupt auftritt (Diagnosepuffer der SPS prüfen).

    Zur Not muss man am Netzwerk den Verkehr mitschneiden und nachprüfen was dort vor sich geht, und damit dann auf den Hersteller zugehen. Zum "Glück" tritt das Problem ja häufig auf, sodass man darauf warten kann.

  6. #15
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Die Ursache für Fehler 2) kann diverse Ursachen haben, wie von Blockmove aufgeführt. Aber erstmal muss festgestellt werden ob 2) überhaupt auftritt (Diagnosepuffer der SPS prüfen).

    Zur Not muss man am Netzwerk den Verkehr mitschneiden und nachprüfen was dort vor sich geht, und damit dann auf den Hersteller zugehen. Zum "Glück" tritt das Problem ja häufig auf, sodass man darauf warten kann.
    Bei Profinet gibt es auch Telegramm-Wiederholungen. Damit etwas im Diagnosepuffer auftaucht muss das Netzwerk schon heftig gestört sein.
    Du kannst ein absolut grenzwertiges Netzwerk haben und bekommst vielleicht einmal pro Woche eine Meldung. Schön sind diese Dinge dann beim F-Programm

    Aber laut den ganzen Marketing-Kaspern ist ja Profinet sooo einfach und viel viel besser als Profibus.

    Es gibt einige Anbieter (Indu-Sol, Softing, ...) die entsprechende Testgeräte anbieten. Aufgrund der Freiheit bei der Topologie sind Netzwerkfehler manchmal aber sehr schwer zu lokalisieren.

    Gruß
    Dieter

  7. #16
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Solange die eingestellte Anzahl der Wiederholungen nicht überschritten wird, ist der Teilnehmer aber nicht gestört. Gab es bei Profibus in Form des Retry-Limit aber auch schon, nur dass dieser dort auf 1 steht solange man die Einstellungen nicht verändern muss.
    Bei Profinet kann ich die Anzahl Wiederholungen nur beim Device einstellen, ich weiß momentan nicht ob die Anzahl dann genauso für den Controller gilt.

    Solange nicht eindeutig festgestellt wurde ob die Ansprechüberwachung ausgelöst hat, braucht man sich noch keine Gedanken um Topologien, Switche oder Erdungen zu machen.

  8. #17
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Bei Profinet-IO gibt es nicht viele Gründe für ein "falsches" bzw. nicht erwartetes Signal:

    1) Der PN-Teilnehmer schickt wirklich ein falsches Signal, d.h. Fehler im Teilnehmer
    2) Der PN-Teilnehmer fällt aus, die SPS setzt den Signalzustand die Eingänge auf Null, der PN-Teilnehmer seine Ausgänge ggf. auf einen sicheren Zustand.

    Fällt ein PN-Teilnehmer wegen ansprechen der Überwachungszeit aus, gibt es normalerweise im Diagnosepuffer der SPS einen Eintrag. Da würde ich als erstes mal nach Auffälligkeiten schauen.
    Wenn du die Aktualisierungszeit heraufsetzt, erhöht sich auch die Ansprechüberwachungszeit.

    Wenn du keinen Eintrag im Diagnosepuffer der SPS hast, bleibt eigentlich nur noch Problem 1).

    Die Ursache für Fehler 2) kann diverse Ursachen haben, wie von Blockmove aufgeführt. Aber erstmal muss festgestellt werden ob 2) überhaupt auftritt (Diagnosepuffer der SPS prüfen).

    Zur Not muss man am Netzwerk den Verkehr mitschneiden und nachprüfen was dort vor sich geht, und damit dann auf den Hersteller zugehen. Zum "Glück" tritt das Problem ja häufig auf, sodass man darauf warten kann.

    Es gibt keine Eintrag im Diagnosepuffer. Die Geräte gehen ja auch nicht auf "Störung". Und es fällt nur das Not-Halt-Signal aus. Und das immer kürzer als 250 ms. Das Tür-Signal welches im selben Block übertragen wird macht keine Probleme. Also doch (1) ? Allerdings wird das Verhalten besser wenn die Aktualisierungzeit erhöht wird. Das spricht für (2).

    Ich warte jetzt erstmal auf das Austauschgerät......
    Früher gab es Peitschen .... heute Terminkalender

  9. #18
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    Es gibt keine Eintrag im Diagnosepuffer. Die Geräte gehen ja auch nicht auf "Störung". Und es fällt nur das Not-Halt-Signal aus. Und das immer kürzer als 250 ms. Das Tür-Signal welches im selben Block übertragen wird macht keine Probleme. Also doch (1) ? Allerdings wird das Verhalten besser wenn die Aktualisierungzeit erhöht wird. Das spricht für (2).
    Durch heraufsetzen der Aktualisierungszeit bekommst du vielleicht nicht jedes Signal mit das von dem Gerät falsch erfasst wird.

    Beispiel: Es gibt auf einem Eingang kurze Spitzen von 10ms Dauer. Wird der Eingang mit 50 ms abgetastet bekommst du nicht jede Spitze mit. Wird mit 1ms abgetastet dann schon (Shannon Theorem).

    Dass du die Störung mit dem 250ms Timer unterdrücken kannst spricht auch gegen einen ausfallenden Teilnehmer. Was ich so festgestellt habe, dauert es nach einem Ausfall eines Devices nach dem Wiederanmelden meist so 2-3 Sekunden bis der zyklische Datenaustausch wieder aufgenommen wird.

  10. #19
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Eigentlich müsstestdu den Fehler durch Tausch von 2 Geräten eingrenzen können.
    Tausch deinen Schalter gegen einen funktionierenden.
    Netzwerkfehler sind in den meisten Fällen Standort treu. Wandert der Fehler mit, dann liegt der Fehler am Schalter.
    Zeigt der bislang funktionierende Schalter Störungen, dann liegt es am Netz.

    Gruß
    Dieter

  11. #20
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe gerade noch mal etwas Doku gelesen.
    Wie schon geschrieben, gibt es bei Profinet eigentlich nur zwei Fehler: entweder das Device schickt falsche Daten oder das Device fällt aus, d.h. schickt keine Daten im eingestellten Überwachungsintervall mit entsprechendem Eintrag im Diagnosepuffer. Nicht erkannte Telegrammfehler seien hier aufgrund der Hamming-Distanz von imho 4 (wie bei Profibus) mal ausgeschlossen.

    Fällt ein Device aus dauert es einige Zeit bis zum Hochlaufen. Ich konnte jetzt nicht aus der Beschreibung herauslesen wie lange diese Zeit mindestens ist. Auf jeden Fall ist nur mit besonderen Controllern und Devices ein sogenannter "priorisierter Hochlauf" möglich. Damit kommt man unter bestimmten Umständen auf eine Hochlaufzeit von 500ms. Ich habe an "normalen" Geräten eine Hochlaufzeit von 2-3 Sekunden festgestellt.
    Ich würde darum mal behaupten, bei allen Störungen kürzer als 500ms ist es garantiert kein Netzproblem.

    Der Vorteil bei Profinet ist, dass es mit im Vergleich zu Profibus relativ günstigem Equipment diagnostizierbar ist. Ein Switch mit Monitor-Port oder besser noch ein TAP und Wireshark reicht völlig aus. Und die Diagnose-Software für Profibus von Trebing&Himstedt ist im Vergleich zu Wireshark ein schlechter Witz.

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 27.08.2014, 11:09
  2. S7-Safety Sicherheitstür von Euchner Baustein
    Von Krumnix im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 26.05.2014, 11:16
  3. Euchner Sicherheitsschalter an Siemens F-CPU anschliessen und auswerten
    Von Krumnix im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 6
    Letzter Beitrag: 29.03.2013, 09:58
  4. KL2541 - Probleme mit Referenzfahrt, fahren ohne NC, nur mit SPS
    Von PraktikantMarkus im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 16.03.2012, 15:38
  5. Euchner eks key
    Von AlexanderEms im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 01.09.2011, 08:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •