Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 32

Thema: Probleme mit Euchner MGB

  1. #21
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.494
    Danke
    502
    Erhielt 1.145 Danke für 738 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Blockmove Beitrag anzeigen
    Eigentlich müsstestdu den Fehler durch Tausch von 2 Geräten eingrenzen können.
    Tausch deinen Schalter gegen einen funktionierenden.
    Netzwerkfehler sind in den meisten Fällen Standort treu. Wandert der Fehler mit, dann liegt der Fehler am Schalter.
    Zeigt der bislang funktionierende Schalter Störungen, dann liegt es am Netz.

    Gruß
    Dieter

    Das mit dem Tausch ist leider gar nicht so einfach da wir die MGBs in 2 verschiedenen Varianten haben (linker bzw. rechter Türanschlag) Und natürlich sind 2 linken kaputt ..... Ich warte mal auf das Ersatzteil... dauert ja nur noch 3 Wochen bis es kommt....
    Früher gab es Peitschen .... heute Terminkalender

  2. #22
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.494
    Danke
    502
    Erhielt 1.145 Danke für 738 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Ich habe gerade noch mal etwas Doku gelesen.
    Wie schon geschrieben, gibt es bei Profinet eigentlich nur zwei Fehler: entweder das Device schickt falsche Daten oder das Device fällt aus, d.h. schickt keine Daten im eingestellten Überwachungsintervall mit entsprechendem Eintrag im Diagnosepuffer. Nicht erkannte Telegrammfehler seien hier aufgrund der Hamming-Distanz von imho 4 (wie bei Profibus) mal ausgeschlossen.

    Fällt ein Device aus dauert es einige Zeit bis zum Hochlaufen. Ich konnte jetzt nicht aus der Beschreibung herauslesen wie lange diese Zeit mindestens ist. Auf jeden Fall ist nur mit besonderen Controllern und Devices ein sogenannter "priorisierter Hochlauf" möglich. Damit kommt man unter bestimmten Umständen auf eine Hochlaufzeit von 500ms. Ich habe an "normalen" Geräten eine Hochlaufzeit von 2-3 Sekunden festgestellt.
    Ich würde darum mal behaupten, bei allen Störungen kürzer als 500ms ist es garantiert kein Netzproblem.

    Der Vorteil bei Profinet ist, dass es mit im Vergleich zu Profibus relativ günstigem Equipment diagnostizierbar ist. Ein Switch mit Monitor-Port oder besser noch ein TAP und Wireshark reicht völlig aus. Und die Diagnose-Software für Profibus von Trebing&Himstedt ist im Vergleich zu Wireshark ein schlechter Witz.

    Wenn ich mal den Netzwerkstecker von dem Gerät ziehe und wieder draufstecke dauert es bestimmt 3-4 Sekunden bis die Signale wieder da sind. Also eine "richtigen" Netzwerkfehler gibt es bei diesen Geräten sicher nicht.
    Früher gab es Peitschen .... heute Terminkalender

  3. #23
    Registriert seit
    13.10.2007
    Beiträge
    12.064
    Danke
    2.793
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    Das mit dem Tausch ist leider gar nicht so einfach da wir die MGBs in 2 verschiedenen Varianten haben (linker bzw. rechter Türanschlag) Und natürlich sind 2 linken kaputt ..... Ich warte mal auf das Ersatzteil... dauert ja nur noch 3 Wochen bis es kommt....
    Kannst du nicht trotzdem tauschen, vielleicht kannst du dann den Spieß mit dem Lieferanten
    umdrehen, anscheinend setzt der dich mit Lieferfristen und überprüfungskosten unter Druck.

    Grundsätzlich würde ich über einen Wechsel nachdenken, solche Unkooperative Lieferanten
    kann man im Industrielken Umfeld nicht gebrauchen. Da kostet jeder Ausfall oder Stillstand
    Geld.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  4. #24
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.534
    Danke
    1.152
    Erhielt 1.253 Danke für 982 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Grundsätzlich würde ich über einen Wechsel nachdenken, solche Unkooperative Lieferanten
    kann man im Industrielken Umfeld nicht gebrauchen. Da kostet jeder Ausfall oder Stillstand
    Geld.
    Das Problem ist nur, dass es - meines Wissens - keine Alternative gibt.
    Ich kenne zumindest kein weiteres Schutztürschalter-System mit integrierter Profi-Net-Schnittstelle.

    Wir setzen Pilz PSENsgate ein und der Verdrahtungsaufwand ist grausig.
    Wenn Euchner MGB mechanisch besser zu uneren Schutztüren passen würde, dann hätten wir dieses System im Einsatz.
    Aber dann hätte ich vielleicht die selben Probleme wie Lipperlandstern

    Gruß
    Dieter

  5. #25
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.494
    Danke
    502
    Erhielt 1.145 Danke für 738 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Kannst du nicht trotzdem tauschen, vielleicht kannst du dann den Spieß mit dem Lieferanten
    umdrehen, anscheinend setzt der dich mit Lieferfristen und überprüfungskosten unter Druck.

    Grundsätzlich würde ich über einen Wechsel nachdenken, solche Unkooperative Lieferanten
    kann man im Industrielken Umfeld nicht gebrauchen. Da kostet jeder Ausfall oder Stillstand
    Geld.
    Da hast du recht. Über den Support bin ich mehr als entäuscht. Die Antworten die ich hier bekommen habe hätte ich eigentlich von Euchner erwartet. Ich weiß schon genau was passiert wenn das Ersatzgerät eintrifft : Das funktioniert, ich schicke das defekte zur Überprüfung ein : Ergebnis : Kein Fehler feststellbar... ..

    Ansonsten muss ich Blockmove recht geben. Die Teile sind schon genial....
    Früher gab es Peitschen .... heute Terminkalender

  6. #26
    Registriert seit
    29.03.2004
    Beiträge
    5.797
    Danke
    144
    Erhielt 1.707 Danke für 1.239 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    Wenn ich mal den Netzwerkstecker von dem Gerät ziehe und wieder draufstecke dauert es bestimmt 3-4 Sekunden bis die Signale wieder da sind. Also eine "richtigen" Netzwerkfehler gibt es bei diesen Geräten sicher nicht.
    Ca. 3 Sekunden sind auch meine Erfahrung.
    Datenverfälschungen durch Störungen auf der Leitung, die als gültige Daten von den Partnern angesehen werden sind extrem unwahrscheinlich. Durch die Ethernet-Prüfsumme müssen mindestens 4 Bits bei der Übertragung gekippt sein, sodass die Prüfsumme trotzdem richtig sein könnte (was zudem recht unwahrscheinlich ist).
    Ansonsten wird bei falscher Prüfsumme das Datenpaket verworfen. Wenn zu viele verworfen wurden, bzw. überhaupt keine gültigen Telegramme mehr eintreffen, spricht nach Ablauf der Überwachungszeit der Watchdog-Timer an und der Teilnehmer gilt als gestört.
    Leider lassen sich Ethernet-Prüfsummenfehler mit einer handelsüblichen Netzwerkschnittstelle am PC oder Notebook nicht erfassen.

  7. #27
    Registriert seit
    25.05.2009
    Ort
    Raum Zürich CH
    Beiträge
    85
    Danke
    15
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Meine Antwort ist zwar etwas spät...

    Könnte es vielleicht sein, dass die MGB-Elektronik bewusst dieses Signal "flackern" lässt (So nach dem Motto: Das ist kein Bug, sondern ein Feature)?
    Wenn man ja sonst Sicherheitselemente mit OSSD-Ausgängen hat, dann wird da normalerweise ein Testimpuls generiert um ein Überbrücken der Ausgänge zu erkennen.
    Möglicherweise macht das die MGB-Elektronik mit dem Signal auf dem ProfiNet auch so, damit man weiss, dass das NotAus-Signal plausibel ist.
    Vielleicht ist das in der ProfiNet-Konfiguration einstellbar.

    Gruss SW-Mech

  8. #28
    Registriert seit
    13.10.2007
    Beiträge
    12.064
    Danke
    2.793
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Na ja das eine ist Hardware und soll einen Querschluss ermitteln,
    das andere ist Software, da wird doch wohl kein Querschluss in
    der Profinet Leitung einen Gefährlichen Zustand herbeiführen.

    Da die Auswertung im Schalter selber sitzt, wird da wahrscheinlich
    garnicht getaketet, weil kein Querschluss zu erwarten ist.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  9. #29
    Avatar von Lipperlandstern
    Lipperlandstern ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.494
    Danke
    502
    Erhielt 1.145 Danke für 738 Beiträge

    Standard

    Zitat Zitat von SW-Mech Beitrag anzeigen
    Meine Antwort ist zwar etwas spät...

    Könnte es vielleicht sein, dass die MGB-Elektronik bewusst dieses Signal "flackern" lässt (So nach dem Motto: Das ist kein Bug, sondern ein Feature)?
    Wenn man ja sonst Sicherheitselemente mit OSSD-Ausgängen hat, dann wird da normalerweise ein Testimpuls generiert um ein Überbrücken der Ausgänge zu erkennen.
    Möglicherweise macht das die MGB-Elektronik mit dem Signal auf dem ProfiNet auch so, damit man weiss, dass das NotAus-Signal plausibel ist.
    Vielleicht ist das in der ProfiNet-Konfiguration einstellbar.

    Gruss SW-Mech

    Dann sollte das der Support Wissen und es an allen MGBs auftauchen und nicht nur an zweien
    Früher gab es Peitschen .... heute Terminkalender

  10. #30
    Registriert seit
    25.05.2009
    Ort
    Raum Zürich CH
    Beiträge
    85
    Danke
    15
    Erhielt 15 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Na ja das eine ist Hardware und soll einen Querschluss ermitteln,
    das andere ist Software, da wird doch wohl kein Querschluss in
    der Profinet Leitung einen Gefährlichen Zustand herbeiführen.
    Ja, ist klar: Eine Querschlusserkennung braucht man auf dem ProfiNet nicht. Ich dachte da mehr an sowas wie eine Livebit-Überwachung. Aber wie gesagt, es war nur eine Vermutung.

    @Lipperlandstern
    Der Support sollte das wissen, aber es gibt eben Supporter und Supporter.

    Gruss SW-Mech

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 27.08.2014, 11:09
  2. S7-Safety Sicherheitstür von Euchner Baustein
    Von Krumnix im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 26.05.2014, 11:16
  3. Euchner Sicherheitsschalter an Siemens F-CPU anschliessen und auswerten
    Von Krumnix im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 6
    Letzter Beitrag: 29.03.2013, 09:58
  4. KL2541 - Probleme mit Referenzfahrt, fahren ohne NC, nur mit SPS
    Von PraktikantMarkus im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 16.03.2012, 15:38
  5. Euchner eks key
    Von AlexanderEms im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 01.09.2011, 08:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •