Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 5 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 41

Thema: Strommessung und Temperaturmessung mit S7-1200+Analogsignalgruppe SM 1231 RTD,PT100

  1. #1
    Registriert seit
    08.03.2015
    Ort
    Bad Nauheim
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Idee


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi ihr lieben,

    ich bräuchte eure Hilfe und bedanke mich jetzt schonmal für eure unterstützung, da ich absolut positive erfahrung im Forum gemacht habe.
    Ich will ein kleinen E-Motoren Prüfstand mit einer S7-1200 realisieren. Dazu will ich folgende Werte vom Motor aufnehmen. 2 Temperaturwerte und einmal den Strom.
    Das ganze mache ich für ein kleines Projekt im Betrieb. Ich soll daher alle Komponenten die für den Prüfstand notwendig sind raussuchen und das bestmöglichste konzept staffeln.
    Nach erster recherche weiß ich, dass ich erstmal für die Temperaturmessung die Analogsignalbaugruppe SM1231 RTD brauche um meine PT100 Sensoren anschließen zukönnen.
    Was sich für mich als etwas schwierig ergibt ist die Strommessung für Wechselstrom. Da die S7-1200 2 Analogeingänge besitzt die jeweils ein Eingangsbereich von 0-10V haben.
    Dafür habe ich auf der Siemens-seite diesen Beitrag gefunden: https://support.industry.siemens.com...dti=0&lc=de-DE
    Das erklärt mir zwar ich ein Sensor anschließe, aber (Jetzt meine Frage^^ ) ich weiß nicht wie ich Wechselstrom messen soll.

    Die konkrete Fragestellung ist: Wie kann ich am besten den Strommessen und dann auch am besten in der SPS verwerten?
    Wie verarbeite ich in der S7-1200 die Analogsignale so das sie in bestimmten zeitlichen abständen in eine Tabelle dokumentiert werden, natürlich nachdem diese in brauchbare werte umgewandelt wurden?

    Ich gehmal davon aus das ich sowas brauche wie ein Messumwandler? Mein betreuer meinte aber ein Gleichrichter.
    Und ich denkmal das ich am besten ein galvanisch getrennten Stromsensor nehmen sollte, oder? (Hall Effeckt sensor evtl?)

    Naja ich bin mir da total unsicher , ich freue mich schon auf eure Kommentare.
    Zitieren Zitieren Strommessung und Temperaturmessung mit S7-1200+Analogsignalgruppe SM 1231 RTD,PT100  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.200
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Stromwandler mit integriertem Messumformer
    z.B. Dahms SWMU 41.52/41.51

    Nachtrag
    Google: Stromwandler
    Google: motor stromwandler 20mA

    Harald
    Geändert von PN/DP (08.01.2016 um 11:37 Uhr) Grund: Nachtrag Suchlinks
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    04.11.2013
    Beiträge
    141
    Danke
    12
    Erhielt 25 Danke für 20 Beiträge

    Standard

    Hallo SPS-Praktikantin,

    einige technische Informationen wären noch hilfreich, z.B. welche CPU/FW,welches TIA, welchen Strombereich und wie exakt musst du messen, wird der Motor per FU oder Schütze gesteuert ?
    Siemens gibt die Genauigkeit der integrierten Analogeingänge der 1200er mit 3,5% an, genauer gehts nur mit einem zusätzlichen Analogmodul.

    Strommessumformer wären z. B. Phoenixcontact MCR-S10-50, galvanisch trennender TRMS-Wandler mit konfigurierbarem Analogausgang, auch 0-10V.
    Einfach mal mit Stichwörtern wie AC Messwandler Strommessumformer Analogausgang im Netz suchen.

    Die Messwerte kannst du in der SPS z.B. in ein FIFO schreiben (such mal im Forum nach FIFO). Wie sollen die Messwerte denn angezeigt/ausgewertet werden ?

  4. #4
    Registriert seit
    08.03.2015
    Ort
    Bad Nauheim
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,
    erstmal danke für die schnelle Antwort.
    Technische Daten der SPS:
    S7-1200
    CPU 1212C AC/DC/RLY
    6es7 212-1BE40-0XB0
    S C-F2S83550 2015
    FS:02
    Ich weiß leider nicht welche FW drauf ist. Hab TIA noch nicht installiert. TIA V13.


    Also der Versuchsaufbau sieht wie folgt aus:
    Der Motor ist ein Einphasiger-Niederspannungs-Asynchronmotor der direkt ans Netz angeschlossen wird.(d.h. da ist kein FU.Das ding fährt auf seine Nenndrehzahl hoch und bleibt auch hoffentlich da^^.Datenblätter habe ich mal mit Hochgeladen.) An dem ist eine Vakuumpumpe angeschlossen, die die Last darstellt. Der Unterdruck der Vakuumpumpe soll mithilfe eines Ventils zwischen 0 und -1bar geregelt werden. Wärend dessen sollen an zwei unterschiedlichen Stellen des Motors Temperaturen aufgenommen werden und der Strom natürlich.
    Das ganze soll zunächst erstmal nur von der SPS dokumentiert und anschließend in eine Excel-Tabelle ausgebgen werden. (Das ist momentan nicht das Problem^^).

    Ich hab mir jetzt diese teile rausgesucht für die Strommessung aber was ich nicht verstehe wo der unterschied zwischen den letzten beiden Teilen liegt:
    http://www.distrelec.de/de/stromwand...FRW3GwodCO4HCA
    http://de.rs-online.com/web/p/stromsensoren/0198835/ Bez. AT20 B 10
    http://de.rs-online.com/web/p/stromsensoren/0198841/ Bez. AT5 B 5

    Unteranderem auch das hier gefunden , dass eine zusätzliche Stromversorgung benötigt: http://de.rs-online.com/web/p/stromsensoren/0522020/

    Frage an der Stelle wären dass so die Richtigen Komponenten?

    Falls ja? kann ich diese auch so anklemmen wie in der beschreibung von Siemens selbst? Und macht es ein Unterschied das diese Strommesser eine Spannungsversorgung benötigen oder nicht?
    https://support.industry.siemens.com...dti=0&lc=de-DE


    herzlichen dank schonmal
    Angehängte Grafiken Angehängte Grafiken
    Angehängte Dateien Angehängte Dateien

  5. #5
    Registriert seit
    04.11.2013
    Beiträge
    141
    Danke
    12
    Erhielt 25 Danke für 20 Beiträge

    Standard

    Der Unterschied zwischen den Messwandlern wird klar, wenn man sich auch mal das zugehörige Datenblatt anschaut. Die erste Zahl gibt den Strommessbereich an, die zweite den Spannungsbereich des Analogausgangs.
    Der max. Strom des Motors beträgt 2,4A (siehe dein Datenblatt), warum hast du u. a. einen Stomwandler bis 20A ausgesucht ? Willst du mehrere Messwandler einsetzen ?

    Du solltest dir einige Gedanken zum "Wie" und "Warum" deiner Lösung machen und hier schreiben. Du sollst ja was lernen und nicht nur nach Vorgabe etwas nachbauen.

    Gruß
    Gleichstromer

  6. #6
    Registriert seit
    07.02.2013
    Beiträge
    81
    Danke
    2
    Erhielt 25 Danke für 23 Beiträge

    Standard

    Beachte bei der Strommessung mit Messumformer auch die Ansprechzeit.
    Diese LEM Wandler haben eine Sprungantwort auf 90% bis zu 300ms, d.h. schnelle Stromänderungen (z.B. Anlaufstrom) kannst du nicht genau erfassen.
    Es gibt schnellere Umformer, aber um wirklich alles genau zu messen, müsstest du eine Analog Karte mit +-10V und einen entsprechenden Stromwandler verwenden und die Berechnung des RMS in der SPS selbst programmieren.

    Gruss

  7. #7
    Registriert seit
    08.03.2015
    Ort
    Bad Nauheim
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    @Gleichstromer, Erstmal danke für deine Antwort.
    Ja was das erlernen angeht bemühe ich mich. Es ist nur so das ich von den ganzen Komponenten keine Ahnung habe,was es so auf dem Markt gibt.
    Und ja danke für den Tipp. Ich hab mir folgenden Lösungsansatz überlegt.(Zum "Wie" Und "Warum".) Ich wollte den Lem AT5B10 nehmen und da wir Negative Ströme haben muss ich ja aus dem Negativ berreich raus(da die SPS keine Negativen werte verarbeiten kann). Und deswegen folgende Schaltung dazwischen Klemmen --> siehe Bild.

    Vielen Dank Schmidi für die Info^^. Ich muss gestehen damit bin ich bisschen Überfordert ich werde mir aufjedenfall dazu gedanken machen.

    Eine Frage zum AD-Wandler der S7-1200. Sehe ich das Richtig im Datenblatt das die Analogeingänge eine Auflösung von 10 Bit hat?
    https://support.industry.siemens.com...13683&lc=de-WW
    Angehängte Grafiken Angehängte Grafiken

  8. #8
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Zitat Zitat von SPS-Praktikantin Beitrag anzeigen
    Hi,

    @Gleichstromer, Erstmal danke für deine Antwort.
    Ja was das erlernen angeht bemühe ich mich. Es ist nur so das ich von den ganzen Komponenten keine Ahnung habe,was es so auf dem Markt gibt.
    Und ja danke für den Tipp. Ich hab mir folgenden Lösungsansatz überlegt.(Zum "Wie" Und "Warum".) Ich wollte den Lem AT5B10 nehmen und da wir Negative Ströme haben muss ich ja aus dem Negativ berreich raus(da die SPS keine Negativen werte verarbeiten kann). Und deswegen folgende Schaltung dazwischen Klemmen --> siehe Bild.

    Vielen Dank Schmidi für die Info^^. Ich muss gestehen damit bin ich bisschen Überfordert ich werde mir aufjedenfall dazu gedanken machen.

    Eine Frage zum AD-Wandler der S7-1200. Sehe ich das Richtig im Datenblatt das die Analogeingänge eine Auflösung von 10 Bit hat?
    https://support.industry.siemens.com...13683&lc=de-WW
    Da habe ich eine Frage! Was stellst Du Dir unter einem negativem Strom bei einer Asynchronmaschine vor? Dass diese als Generator läuft mit einer angeschlossenen Vakuumpumpe? Und, wo klemmst Du Deine Schaltung dazwischen?

    Der AD-Wandler kann 10bit inkl. Vorzeichen- sprich daher also 9bit. Ich persönlich verstehe die Angabe allerdings nicht, da die Karte ohnehin nur 0-10V einlesen kann. (also ich habe noch nie eine 1200er in der Hand gehabt, aber schon das Datenblatt schaut nach Murks aus, 10bit??!).

    Im Handbuch
    https://cache.industry.siemens.com/d...e-DE_de-DE.pdf
    steht auf Seite 786 10bit(ohne weitere Vorzeichenangabe- ich halte das für realistischer als die 9bit oben).

  9. #9
    Registriert seit
    08.03.2015
    Ort
    Bad Nauheim
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry wenn ich mich da nicht richtig ausgedrückt habe.

    Also der Asynchronmotor wird ja am Netz angeschlossen 230V/50Hz. Wechselstrom Sinusförmig d.h. ich hab positiven, sowie negativen Strom-/Spannungsverlauf. Da wie erwähnt die Analogeneingänge der S7-1200 nur von 0-10V ausgelegt sind,muss ich ja dafür sorgen das ich in diesem Spannungsbereich bleibe. Hätten die Eingänge -+10V, würde es ja das ganze vereinfachen. Und wenn ich jetzt den Stromsensor von LEM AT5B10 einsetzte wird die Messung wohl oder übel zwischen -5V und +5 V sein. Daher dachte ich mir das ich zwischen SPS und LEM-Sensor die OP-Verstärkerschaltung anschließe um das Signal anzuheben, damit ich aus dem negativen Bereich raus bin. So dass ich den Eingang der SPS verwenden kann.

    Was genau meinst du mit Murks? Also ich hab mit Siemens Support telefoniert, die haben mir auch gesagt nur der Bereich zwischen 0-10V.

    Hab mal im Anhang gezeichnet was ich mir Vorstelle. In meiner Fantasie sollte das funktionieren !!!!

    Also nur mal um zu erläutern wieso ich die Schaltung aufbauen möchte. Wenn ich mir das Datenblatt des Stromsensors von Lem anschaue -->http://www.distrelec.de/Web/Download...lication%2Fpdf
    Sieht man ja auf der zweiten Seite die Schaltung. Im Datenblatt steht oben zwar 0-10V DC Output. Aber wenn ich mir die Schaltung so anschaue, vermute ich mal das bei Wechselstrom es -+10V AC werden. Oder ?
    Angehängte Grafiken Angehängte Grafiken
    Geändert von SPS-Praktikantin (12.01.2016 um 08:27 Uhr)

  10. #10
    Registriert seit
    08.03.2015
    Ort
    Bad Nauheim
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    ich glaub ich hab hier ein denkfehler. Bzw. bin bissi übers Ziel hinausgeschosse.

    Der AT5B10 laut Datenblatt heißt es:
    Split-core transducer for the electronic measurement of AC waveform
    currents, with galvanic isolation between the primary circuit (power)
    and the secondary circuit (measurement). 0-10V DC voltage output
    proportional to the RMS value of the primary current.

    Ich hab mich zu sehr auf die grobe Schaltung konzentriert. Da sieht man nämlich nur eine Spule, daher habe ich mir das ganze mit dem OP-Verstärker ausgedacht. Weil ich dachte, wenn das nur eine Spule ist, kann da nicht nur 0-10V DC rauskommen.

    Kann es sein das im Lem-Sensor da ein Gleichrichter verbaut ist? Wenn ja könnte ich ja praktischerweise das Teil direkt an die SPS anschließen.


Ähnliche Themen

  1. Antworten: 13
    Letzter Beitrag: 11.05.2016, 10:35
  2. Siemens SB 1231 RTD
    Von MareMM im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 28.12.2015, 14:04
  3. s7 1200 - Signalboard 1231 mit PT100 verbinden
    Von B1798 im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 31.05.2015, 00:36
  4. PT100-Temperaturmessung auch ohne 2AI RTD ST?
    Von absoluterbeginner im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 21.11.2012, 13:00
  5. PT 100 an SM 1231 RTD
    Von Hannibal16 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 08.11.2012, 06:54

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •