Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 12 von 12

Thema: Schnelle Regelung und Signalverarbeitung SPS Auswahl

  1. #11
    A_Student ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.10.2017
    Beiträge
    13
    Danke
    7
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich pack mal eine grobe Skizze rein. Der Versuchsaufbau sieht folgender maßen aus. 20171117_164418.jpg

    Ich beschreib mal zunächst die Ausgangssituation spricht im Bild, der obere Aufbau (analog). Der Istwert kommt von einem Magnetostriktiver Sensor, wird direkt auf den Regler geschaltet. Der Sollwert kommt von der S7 400 Station. Die Station hat eine 414-3 DP CPU, die Analogeausgangskarte hat folgende Bestellnummer 432-1HF00-0AB0. Der Regler steuert direkt das Propventil. Ist ein 4/3 Wegeventil, direkt gesteuert. Kann gerne auch mehr Informationen dazu geben bei Bedarf.

    Nun zur Zielsituation. Will den Analogregler durch einen Digitalregler austauschen. Dazu habe ich eine S7 300 Station autarkt aufgebaut. Diese Station dient nur der Regelung, sonst kommt da nichts rein. Die CPU ist wie gesagt eine 317-PN/DP CPU. der Istwert kommt vom gleichen Sensor wie in der Ausgangssituation, direkt in die Analogeeingangskarte. Die Analogeeingangskarte hat folgende Bestellnummer 331-7KF02-0AB0 Hat laut Datenblatt eine Grundwandlungszeit von ca. 20-100ms je nach Einstellung. Der Sollwert kommt wie in der Ausgangssituation von meiner S7400 Station. Der Sollwert wird ebenfalls auf die Analogeeingangskarte der S7300 Station geschaltet. Also fassen wir zusammen Sollwert und Istwert kommen extern auf die Analogeeingangskarte. Stellwert wird auf ein Wago Modul per Profibus geschaltet, bzw. wird das Propventil von einer Wago Modul Karte gesteuert. 750-632 die ist extra für Propventile gedacht. Diese Karte ist per Profibus DP (Profibus DP Mastersystem) mit der S7 300 Station gekoppelt. Die Länge des Kabels beträgt keine 30cm.

    Wie gesagt aktuell reagiert das System viel zu langsam, deshalb wollte ich vorerst meine Analogeeingangskarte durch eine deutlich schnellere ausstauschen. So einer Highspeed Karte die eine Grundwandlungszeit von 52 µs hat.
    Ich hoffe mal das die Kommunikation zwischen der Wago Karte und der S7 Station schnell genug ist bzw der Profibus mir keine Probleme macht und die Latenzzeit der Wago Karte mir auch keine Probleme macht. Ich gehe nämlich stark davon aus, dass die Analogeeingangskarte an die starke Verzögerung Schuld ist.

    Der Regler wird im OB35 aufgerufen. Eine Zykluszeit von 1 MS wurde in der Hardwarekonfiguration eingestellt.

    Ein Paar Bilder zum Programm selber.
    OB35a.jpgOB35b.jpgOB35c.jpgOB35d.jpg
    Geändert von A_Student (Heute um 17:22 Uhr)

  2. #12
    Registriert seit
    25.02.2016
    Beiträge
    260
    Danke
    16
    Erhielt 45 Danke für 42 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Student,

    da hätte ich noch Ein Paar Fragen hast du die nicht verwendeten in der Hardware deaktiviert? Hast du die Rauschunterdrückung auch komplett deaktiviert in der Hardwarekonfiguration?

    Wie übergibst du denn wert an die Wagobaugruppe? Im Bild sieht Mann nur das du ein Merwort beschreibst.
    Hier wäre mal die Ditherfrequenz und normale Pwm Frequenz anschauen diese Werte wenn nicht sauber passen sind Propventile echt fast unbehärschbar.
    Was ich noch prüfen würde du descalierst den Wert für die Wago per Fc106 der Skaliert den Wert auf 0 bis 27648 bist du dir sicher das die wago Karte den Wert richtig versrbeitet ? Auf die Schnelle habe ich gar nix gefunden
    Was evtl noch ein Versuch wäre ich habe bei uns mal einen Startoffset eingeführt hier wird ein Offset ausgemessen wo sich die Achse gerade bewegt so kannst du deine Strecke evtl etwas verbessern.
    ausserdem weißt du ob evtl dein Ventil eine Linearekennline hat wahrscheinlich nicht evtl wäre hier noch ein Ansatzpunkt diese Kennlinie zu linearesieren.

    Noch ne frage welche Fehler Ob’s hast du geladen bzw hast du evtl. Sporadisch Einträge in den Diagnose Puffer? Ich muss sagen das ich mir fast nicht vorstellen kann das auch eine 317 1 ms im Ob Interrupt Schaft.

    ich würd sagen hier gibt es noch viel zu Probieren welchen analogen Regler hattest du? Gibt es hier evtl noch Datenblätter bzw Parameter?

    Mit freundlichen Grüßen Tia

Ähnliche Themen

  1. Sehr Schnelle Regelung -> Steuerungskonzept
    Von plc_typ im Forum CODESYS und IEC61131
    Antworten: 28
    Letzter Beitrag: 15.02.2017, 20:53
  2. Antworten: 1
    Letzter Beitrag: 10.01.2017, 11:51
  3. Antworten: 13
    Letzter Beitrag: 02.09.2016, 16:31
  4. Phasenverschiebung in DB schreiben - schnelle Regelung
    Von SPS-newbie im Forum Programmierstrategien
    Antworten: 7
    Letzter Beitrag: 12.05.2010, 11:49
  5. Schnelle Regelung mit SIMATIC?
    Von Olav im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 25.10.2006, 14:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •