Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Will die Bits flitzen sehen

  1. #1
    Registriert seit
    04.01.2006
    Beiträge
    152
    Danke
    20
    Erhielt 31 Danke für 29 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich möchte mir die Daten, die über eine serielle 485 (2 Draht) Verbindung laufen, einmal ansehen.
    Eine Oszilloskop habe ich in einer Ecke gefunden (bin seit 14 Jahren in der Firma und habe das Ding noch nie benutzt). Weiß jemand wo es Anleitungen gibt wie man Messtechnisch an die Sache ran gehen muß ?
    Das letzte mal das ich ein Oszilloskop benutzt habe, war während meiner Ausbildung in den 80er Jahren.
    Und da waren es auch nur einfache Spannungen in simplen Schaltungen.

    Oder hat jemand vielleicht sonst noch eine Idee wie ich den tatsächlichen Datenverkehr analysieren kann ?

    Jens
    Zitieren Zitieren Will die Bits flitzen sehen  

  2. #2
    Registriert seit
    25.04.2005
    Beiträge
    98
    Danke
    19
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Hallo,
    schau mal :
    http://de.wikipedia.org/wiki/Oszilloskop

    unten sind auch ein paar links zu Simulationen.
    mfg max

  3. #3
    Avatar von Jens_Ohm
    Jens_Ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.01.2006
    Beiträge
    152
    Danke
    20
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Schöne Seiten, danke.
    Aber ich meinte mehr, was muß ich beachten wenn ich ein RS485 Signal abtasten möchte. Welche freqenzen, Spannungen etc. sind zu erwarten.
    Ich habe da leider einige Defizite was Schnittstellen, und Signalübertragungen angeht. Leider hab ich erst seit ca. 1 Jahr damit zu tun und meist funktionerts ja und um das wie brauch ich mir keinen Kopf zu machen. Jetzt haben wir 30 Regler (RS485 Modbus) die wir einmal als komplettes RS485 Netzwerk (2 Draht) über einen Rs485/232 Wandler an einen PC weitergeben und ein anderes Mal die Regler in dreier Gruppen (485) an jeweils einen RS485/Ethernet-Konverter zum Router zum PC verbinden. Klappt soweit gut. Aber nach X-Stunden(auch mal weniger) habe ich Störungen auf dem BUS (in beiden Versionen).
    Vieleicht liegts an der 485 Terminierung (jeder den ich gefragt habe, gibt mir eine andere Antwort bezüglich der Position, Anzahl und Wertigkeit der Terminierung.) Aber vieleicht liegt der Knackpunkt auch wo ganz Anders. Im Moment weiß ich nicht so recht weiter und kram das Oszi raus, obs was bringt ? (zumindest erfahrung)

    grüsse aus Bielefeld und schönes Wochenende

    Jens
    Zitieren Zitieren Danke Max  

  4. #4
    Registriert seit
    02.04.2006
    Ort
    nähe Muc
    Beiträge
    2.787
    Danke
    115
    Erhielt 126 Danke für 107 Beiträge

    Standard

    Zapf lieber ie Daten ab und Logge sie mit einen Rechner mit.

    Das Messen hilft dir ja nichts wenn du gar nicht weisst was du Messen willst und was für einen Fehler du hast.

    Es kann ja auch mal sein das falsch gesendet oder flasch empfangen wird.


    Die Einstellung des Oszis entnimmst du den Kommunikationsdaten.
    Stell 2V pro Kästchen ein, dann ist dein Signal 2,5 Kästchen gross.

    Je nach Baud stellst du dann die Zeit ein bis du irgendwas erkennen kannst.

    Bei hohen Mbits wirst du da aber nimemr viel sehen
    ___________________________________________





    Sende eine SMS mit dem Stichwort "Feuer" an die 112 und innerhalb von 10 Minuten steht ein roter Partybus mit derbem Sound vor deiner Tür.


    AGB: Wer Rechtschreibfehler findet darf diese behalten. Bitte meine in eile gefertigten, selten anfallenden Vertipsler zu entschuldigen.

  5. #5
    Avatar von Jens_Ohm
    Jens_Ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.01.2006
    Beiträge
    152
    Danke
    20
    Erhielt 31 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Allen erstmal vielen Dank


    Wir haben den Fehler offensichtlich gefunden (natürlich ohne Oszi).
    Es lag wohl an den Einstellungen. Mit der Einstellung 2 Stopbits läufts anscheinend Problemlos.
    Aber das ist wieder der Unterschied Theorie und Praxis.
    Theorie ist wenn man weiss wies geht aber nix funktioniert
    Praxis ist wenn alles funktioniert und keiner weiss warum
    )))
    Aber Spass beiseite. Den Fehler haben wir also nur durch ausprobieren beseitigen können.
    Wie geht denn der Profi an Probleme mit der Datenübertragung (Seriell) ?
    Immerhin trat das Fehlverhalten ja unter Laborbedingungen und nicht erst im Feld auf.


    Jens
    Zitieren Zitieren wir haben den Fehler warscheinlich gefunden, aber...  

Ähnliche Themen

  1. PAW Bits
    Von zloyduh im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 04.04.2011, 09:35
  2. Antworten: 5
    Letzter Beitrag: 15.10.2010, 07:26
  3. S7 200 Bibliothek öffnen um code zu sehen
    Von cozmik im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 07.10.2008, 09:56
  4. Bits in temporäres Byte mappen und gesetzte Bits zählen
    Von yetibrain im Forum PC- und Netzwerktechnik
    Antworten: 3
    Letzter Beitrag: 19.02.2005, 16:31

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •