Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 6 of 6

Thread: MicroMaster 440 und Profibus

  1. #1
    Join Date
    14.06.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,
    hab mal wieder so meine problemchen... ich hab eine profibuskarte cp 342-5 und einen mm4. zuerst hab ich dem mm4 eine adresse (über dip-schalter) gegeben und eine kommunikation hergestellt. leider geht bei mir die cpu immer wieder auf sammelfehler. wenn ich im baugruppenzustand nachsehe heisst es:

    peripherie-zugriffsfehler, lesend

    wenn ich dann bei den details nachschaue, heisst es weiter, dass ich auf die zugriffsadresse 15 nicht zugreifen kann, obwohl das die eingangsadresse des mm4 ist...

    hiiiilfe
    Reply With Quote Reply With Quote MicroMaster 440 und Profibus  

  2. #2
    Join Date
    06.10.2003
    Posts
    4,517
    Danke
    626
    Erhielt 787 Danke für 616 Beiträge

    Default

    Hallo Roland,

    vielleicht hast du im Programm oder an den Dipschaltern ein Verwechslungsfehler hexdezimal-dezimal?


    Gruß, Onkel
    Reply With Quote Reply With Quote hexdezimal-dezimal  

  3. #3
    Roland is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.06.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    welche dippschalter meinst du? die beim mm4? wenn ich in der diagnose nachsehe, dann erkennt er die richtige adresse. was mich einfach wundert ist, dass ich quasi nicht auf die eingangswörter zugreifen kann...

  4. #4
    Roland is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.06.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    vielleicht ist die genau fehler beschreibung vom diagnosepuffer hilfreich:

    peripherie-zugriffsfehler, schreibend
    p-bereich, wortzugriff, zugriffsadresse 5 // steht p-bereich für pointer?
    .
    .
    .
    externer fehler

  5. #5
    Join Date
    06.10.2003
    Posts
    4,517
    Danke
    626
    Erhielt 787 Danke für 616 Beiträge

    Default

    Hallo Roland,

    p-bereich steht sicherlich für Peripheriebereich. Was vermutlich den Fehler auslöst ist die Adresse 5. Versuche es doch mal mit einer geraden Adresse!


    Gruß, Onkel
    Reply With Quote Reply With Quote gerade Adresse?  

  6. #6
    Roland is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.06.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,

    ich hab den fehler gefunden!! zuerst hab ich es mit der gerade adresse versucht... ich hab aber quasi die gleiche meldung erhalten. der fehler lag darin, dass ich eine externe profibus-schnittstelle verwendet habe und ich somit nicht direkt auf den e/a-datenbereich der slaves zugreifen konnte, dh ich musste zwei bibliotheksbausteine (dp_send und dp_recv) einfügen und dann mithilfe eines any-pointers auf datenbausteine zugreifen. ich zuvor zwei db erstellt, einer für die eingangsadressen (db101) und einen für die ausgangsadressen (db102). wenn ich dann beispielsweise auf den eingang e0.0 eines slaves zugreifen wollte, musste ich db100.dbx 0.0 verwenden...

Similar Threads

  1. Micromaster 440
    By buchi2 in forum Antriebstechnik
    Replies: 3
    Last Post: 31.07.2019, 21:49
  2. Micromaster Vector in Micromaster 440 ändern
    By knabi in forum Antriebstechnik
    Replies: 6
    Last Post: 20.09.2018, 08:19
  3. MicroMaster 440
    By Lipperlandstern in forum Antriebstechnik
    Replies: 9
    Last Post: 19.08.2010, 07:37
  4. Profibus und MM 440
    By nafets83 in forum Feldbusse
    Replies: 1
    Last Post: 30.01.2008, 18:15
  5. Micromaster 420/440 an Profibus
    By Anonymous in forum Feldbusse
    Replies: 1
    Last Post: 28.09.2004, 19:56

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •