Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 8 of 8

Thread: 314 IFm mit CP342-5 und 315-2DP über profibus koppeln

  1. #1
    Join Date
    06.08.2004
    Posts
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo ich habe folgendes Problem,
    für Ausbildungszwecke möchte ich eine 314IFM mit CP342-5 und eine 315 2DP über Profibus koppeln.
    Die 315 soll Master sein, die 314 Slave. In die 314 habe ich die beiden FC's (DP-SEND und DP-RECV ) eingetragen. Wie funktioniert der Datenempfang/- senden im Master? Beispeil von Siemens Nr. 6519580 schweigt sich darüber aus?

    Umgekehrt 314IFM mit CP 342-5 als Master und 3152DP als Slave habe ich die gleichen Probleme. Busverbindung steht(keine Fehlermeldung), Datenaustausch läuft nicht. (Siemens-Bsp. Nr.651893

    Vielleicht hat jemand ein kurzes Listing für Datenaustausch von jeweils einem Byte. Die Funktion der FC's sind klar da ich zwei 314 mit CP342-5 erfolgreich gekoppelt habe.
    Reply With Quote Reply With Quote 314 IFm mit CP342-5 und 315-2DP über profibus koppeln  

  2. #2
    Join Date
    27.05.2004
    Location
    Thüringen/Berlin
    Posts
    13,867
    Danke
    763
    Erhielt 3,162 Danke für 2,249 Beiträge

    Default

    Die Send- /Recive-Bausteine benutzt du nur auf der 314 mit CP.
    In der 315-2DP mußt du in der Hardware-Konfig aus dem Zweig Profibus-DP/bereits projektierte Stationen/S7-300 CP 342-5 DP die richtige CP auswählen und in dein Profibusnetz der 315 einfügen (Geht am Besten, wenn beide CPU's in einem Projekt liegen !!!). Dort kannst du den E/A-Bereich festlegen, auf dem deine Daten liegen sollen. Bei der 314 legst du den EA-Beireich an den Send- /Recive-Bausteinen als Parameter fest.

    Gruß Ralle!

  3. #3
    lernender is offline Neuer Benutzer
    Themenstarter
    Join Date
    06.08.2004
    Posts
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Danke erst einmal für die schnelle Reaktion. Trotzdem kommt noch kein Datenaustausch zu stande. Habe in der Konfiguration für die 315 (Slave) A0 als Ausgang (1 Byte) und E0 als Eingang (1 Byte) und für den DP partner das gleiche festgelegt., so dass der slave von A0 auf e0 (master) sendet und vom Master E0 auf A0 des Slave empfängt. In der 314 habe ich DP SEND die Sendeadresse auf p#a0.0 byte 1 gestellt und im DP REC die Empfangsadresse auf p#e0.0 byte 1.
    Im Master arbeite ich mit Verschiebebefehl (MOVE) bzw L und T (AWL)
    L EB 0
    T MB60
    zum Empfang der daten und
    L EB4 (DI/DO-Baugruppe auf Steckplatz 5)
    T AB0
    (auf Steckplatz 4 ist eine AI/AO)

    was mache ich falsch?
    Reply With Quote Reply With Quote trotzdem noch keine Daten  

  4. #4
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default

    Stell mal Deine DP_Send un Receive mit CP Ladeadresse etc. hier ein.

    Gruß
    Ralf

  5. #5
    Join Date
    27.05.2004
    Location
    Thüringen/Berlin
    Posts
    13,867
    Danke
    763
    Erhielt 3,162 Danke für 2,249 Beiträge

    Default

    Hast du den Slave auch eingekoppelt ? (3 Reiter des DP-Slave in der Hardware-Konfig der 315).

  6. #6
    Join Date
    23.12.2003
    Posts
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    hallo Lehrnender
    wenn du eine Email angibts könnte ich dir ein Beispielprojekt zusenden !!

    Gruss

    Joker
    Reply With Quote Reply With Quote CPU mit Externer CP  

  7. #7
    Join Date
    29.08.2003
    Posts
    221
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Default

    Moin

    ich wäre dir Dankbar wenn du das Beispiel hier Posten würdest dann hätten alle was davon


    MfG Balou
    So wie das Eisen außer gebrauch rostet und das stillstehende Wasser verdirbt oder bei Kälte gefriert, so verkommt der Geist ohne Übung.

  8. #8
    lernender is offline Neuer Benutzer
    Themenstarter
    Join Date
    06.08.2004
    Posts
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, danke für eure schnelle Reaktion.

    1. Hier meine Email : schmidt_v.@web.de
    2. gekoppelt habe ich die SPS (ist als gekoppelt eingetragen )
    3. Hier mein DP SEND
    CALL "DP_SEND"
    CPLADDR:=W#16#100
    SEND :=P#A 0.0 BYTE 1
    DONE :=M90.0
    ERROR :=M90.1
    STATUS :=MW92
    4. Hier der DP RECV
    CALL "DP_RECV"
    CPLADDR :=W#16#100
    RECV :=P#E 0.0 BYTE 1
    NDR :=M100.0
    ERROR :=M100.1
    STATUS :=MW102
    DPSTATUS:=MB104
    der CP sitzt auf Steckplatz 4 (gleich hinter der 314IFM)

    Ich hoffe ihr könnt damit etwas anfangen

    Viele Grüße

    lernender

Similar Threads

  1. Replies: 2
    Last Post: 09.04.2013, 09:13
  2. Replies: 2
    Last Post: 13.07.2009, 14:14
  3. Replies: 0
    Last Post: 05.07.2009, 15:40
  4. Replies: 4
    Last Post: 21.02.2006, 15:54
  5. Master Slave Verbindung mit CP342-5 und 315 2DP
    By Anonymous in forum Simatic
    Replies: 12
    Last Post: 11.04.2005, 11:33

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •