Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: PCS7->HMI-S7-400 über MPI

  1. #1
    Registriert seit
    27.01.2006
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen zusammen,

    habe da ein kleine Verständnisproblem mit unserer MPI Verbindung und hoffe dass ihr mir weiterhelfen könnt.

    Haben folgende Konfig...
    PCS7 Multiprojekt mit mehreren CPU 417H . Eine von diesem CPU ist unsere, -->417H mit einem Profibusstrang und einem MPI Strang.
    An diesem MPI-Bus hängt nur ein TP177A(MPI Adresse 4) mit flexible 2005sp1. Die CPU hat die MPI-Adresse 2.

    Laut Kunde sollte die Kommunikation auch dann klappen wenn die HMI-Station(MPI-Adresse 4) nicht im PCS7-Projekt eingebunden ist.
    Klappt aber nicht!!!

    Und bevor ich nun meinen Vorschlag dem Kunden preisgebe , wollt ich mal eure Meinung hören

    Mein Gedanke ist nun folgender:
    Da ich im PCS7-Projekt keine HMI-Station einbinden kann(habe ich nicht zur Auswahl), würde ich nun hingehen und eine "Andere Station" einfügen und dieser die MPI-Adresse 4 zuweisen.
    Dann sollte doch die Kommunikation funktionieren, oder??

    Danke im voraus
    Zitieren Zitieren PCS7->HMI-S7-400 über MPI  

  2. #2
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    wenn ein TP an einem MPI Netz angeschlossen ist, und er hat eine
    eindeutige Adresse, und die CPU auch, dann greift er auf die projektierte
    Variablen über MPI zu. Normalerweise ist es egal, ob der TP in der Konfiguration ist oder nicht, er weiss das ja gar nicht; er stellt Anfragen an die CPU Adresse, und wenn da die Datenbereiche auch liegen, dann passt es ja. Könnte sein, dass es etwas ganz neues gibt, und ich habe Unrecht, aber ich denke es ist schon so.
    S7 Verbindungsressourcen der CPU wären noch frei, oder?

    Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren TP an MPI  

  3. #3
    Tito ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.01.2006
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    danke ermal für deine Antwort.

    Also im meinem Fall haben die Teilnehmer eine feste Adresse.
    Einstellungen CPU:
    MPI-Adresse =2
    Rack =0
    Steckplatz =3
    Übertragungsrate =187,5
    Highest MPI-adress =31

    Einstellungen TP:
    MPI-Adresse =4
    Übertragungsrate =187,5
    Highest MPI-adress =31





    Mein konkreter Fall sieht so aus:
    Es werden über Profibus, Daten eingelesen= Eingangswörter EW400,402,404...usw.Diese werden im Programm weiterverarbeitet.

    Mit dem TP greife ich direkt auf diese EW400,402..zu.
    Über Verbindung1 im HMI.

    Was meinst du genau mit Verbindungsresourcen?

    Vieleicht liegt es auch an der Kabelverbindung. Wie kann ich auf einfachsten Weg feststellen ob die MPI-Verbindung steht.?
    Kann ich mich mit dem PG auf die MPI-Schnittstelle der CPU hängen?
    Normalerweise soll man bei PCS7 alles über die ES machen, nur dafür muss ich meine Station im Projekt einbinden

    gruß tino

  4. #4
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Zitat Zitat von Tito Beitrag anzeigen
    Hallo,
    Einstellungen CPU:
    MPI-Adresse =2
    Rack =0
    Steckplatz =3
    Übertragungsrate =187,5
    Highest MPI-adress =31

    Einstellungen TP:
    MPI-Adresse =4
    Übertragungsrate =187,5
    Highest MPI-adress =31
    Steckplatz 3 für die CPU??? ...eigentlich 2. Sonst ist OK.
    Das mit dem PCS7/ES usw.: glaub nicht, dass das relevant ist. TPs können auf einer CPU auch ohne PCS7 zugreifen.

    Hast du überhaupt keine MPI Verbindung, oder fehlen nur die Daten?

    Sag mal, hast du "normale" CPU oder eine PC Station(PCS7 Box)?

    Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Mpi->tp  

  5. #5
    Registriert seit
    01.03.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Tito,

    normalerweise ist es nicht notwendig das HMI in PCS7 bekannt zu machen.

    Selbstverständlich kannst Du dich mit einem PG auf die MPI-Schnittstelle stecken. Versuche dort in PG/PC-Schnittstelle die erreichbaren Teilnehmer zu lesen. Es sollte sich das PG, die S7, evtl. gesteckte CP's und das HMI melden.

    Bei der Vergabe der MPI-Adressen für das HMI musst du berücksichtigen, dass jeder gesteckte CP eine MPI-Adresse hat. Diese wird normalerweise von der CPU-Adresse aus weiter gezählt, bedeutet wenn die CPU-MPI = 2, 1. CP erhält Adr. 3, 2. CP erhält Adr. 4 usw.

    Überprüfe ob die HMI-Schnittstelle tatsächlich auf MPI steht. Bei einigen OP's muß das Protokoll über DIP-Schalter eingestellt werden.

    Ich hatte allerdings mit Flexible schon mal das Problem, dass die CPU die Verbindung nicht aufgebaut hat, weil keine Verbindung projektiert war. Bei ProTool kenne ich das Problem nicht.

    @vladi
    Wenn bei einer S7-400 ein 10A oder 20A Netzteil gesteckt wird, verschiebt sich aufgrund der Baubreite des Netzteil der Steckplatz der CPU auf Steckplatz 3 bzw. 4.

  6. #6
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Zitat Zitat von Parz Beitrag anzeigen
    Bei der Vergabe der MPI-Adressen für das HMI musst du berücksichtigen, dass jeder gesteckte CP eine MPI-Adresse hat. Diese wird normalerweise von der CPU-Adresse aus weiter gezählt, bedeutet wenn die CPU-MPI = 2, 1. CP erhält Adr. 3, 2. CP erhält Adr. 4 usw.
    Bei S7-300 ja. Bei S7-400 nein.
    Jesper M. Pedersen

  7. #7
    Registriert seit
    01.03.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @JesperMP

    Stimmt natürlich.

Ähnliche Themen

  1. S7 300 an PCS7 V7.1
    Von IPC Bernhard im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 02.03.2011, 14:46
  2. Pcs7 v7.0 sp2
    Von DerWeiseMeister im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.10.2010, 15:54
  3. FB3 PULSEGENERATOR in PCS7
    Von Tippfejler im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 30.06.2009, 18:17
  4. Pcs7
    Von Bender25 im Forum HMI
    Antworten: 5
    Letzter Beitrag: 08.12.2008, 11:03
  5. PCS7 und CFC
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 28.08.2005, 23:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •