Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: CP 342-5 Neuling am Profibus

  1. #1
    Registriert seit
    10.01.2007
    Beiträge
    45
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Morjens erstmal,
    Vorweg muss ich sagen, dass ich absoluter Profibus-Neuling bin.

    In meiner SPS gibt es einen CP 342-5 als Slave der von einem DP-Master ein einzelnes BIT (Freigabe_zum_Betrieb = 1; gesperrt = 0) erhalten soll.

    In der HW-konfig ist alles eingestellt und auch in die CPU übertragen worden.

    Leider hab ich noch keine Ahnung wie ich jetzt an ein einzelnes BIT komme welches vom Master übertragen wurde. Denn wenn ich die, vom System vergebenen, E/A Adressen wie normale Ein- Ausgänge benutze (Tip vom Betreiber des DP-Master) läßt die CPU_314 ein Laden des entsprechenden Bausteins nicht zu. (CP342-5 E/A 28. Die CPU314 versteht aber nur max EW128 wenn ich mich nicht irre. Demnach kann ein programmierter Eingang auf E288.0 nicht funktionieren. Hab auch schon versucht die DP E/A´s in einen Bereich unterhalb der EW128 zu schieben, da gabs dann Probleme mit dem Prozessabbild.

    Wenn jemand mir erklären könnte wie ich die Sache richtig angehe und an diese einzelne Bit komme... nur her damit... und vielen Dank.

    MfG
    PCE-5Smp
    Die Intelligenz eines Menschen misst sich an seinen Fragen! ........ häääää?
    Zitieren Zitieren CP 342-5 Neuling am Profibus  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Es gibt in der Standard-Library dafür Bausteine (FC1/FC2), mit denen mußt du die Daten zur CP schicken, bzw, von ihr holen. Schau dir mal die Hilfe zu den Bausteinen an, richte dir einen DB für Send/Receive ein und verdrahte die Bausteine entsprechend.

    Code:
           CALL  "DP_RECV"
           CPLADDR :=W#16#120
           RECV    :="Koppel-DB".Receive_Modul
           NDR     :=#DP_NDR
           ERROR   :=#DP_Error_70
           STATUS  :=#DP_Status_70
           DPSTATUS:=#DP_DPStatus
        
    
          CALL  "DP_SEND"
           CPLADDR:=W#16#120
           SEND   :="Koppel-DB".Send_Modul
           DONE   :=#DP_Done
           ERROR  :=#DP_Error_71
           STATUS :=#DP_Status_71
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Registriert seit
    10.01.2007
    Beiträge
    45
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Danke für die Hilfe,

    damit sollte es klappen.

    Letzte Frage (hoffentlich):
    Wo nehme ich die "Logische Basisadresse" des CP her, HW-Konfig gibt mir darüber keine Auskunft und die Step-Hilfe hat dafür auch keinen Rat.

    MfG
    PCE-5Smp
    Die Intelligenz eines Menschen misst sich an seinen Fragen! ........ häääää?

  4. #4
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    58
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Hi,

    du musst die Adresse auf dem Bild (natürlich nicht immer 272!!)als HEX-Wert angeben:




    Gruß

    Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  5. #5
    Registriert seit
    10.01.2007
    Beiträge
    45
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Jo, genau das hab ich gesucht.

    Vielen Dank... bei mir ist die EA 304 ... also in Hex 130

    Endlich hab ichs gerafft.
    Die Intelligenz eines Menschen misst sich an seinen Fragen! ........ häääää?

  6. #6
    Registriert seit
    20.04.2010
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,
    ich habe ein vergleichbares Problem wie der PCE-5Smp. Ich muss eine SPS mit der CPU 313C an einen Profibus hängen und damit Daten an einen Kukaroboter senden. Habe als Profibusadapter den 342-5 SPS-seitig ran gehängt. Habe die Einstellungen, wie oben beschrieben, alle vorgenommen und die Bausteine RECV/SEND eingebunden. Der 342-5 ist im Slavebetrieb, da der Kuka den Master im System spielt.
    Problem:
    Kann bisher jedoch auf dem Kuka nichts empfangen.

  7. #7
    Registriert seit
    27.07.2007
    Beiträge
    223
    Danke
    17
    Erhielt 42 Danke für 40 Beiträge

    Standard

    Aus welchem tiefen Loch hast du denn den Beitrag ausgegraben?

    Nun zu deiner Frage:
    Zeigt der Statusausgang der Send/Receive Bausteine eine Fehlernummer an?

  8. #8
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Mischl Beitrag anzeigen
    Ich muss eine SPS mit der CPU 313C an einen Profibus hängen und damit Daten an einen Kukaroboter senden. Habe als Profibusadapter den 342-5 SPS-seitig ran gehängt. Habe die Einstellungen, wie oben beschrieben, alle vorgenommen und die Bausteine RECV/SEND eingebunden. Der 342-5 ist im Slavebetrieb, da der Kuka den Master im System spielt.
    Sieh mal hier, du solltest Mona kennen lernen, oder kennt ihr euch etwa schon (lange)?

    Grüße von HaDi

Ähnliche Themen

  1. Schaltschrank Neuling
    Von LeNac im Forum Schaltschrankbau
    Antworten: 1
    Letzter Beitrag: 06.07.2011, 20:11
  2. Ein Neuling...
    Von Gerhard2 im Forum Stammtisch
    Antworten: 11
    Letzter Beitrag: 25.05.2009, 18:21
  3. Neuling in DP/DP
    Von Jelly im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 17.04.2007, 08:43
  4. Neuling
    Von Mahmut im Forum Stammtisch
    Antworten: 6
    Letzter Beitrag: 12.01.2007, 13:54
  5. Neuling Profibus
    Von Anonymous im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 11.02.2004, 12:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •