Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Probleme mit Slavenummer und Beckhoff-Master

  1. #1
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe hier eine Profibus-Klemme EL6731 und versuche zum ersten Mal einen Slave anzusprechen. Leider lässt sich die Slave-Adresse nicht ändern. Kann mir da jemand helfen?
    Zitieren Zitieren Probleme mit Slavenummer und Beckhoff-Master  

  2. #2
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Was meinst du mit "Slaveadresse ändern"? Was für Slaves sind dran?
    Haste eine automatisch Erkennung via System Manager durchgeführt?

    Ich hab bisher die Slaveadresse immer nur direkt am Slave eingestellt.
    Wenn die zum Salve passende GSD-Datei im TwinCAT-Ordner "TwinCAT\Io\Profibus" vorhanden ist, wird der Salve samt Adresse eigentlich automatisch erkannt.

  3. #3
    drfunfrock ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Also der Slave ist ein RFID-Lesegerät von Baumer und ich möchte die Stationsnummer ändern (Das sollte die Slaveadr sein?) und genau das funktioniert nicht. Ich habe das Lesegerät automatisch erkennen lassen und das klappte recht gut, nur im RunMode zeigt mit die Profibus-Klemme an, dass etwas falsch läuft, in dem die BF-Led ständig rot leuchtet.

  4. #4
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Die Stationsnummer ist die Salve-Adresse.
    Erlaub das Lesegerät denn überhaupt, die Adresse vom Master aus zu ändern?
    Wenn die Adresse am Slave mittels Schalter eingestellt werden kann, tippe ich mal, dürfte das nicht gehen.

    Aber du weißt nicht mit Sicherheit, dass es an der Adresse liegt? Busfehler kann ja auch z. B. durch die Verkabelung kommen.
    Bei der EL6731 sonst alles i.O.? Baudrate korrekt? Den Karteireiter "EL6731" im System Manager komplett durchgeforstet? Was zeigt die Registerkarte "Box States"?

    Haste zur Not nen anderen Profibus-DP-Salve zum Testen da?

  5. #5
    drfunfrock ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Ja die Slave-Adr soll vom Master aus geändert werden können. Aber ich habe wohl noch andere Probleme. Notfalls kann ich die Adr. auch über den RS232 setzen.

  6. #6
    drfunfrock ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    So die Slave-Adr kann über Profibus DB V2 gesetzt werden, aber ... die GSD-Datei gibt das nicht frei, so dass ich im Master der Klemme EL6731 das nicht setzen kann. Weiss jemand wie man das macht?

    Dann habe ich immer noch das Problem, dass im Free-Run-Modus, kein Fehler angezeigt wird, im Run-Modus aber schon und ich bekomme die folgenden Erklärungen für blinkenden Leds im Run-Mode:

    1) DP-Master in STOP mode

    2) State of the EtherCAT State Machine:
    PREOP = Setting for mailbox communication and variant standard settings


    Nur Fehlermeldung bekomme ich keine im System Manager.

  7. #7
    drfunfrock ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Das Problem hatte sich gelöst, als ich versuchte die Statusregister in einem Programm auszulesen. Offenbar benötigt die Profibus-Masterklemme irgendwie den RUN-Zustand, um den Zustand OK zu signalisieren. So etwas kann einen wirklich zur Verzeiflung treiben.
    Zitieren Zitieren Problem gelöst  

  8. #8
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Also der EtherCAT benötigt generell eine "Trigger-Task". Ohne die werden keine Prozessdaten abgerufen. Anders im Konfig-Mode. Dort wird der Bus mit der Free-Run-Zykluszeit getriggert.
    Also du musst von irgend einer EtherCAT-Klemme im Run-Mode mindestens eine Verknüpfung zu einer Task haben (SPS-Programm oder "zusätzliche Task", etc.).
    Das Abrufen eines Statusworts ist z.B. einer Prozessdatenverknüpfung

  9. #9
    drfunfrock ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Nein mit Ethercat habe ich solche Probleme nicht. Ich kann den Bus um FreeRun.Modus checken und weiss dann, der er läuft. Bei dieser Profibus-Master-Klemme muss ich wirklich erst eine Veknüpfung aufbauen und hoffen es geht. Wenn nicht, habe ich irgendetwas falsch konfiguriert oder das Profibus-Gerät ist mal wieder abgestürzt. Kann natürlich auch einzig an diesem elenden RFID-Lesegerät liegen. Ach ja, Dokumentation von deutschen Firmen sind häufig nur der Versuch, ein Produkt kompliziert aussehen zu lassen und dank der vielen Doku-Fehler dass ganze unverständlich zu machen. So ist es mir jedenfalls bei diesem Lesegerät ergangen.

  10. #10
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von drfunfrock Beitrag anzeigen
    Ich kann den Bus um FreeRun.Modus checken und weiss dann, der er läuft. Bei dieser Profibus-Master-Klemme muss ich wirklich erst eine Veknüpfung aufbauen und hoffen es geht.
    Genau weiß ich es jetzt nicht. Aber ich könnte mir vorstellen, dass ähnlich wie beim EtherCAT die EL6731 zwingend eine Prozessdatenverknüpfung benötigt, um den Profibus überhaupt anlaufen zu lassen.

    Schau doch mal ins InfoSystem. Die EL6731 soll hardwaretechnisch identisch mit der FC310x sein. Dort steht auch was zum Config-Mode:
    Feldbuskomponenten -> Feldbuskarten -> FC310x -> FC310x als Master -> Profibus DP

Ähnliche Themen

  1. Problem mit Beckhoff Profibus-Master EL6731
    Von grosser_marco im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 17.03.2011, 09:25
  2. Beckhoff EL6751 Master mit CanOpen Encoder SOD bzw. PDO Einstellungen
    Von temporunner13 im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 17.02.2010, 07:13
  3. Siemens TP177 an Beckhoff CX9001 mit DP Master
    Von stefanm80 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 17.08.2009, 09:39
  4. Beckhoff: Touchscreen/USB Probleme
    Von Bührer im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 11.06.2007, 13:15
  5. Antworten: 3
    Letzter Beitrag: 08.11.2004, 20:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •