Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 5 ErsteErste 12345 LetzteLetzte
Ergebnis 21 bis 30 von 42

Thema: Profibus bricht zusammen

  1. #21
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von MeTh Beitrag anzeigen

    Vielleicht kannst du deinem Chef aus Sicht der Kunden und auch aus Sicht der Kosten (alles Doppelt bestellen, doppelte Arbeit, ...) ein bischen
    "EMV-Erziehen".
    Wieso Kunde, wer hat den die CE-Erklärung unterschrieben, wie sieht es mit der EMV-Richtlinie aus. Wo ist die Anlage aufgebaut, welche Funktenstörklasse ist notwendig. Wurden die Herstellerangaben erfüllt....
    Fragen üder Fragen.
    Man kann darüber diskutieren obe einseitig oder beidseitig , weil es zeitweise unterschiedliche Vorgaben gab, aber kein Schirm, nee nee nee.

    Von wann ist denn die Anlage, seit dem 1.10.2007 gelten neu verschärfte EMV Richtlinien.

  2. #22
    Registriert seit
    22.03.2007
    Ort
    Haiger
    Beiträge
    120
    Danke
    4
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hi,

    Puh, das hört sich ja alles echt nicht Witzig an.
    Aber mal unter uns: Wer verbaut denn bitteschön ungeschirmte Motorleitungen hinter einem FU? (Außer natür wenn ein Filter dahinter sitzt)
    Ich kenn auch ein paar Firmen die das bei uns schonmal gemmacht haben, nach einigen Stunden kompletten Produktionsausfall ist dann rausgekommen das 4 Leitungen ungeschirmt waren, 2 Stecker waren mit Drahtresten zugemüllt und eine Strecke hatte über 300 Meter in einem 1,5MBit Netz...
    Das war net wirklich Lustig.

    Ich überlege mir jetzt in Zukunft Profinet mit Baumstruktur in allen größeren Sachen zu verlangen. Hat den klaren Vorteil wenn sich mal ein Teilnehmer abmeldet dann bleiben wenigstens die restlichen...

    Andreas
    Wichtig ist am Ende auch egal!

  3. #23
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von Dumbledore Beitrag anzeigen
    Ich würde mal davon ausgehen, dass die Abschlusswiderstände bei einem "Stecker der als Verlängerung dient" ins Nirwana führen. Sie liegen ja sonst über 390 Ohm an +5V (Pin 6) bzw. 0V (Pin 5) und diese Pins sind bei einer "Verlängerung" ja gar nicht belegt, da dort wohl nur RxD/TxD und Screen aufgelegt sind.

    Insofern war das Kabel gar nicht terminiert sondern nur über die 220 Ohm an A und B belastet ...

    Gruss Michael
    Ich habe mal ein kleinwenig gesucht und leider nicht gefunden, wo genau der Abschlußwiderstand (vermutlich die 390 Ohm) und wo die 220 Ohm beschalten sind.
    Werden die 220 Ohm zum Entkoppeln genutzt oder für was sind die gut ?

    Die Erklärung klingt aber sehr plausibel und ich verstehe sie auch
    Ich entnehme daraus, daß jede Blechkiste, auf die der Schirm aufgelegt wird und in der Kiste 2 Lüsterklemmen... die bessere Lösung gewesen wären ?
    Oder ist es üblich, Profibus-Stecker als "Leitungsverlängerung" zu nehmen ?

    Ich habe mal ein Bildchen angehangen. Vielleicht könntest Du ja mal die beiden Widerstände einmalen. (Einfach eine Freihandlinie reicht. Ich weiß ja was es bedeuten soll )
    Angehängte Grafiken Angehängte Grafiken

  4. #24
    Registriert seit
    04.01.2007
    Ort
    Euskirchen
    Beiträge
    136
    Danke
    23
    Erhielt 37 Danke für 31 Beiträge

    Standard

    Zitat Zitat von mega_ohm Beitrag anzeigen
    Ich habe mal ein kleinwenig gesucht und leider nicht gefunden, wo genau der Abschlußwiderstand (vermutlich die 390 Ohm) und wo die 220 Ohm beschalten sind.
    ...
    Die Erklärung klingt aber sehr plausibel und ich verstehe sie auch
    Ich entnehme daraus, daß jede Blechkiste, auf die der Schirm aufgelegt wird und in der Kiste 2 Lüsterklemmen... die bessere Lösung gewesen wären ?
    Oder ist es üblich, Profibus-Stecker als "Leitungsverlängerung" zu nehmen ?
    google ist dein Freund ... gibt hier z.B. folgenden link

    http://www.softing.com/home/de/indus...dp/general.php

    dort ist ein schönes Diagramm zu finden ...

    Und was die Verlängerung betrifft: eigentlich sind Verlängerungen gar nicht zulässig, wegen der entstehenden Reflektionen. Wenn sie denn gar nicht zu vermeiden sind, dann am besten mit (abgeschirmten) Steckern in denen der Schirm nicht unterbrochen wird (was in der Praxis das Problem ist, auch bei den genannten "Lüsterklemmen"). Und natürlich ohne Abschlusswiderstände aller Art

    Gruss Michael

  5. Folgender Benutzer sagt Danke zu Dumbledore für den nützlichen Beitrag:

    blasterbock (01.11.2007)

  6. #25
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von Dumbledore Beitrag anzeigen
    google ist dein Freund ... gibt hier z.B. folgenden link

    http://www.softing.com/home/de/indus...dp/general.php
    Gruss Michael
    Ich habe diesen Link gelesen....
    und er (der Link) ist nicht sehr aussagekräftig !

    Ich habe mal die Widerstände an einem Profibus-DP- Stecker gemessen:
    Versuchsvoraussetzung:
    - Stecker Profibus-DP von Siemens
    - Meßgerät (Amprobe)
    - keine Profibus- Leitung, kein Gerät angeschlossen => Werkstatt-(Labor)versuch

    Folgende Widerstandsmessungen wurde durchgeführt:
    - INPUT A => OUT A ... 0,002 Ohm (un-terminiert)
    IN A => OUT A ... >> gegen unendlich Ohm (terminiert)
    - INPUT B => OUT B ... 0,002 Ohm (un-terminiert)
    IN B => OUT B ... >> gegen unendlich Ohm (terminiert)
    - INPUT A => OUT B ... >> gegen unendlich Ohm (un-terminiert wie terminiert)
    - INPUT B => OUT A ... >> gegen unendlich Ohm (un-terminiert wie terminiert)

    Die Sub-D-9 Pins des Steckers waren bei keiner Messung belegt !!

    Folgendes muß ich dazu noch schreiben:
    Meine berufl. Voraussetzung: Ich habe bei einem EVU gelernt, kenne die Grundlagen von Leitungs-/ Kabelmessungen zwecks Fehlersuche.
    - Nachdem die Messungen von dieser ext. Firma durchgeführt wurden (Zeitrahmen> 5h, die Messungen konnten nur während des Stillstands der Anlage durchgeführt werden.)
    Es wurde von Busstation 1 (Schaltschrank) gegen Busstation 16 (Letzte lt. Bus-Plan) begonnen, danach der Fehler gegensätzlich der Meßstelle eingegrenzt. (Stat2= [BUS-STATION 2] > Stat15, Stat3> Stat14... usw.)
    Ich hätte Stat1 gegen Stat16 als erste Messung, danach Stat1 gegen Stat8, danach Stat8> Stat16 gemessen... Danach hätte man m.M. eher einen einschränkenden Meßweg gefunden.
    Das ist aber keine Kritik, sondern nur meine persönliche Meinung !
    Bleibend sind die Meßergebnisse, die die Firma durchgeführt und protokolliert hat, die Meßwerte jeder einzelnen Busstrecke sind für die Zukunft auch Gold wert.

    Nun nochmals zum Anfang:
    Tatsache ist... wir (das elt. Inst.- Personal) hatten "nur" sporadisch mit dieser Anlage >Bus- Probleme< !!!
    Die Anlage 'lief' wochen-,monatelang ohne Probleme und es kam manchmal, eher selten innerhalb von einer Schicht (8h) zu Fehlerhäufungen, die jedem Arbeitsvorbereiter (Controller) nach Sichtung der Produktionsdaten einen Fast-Totalausfall aufzeigen.

    Ich habe die Widerstands- Meßwerte des 'angeblichen Verursachers [Profibus-DP- Stecker als Leitungsverlängerung verwendet]' mal aufnotiert... und hoffe auf weiteren 'geistigen Input'.

    UND...
    - ich verstehe (für mich ist es noch nicht logisch erklärbar) das Problem (welches von einer Fremdfirma scheinbar behoben wurde) noch nicht !!!
    >>> Profibus-stecker gefunden > Terminierungs-Widerstand ausgeschaltet und alles ist schick... Die Anlage lief vorher seit 3 Jahren, der Ausfall von Busstationen war mal weniger, mal nerviger.
    Angehängte Grafiken Angehängte Grafiken

  7. #26
    Registriert seit
    25.07.2007
    Beiträge
    79
    Danke
    2
    Erhielt 12 Danke für 12 Beiträge

    Standard

    Alle Siemensstecker die ich kenne, trennen den Bus beim Terminieren auf. D.h. "In" wird von "Out" getrennt und "In" wird wie in den Beispielbildern beschaltet.

  8. #27
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von ybbs Beitrag anzeigen
    Alle Siemensstecker die ich kenne, trennen den Bus beim Terminieren auf. D.h. "In" wird von "Out" getrennt und "In" wird wie in den Beispielbildern beschaltet.
    Das war auch mein Kenntnisstand.

    Mich hatte (und danach hatte ich gefragt) verwirrt, daß (ob man es nun macht oder nicht => ICH HABE ES NICHT installiert, mußte als instandhaltender Elektriker aber erstmal damit leben) eine Firma, die ihre Meßtechnik verkaufen will (obwohl ich ein bedeutend besseres Profibus-DP- Meßinstrument, welches online messen kann) gerade einen Busstecker als Fehlerquelle für sporadisch !!! (die sind mal da... und wochenlang nicht) auftretende Fehler ausgemacht hat.
    Ich habe den Namen der Firma nie genannt, werde mich auch davor in Zukunft hüten.

    Tatsache ist: Seit dem Einmessen des Fehlers (der terminierte Stecker in einem Kabelkanal, der als Leitungsverlängerung dienen sollte) ist erstmal wieder Ruhe im System
    Aber: Diesen Zustand (Anlage funktioniert ohne Stationsausfälle) hatte ich bestimmt 20x vorher auch schon, nachdem ich die Schirmungswiderstände des gesamten Profibus-DP-Systems gemessen hatte, alle Stecker und Mot.-Rückführungen (auch Profibus) nachgeprüft und teilweise ersetzt hatte.
    -zig Niederohm- Messungen ergaben, daß die Anlage an jedem erdenklichen Punkt das gleiche Erdpotential bezieht und der Widerstand fast gegen 0 geht. Es wurden auf der kompletten Anlagenlänge Erdseile (240 qmm Alu) gezogen, die zusätzlich zu der normalen, von der Masch.bau- Firma berechneten Erdung, angeschlossen sind. Der Leitungsweg zum nächsten MS- Trafo beträgt höchstens 50m !!

    Nachdem hier 390 Ohm und 220 Ohm aufgetaucht sind, habe ich nochmals den Widerstand eines Profibus-DP- Steckers in "unangestecktem" Zustand gemessen. (Versuchsaufbau wurde von mir beschrieben)
    Meine Meinung ,durch die Meßergebnisse erhärtet, ist: Die Firma hat vielleicht ein Problem gefunden... die Lösung ist es nicht.
    Ich denke aber nicht nur problem- sondern lösungsorientiert.

    Ich bin nach meinen bisherigen Kenntnissen und diesen, von mir durchgeführten Messungen überzeugt: Ein terminierter Profibus-DP- Stecker läßt keine "Bits mehr purzeln"... an der Stelle ist Endstation und meine bisherige Erfahrung bewahrheitet sich: Nachfolgende Busstationen können (Widerstand => gegen unendlich) nicht mehr gefunden werden.

    _________________________________________________________
    Sollte meine Erkenntnis Fehler enthalten, bitte ich, nicht nur Links zu senden, sondern zu erklären !
    Ich bin lernfähig.

  9. #28
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    UND...
    - ich verstehe (für mich ist es noch nicht logisch erklärbar) das Problem (welches von einer Fremdfirma scheinbar behoben wurde) noch nicht !!!
    >>> Profibus-stecker gefunden > Terminierungs-Widerstand ausgeschaltet und alles ist schick... Die Anlage lief vorher seit 3 Jahren, der Ausfall von Busstationen war mal weniger, mal nerviger.
    Da ich in meinem Berufsleben schon einige Busmessungen an Profibussystemen gemacht habe, kann ich dir sagen, dass es nichts außergewöhnliches ist wenn eine Anlage in diesem Zustand 3 Jahre läuft.
    Du schreibst ja selber, dass es immer wieder zu Störungen gekommen ist.

    Zu dem Thema mit der Verlängerung im Kanal. Normalerweise ist es kein Problem eine Busleitung mit einem Busstecker zu verlängern (ich mache sowas nicht).
    Die eingeschaltete Terminierung, genau genommen der 220Ohm Widerstand, dämpft aber das Signal, so dass es hier schon sein kann, dass deine Analge nun wieder läuft nachdem der Widerstand abgeschaltet wurde.
    Die 390Ohm Widerstände dienen dazu im Ruhezustand (kein Telegramm) eine sogenannte Idlespannung auf dem Bus zu erzeugen.

    Diese Spannung bewegt sich bei Messung von B gegen A so um die 1,2Volt.
    Dies kann natürlich nur funktionieren wenn die Stecker an einem Teilnehmer angeschlossen sind und die Versorgungsspannung eingeschaltet ist.

    Gruß Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  10. #29
    Registriert seit
    25.07.2007
    Beiträge
    79
    Danke
    2
    Erhielt 12 Danke für 12 Beiträge

    Standard

    Sorry, da habe ich wohl die Schilderung Deines Versuchs fehlinterpretiert.

    Wenn ich mich recht erinnere hatten wir früher, also ganz ganz früher Profibusstecker die beim Einschalten des Abshlußwiderstandes den 2. Busabgang nicht auftrennten. Hier würde wie von centipede bereits erwähnt der Bus mit dem zusätzlichen Widerstand belastet.

    Weisst Du welcher Stecker verwendet wurde? Wurde dieser Entfernt oder lediglich der Abschluß geöffnet?

  11. #30
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von centipede Beitrag anzeigen
    Da ich in meinem Berufsleben schon einige Busmessungen an Profibussystemen gemacht habe, kann ich dir sagen, dass es nichts außergewöhnliches ist wenn eine Anlage in diesem Zustand 3 Jahre läuft.
    Du schreibst ja selber, dass es immer wieder zu Störungen gekommen ist.
    Ja.... die Störungen im Profibus-DP zu erkennen.... das ist recht einfach.
    Das zu Erkennen war sogar mir möglich: Die Anlage tut nix mehr... Streik der Automaten ???
    Vorsorglich habe ich mal die Terminatrix um "Rat" gebeten

    Meine eigentliche Frage war:
    Die Anlage bleibt einfach unkontrolliert stehen, bringt teils recht verwirrende Fehlermeldungen auf die HMI.
    WARUM ????

    Mir ging es um die Ursachenforschung.
    Ich habe meinen "Meßaufbau" genau beschrieben.

    Ich weiß (das hatte ich ja schon mehrfach geschrieben), daß erstmal wieder der BUS funktioniert. Dieses Ergebnis hatte ich aber schon 4711- mal !!
    Ich habe gemessen... an einem "!unplugged" Profibus-DP- Stecker !
    Die Meßwerte habe ich hier veröffentlicht !

    Ich bei all meinen Messungen habe keine 390, 220 oder auch sonst welche Ohm-se gesehen.

    Ich habe nur Widerstände gegen Null (0,02- 0,06 Ohm) oder gegen "unendlich" (mehr als 999 Megaohm) gemessen.
    Meine Meßwerte (!) lassen mich eben gerade an der Lösung (es soll ein Stecker, terminiert, gewesen sein) zweifeln.
    Derzeit ist das Problem abgefrühstückt... (das war es aber die 3 Jahre vorher auch schon !)

    Ich bin gespannt... (und wäre der Erste, der sich freut, wenn das Problem DIESES MAL TATSÄCHLICH gelöst !!! wäre... [wie oft hatte ich schon vorher geglaubt, dieses erstrebenswerte Ziel erreicht zu haben].. )

    Ich habe schon sehr viel Zeit und Fragen in Fachforen gesteckt, um dieses Problem mir zumindest einigermaßen zugängig zu machen. Ich hätte aus der Richtung HF-Technik (da kenne ich mich fast gar nicht aus) eine Erklärung erhofft. Widerstände kann ich messen, das bekomme ich als gelernter Elektriker gerade noch hin !!!

Ähnliche Themen

  1. Antworten: 11
    Letzter Beitrag: 18.02.2010, 07:05
  2. Analogwert bricht zusammen
    Von settelma im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 16.06.2008, 16:30
  3. Antworten: 9
    Letzter Beitrag: 13.02.2008, 20:17
  4. Antworten: 11
    Letzter Beitrag: 04.09.2006, 13:32
  5. MPI und Profibus zusammen im Einsatz
    Von MerlinTT im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 22.07.2005, 16:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •