Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Instabile Analogwerte

  1. #1
    Registriert seit
    20.08.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,
    bei der Inberiebnahme der Anlage habe festgestellt daß die Analogwerte die ich über PEW einlese instabil sind, durch die reduzierung der Bus-Baudrate von 1,5 auf 500 habe ich den stabilität erreicht, stellte aber nach der Busüberprüfung mit dem Bus-tester PBT3 fest, daß 3 et200s Slaves sich nicht melden, die 319F-F_CPU meldet aber kein Bus und kein Sammelfehler.
    woran kann es liegen?
    Zitieren Zitieren Instabile Analogwerte  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Also wenn du die Geschwindigkeit des Busses so weit heruntersetzen musst, dann würde ich ersteinmal den Bus selber kontrollieren
    Also Terminierung, Buslänge, Abschirmung usw.

  3. #3
    Alex ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.08.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von marlob Beitrag anzeigen
    Also wenn du die Geschwindigkeit des Busses so weit heruntersetzen musst, dann würde ich ersteinmal den Bus selber kontrollieren
    Also Terminierung, Buslänge, Abschirmung usw.
    Danke vorest, was ist mit der Terminierung gemeint, die Abschirming und Busstecker werde ich noch kontrollieren, Aber was mich stützig macht, dass es die 3 Module die es betrifft nicht hintereinander sind, sondern im Starng z.B auf Platz 5,8 und 20. sind, und die Stationen dazwischen sind OK.

  4. #4
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Zitat Zitat von Alex Beitrag anzeigen
    ...was ist mit der Terminierung gemeint...
    Terminierung: Die Busabschlusswiderstände müssen am Anfang und Ende
    des Busses eingeschaltet sein. Alle anderen aus

  5. #5
    Alex ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.08.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von marlob Beitrag anzeigen
    Terminierung: Die Busabschlusswiderstände müssen am Anfang und Ende
    des Busses eingeschaltet sein. Alle anderen aus

    Das ist soweit richtig eingestellt, die Signale sieht die SPS auch.

  6. #6
    Registriert seit
    28.02.2005
    Beiträge
    186
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard

    äh, instabil ?
    das hat doch nix mit dem Bus zu tuen oder meinst du das die Werte ab und zu dann 0 werden, wenn der bus nicht läuft ?
    Wenn du mit der Busgeschwindigkeit rummachst, musst du auch schauen das alle Teilnehmer die benutzte Busgeschwindigkeit eingestellt bekommen.
    Es gibt noch Teilnehmer die das per Dipschalter machen.
    Sonst sind schwankende Analogwerte ein Zeichen für fehlende Masseverbindung zwischen den Anlagenteilen, Spannungsversorgung ?
    Das kann dann auch die Funktionsfähigkeit des Bussystems betreffen.
    An einer Neuanlage würde ich dann so vorgehen:
    - Stell die Busgeschwindigkeit auf 1,5MBit/s
    - Schalte den 1. Teilnehmer zu, danach Kontrolle auf Funktion
    - Schalte den 2. Teilnehmer zu etc etc. dann siehst du ob etwas nicht stimmt.
    - normal solltest du auch eine Störmeldung generieren, wenn der Bus keinen Datentransfer mehr vollbringt, also gestört ist.

    good luck =)

    edit: wenn kein busfehler angezeigt wird kann es auch noch sein das du die Adressen doppelt belegt hast. Ich würde das Stück für Stück in Betrieb nehmen wenn es nicht auf anhieb geht ...
    Geändert von GobotheHero (15.11.2007 um 13:01 Uhr)

  7. #7
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Zitat Zitat von GobotheHero Beitrag anzeigen
    äh, instabil ?
    das hat doch nix mit dem Bus zu tuen oder meinst du das die Werte ab und zu dann 0 werden, wenn der bus nicht läuft ?
    Also wenn der Bus z.B. nicht vernünftig abgeschirmt ist, dann denke ich schon, das das was ausmachen kann, oder siehst du das anders?

  8. #8
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.227
    Danke
    534
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Zitat Zitat von marlob Beitrag anzeigen
    Also wenn der Bus z.B. nicht vernünftig abgeschirmt ist, dann denke ich schon, das das was ausmachen kann, oder siehst du das anders?
    Also die Analogwerte dürfen deshalb nicht instabil sein, wenn der Bus Mist ist, dann gibts Fehlertelegramme und Sendewiederholungen, aber keine falschen Werte.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #9
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Also die Analogwerte dürfen deshalb nicht instabil sein, wenn der Bus Mist ist, dann gibts Fehlertelegramme und Sendewiederholungen, aber keine falschen Werte.
    Man kann nicht alles wissen

    Aber wenn der Bus nur stabil läuft, wenn er die Geschwindigkeit des Busses heruntersetzt, würde ich mir ihn trotzdem mal angucken

  10. #10
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.227
    Danke
    534
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von marlob Beitrag anzeigen
    Man kann nicht alles wissen

    Aber wenn der Bus nur stabil läuft, wenn er die Geschwindigkeit des Busses heruntersetzt, würde ich mir ihn trotzdem mal angucken
    Klar, auf jeden Fall. Zuerst den Bus in Ordnung bringen und dann weiter mit den Analogwerten. Im Übrigen, wenn der Bus deshalb spinnt, weil er Spannung auf dem Schirm hat, der Schirm sich was einfängt, der Schirm offen ist, etc. kann ja auch der entsprechende Slave mit den Analogeingängen davon betroffen sein.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

Ähnliche Themen

  1. Analogwerte
    Von siqo im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 07.07.2011, 01:30
  2. Analogwerte
    Von Alexandr im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 12.08.2010, 13:59
  3. analogwerte
    Von Majus68 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 31.08.2009, 14:41
  4. Analogwerte aus SPS auslesen
    Von TimoK im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 09.09.2008, 22:21
  5. Analogwerte mit AS-i
    Von Johnathan im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 09.02.2006, 18:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •