Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Wago 750-650 mit Delphi und MBT.dll

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen!

    Ich habe ein Problem mit dem Empfangen der Zeichen der RS232 Klemme von Wago.
    Mit hilfe des Wago MBT.dll und Delphi programmiere ich die Schnittstelle welche am Feldbuskoppler 750-842 hängt (Modbus/TCP).

    Zuerst möchte ich fragen ob hier einer schon eine RS232 Klemme mit Delphi / C / usw. benutzt hat und mir vielleicht weiter helfen könnte.

    Ich wäre sehr froh, wenn mir jemand weiter helfen könnte, da ich von Wago selbst nicht den nötigern Input bekommen habe um das Problem zu lösen.

    Vielen Dank im Voraus

    Gruss

    Lanthan
    Zitieren Zitieren Gelöst: Wago 750-650 mit Delphi und MBT.dll  

  2. "Also, damit ich das auch kapiere:

    Vermutlich WinPC als ModbusTCP Master geht auf
    Wago - Feldbuskoppler 750-842
    Feldbuskoppler 750-842 hat ein SPS Programm
    Feldbuskoppler 750-842 hat als I/O Klemme eine RS232 Klemme.
    WinPC hat ein 'EigenProgramm' und nutzt die MBT.dll von Wago.

    Signallauf?
    Eigenprogramm an Feldbuskoppler 750-842 -> SPS Prog -> Klemme232.... und

    was geht hier wo wann verloren, wie merkt man das?

    kurt"


  3. #2
    Registriert seit
    21.05.2004
    Beiträge
    418
    Danke
    31
    Erhielt 16 Danke für 8 Beiträge

    Standard

    Also, damit ich das auch kapiere:

    Vermutlich WinPC als ModbusTCP Master geht auf
    Wago - Feldbuskoppler 750-842
    Feldbuskoppler 750-842 hat ein SPS Programm
    Feldbuskoppler 750-842 hat als I/O Klemme eine RS232 Klemme.
    WinPC hat ein 'EigenProgramm' und nutzt die MBT.dll von Wago.

    Signallauf?
    Eigenprogramm an Feldbuskoppler 750-842 -> SPS Prog -> Klemme232.... und

    was geht hier wo wann verloren, wie merkt man das?

    kurt

  4. #3
    Anonymous Gast

    Standard

    Der Signallauf ist fast richtig...
    Eigenprogramm -> Feldbuskoppler 750-842 -> Klemme RS232

    Ich verwende kein SPS Programm auf dem Programmierbaren Koppler!

    Ich verstehe nicht wie ich das ganz Empfangen soll und wie ich den 120 Byte Buffer nutzen kann.

    So wie ich es im Moment empfage, werden mir die Zeichen überschrieben. Deshalb die Frage ob einer schon damit Erfahrung hat.

  5. #4
    Registriert seit
    21.05.2004
    Beiträge
    418
    Danke
    31
    Erhielt 16 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Hardware ist ja 'wie' Beckhoff, Wago hat aber eine andere (eigene) Firmware.
    So weit ich mich mal dafür bei Beckhoff interessiert habe (selber nie eingesetzt), so kommuniziert der RJ Anschluss ausschließlich mit dem SPS Prog und die RS232 Klemme ausschließlich mit dem SPS Prog. Ein direkter Durchgriff vom RJ (Feldbus-Modbus) zur Klemme (ohne SPS Prog dazwischen) ist nicht möglich.
    Das SPS Prog nimmt die Daten vom Modbus und managt die serielle Kommunikation.

    Möglicherweise bei Wago anders.

    kurt

Ähnliche Themen

  1. Kann WAGO 750-841 mit Delphi auslesen aber nicht ändern
    Von einheit141 im Forum Sonstige Steuerungen
    Antworten: 7
    Letzter Beitrag: 23.03.2011, 10:46
  2. Mit Wago OPC-Server eine Wago 750-481 auslesen?
    Von Reto Hasler im Forum Hochsprachen - OPC
    Antworten: 8
    Letzter Beitrag: 26.06.2008, 10:02
  3. Delphi 7
    Von enter im Forum Hochsprachen - OPC
    Antworten: 5
    Letzter Beitrag: 21.05.2007, 06:34
  4. Wago I/O System 750 - Kommunikation mit Delphi
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 19.12.2005, 22:32
  5. Delphi und SPS
    Von sfc46 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 08.12.2004, 10:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •