Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17

Thema: DP/DP-Koppler konfigurieren???

  1. #1
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hat schon mal jemand mit einem solchen Koppler Erfahrungen gemacht?

    Meine beiden Master CPU`s melden keine Fehler.
    Beim Koppler leuchten SF1+2, BF1+2, rot,
    sowie die beiden ON1+2 für die Netzversorgungen (grün).

    Netz1 Netz2

    DP-Koppler mit der Adresse 5 DP-Koppler mit Adresse 11

    die Adressen sind Über die Schalter eingesttellt (beide ADDR-Schalter auf OFF).

    PS Schalter beide auf ON

    Im Anhang ist die E/A Konfiguration

    Vielleicht hat jemand eine Idee!
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren DP/DP-Koppler konfigurieren???  

  2. #2
    Registriert seit
    01.02.2006
    Beiträge
    212
    Danke
    33
    Erhielt 6 Danke für 5 Beiträge

    Standard

    ist schon etwas her, aber ich hatte mal was mit den PS-Schalter. wen ichs noch richtig im kopf habe, darf doch nur 1. PS-Schalter ON sein (korrigiert mich ruhig!).
    sonst würd ich mal auf beiden seiten ein Byte mit Ein- und Ausgängen machen. du machst das hier nur in 1 Richtung oder?
    Gruß

    Jelly
    Zitieren Zitieren Ps  

  3. #3
    Topse ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Nein, die Daten werden von beiden Seiten gesendet und empfangen.

    Mit dem Schalter wird eingestellt welche Spannungsversorgungen angeschlossen sind. Dies ist notwendig für die Diagnose, fall eine Versorgung wegfällt.

    Ich denke nicht das nur einer betätigt sein darf. steht jedenfalls nicht ausdrücklich in der Beschreibung.

    Hab das auch versucht. Da die Einstellung für die PS Schalter sofort übernommen werden, hat das nichts gebracht.

    Aber danke für die Mühe.

  4. #4
    Registriert seit
    04.01.2007
    Ort
    Euskirchen
    Beiträge
    136
    Danke
    23
    Erhielt 37 Danke für 31 Beiträge

    Standard

    Zitat Zitat von Topse Beitrag anzeigen
    Beim Koppler leuchten SF1+2, BF1+2, rot,
    sowie die beiden ON1+2 für die Netzversorgungen (grün).
    Der Aufbau sieht erstmal korrekt aus.

    Das Handbuch ist zum DP-DP-Koppler liegt dir sicher vor, sonst ist es bei diesem Link erhältlich.

    Mir sieht das so aus, als hätte der Koppler (aus welchem Grund auch immer) zu beiden Netzen keine Verbindung. Die CPUs wurden doch mit der aktuellen HW-Konfig geladen?

    Und nochmal der Hinweis auf den immer wieder gerne gemachten Fehler: ON und OFF auf den DIP-Schaltern wurde sicher nicht verwechselt?

    Gruß Michael aka Dumbledore

  5. #5
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    tippe auch auf die hw config wenn an den beiden cpu kein bf angezeigt wird. wurde die hw-config wirklich übertragen oder hast su im eifer des gefechts ein fehlermeldung anstatt der fertigmeldung weggeklickt, weil zb ein baustein beobachtet wurde - mir geht das ständig so...

    wegen dem koppler - dp-slaves übernehmen die an den schaltern eingestellte adresse erst nach spannungswiederkehr!
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  6. #6
    Topse ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich neige auch dazu das was mit der hw nicht stimmt. Ich hab die hw einfach vom Katalog rübergezogen, unter Netzkomponenten. Wie kann ich das kontrollieren?
    Das sind doch die GSDateien wo bekomme ich die aktuelle her? Dann könnte ich einfach mal die neue rein laden. Wobei ich davon ausgehe das die neue bei mir im Katalog steht.

    Wenn ich vom Netz1 ein Byte an Netz 2 senden will, muss das dann wie folgt konfiguriert werden???

    Netz 1
    1 Byte Ausgang

    Netz 2
    1 Byte Eingang ??????? Korrekt?????

  7. #7
    Topse ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich hätte da noch eine Frage:

    Wie kann ich bei einer Gleitkommazahl die Stellen nach dem Komma einfach abschneiden, also nicht runden? Gibt es da einen fertigen Befehl?

    2,67837636 Es soll nur die 2 stehen bleiben!

  8. #8
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Topse Beitrag anzeigen

    Wie kann ich bei einer Gleitkommazahl die Stellen nach dem Komma einfach abschneiden, also nicht runden?
    Code:
          L     MD 2
          TRUNC 
          DTR   
          T     MD 6
    für die umwandlung in FUP oder KOP solltest du es so einsetzen:

    Code:
          U(    
          L     MD     2
          TRUNC 
          T     #temp
          UN    OV
          SAVE  
          CLR   
          U     BIE
          )     
          SPBNB _001
          L     #temp
          DTR   
          T     MD     6
    _001: NOP   0
    Geändert von vierlagig (23.01.2008 um 10:22 Uhr)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  9. #9
    Topse ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die zweite Frgae hab ich mir selbst beantworten können:

    Lsg. TRUNC

  10. #10
    Topse ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2007
    Beiträge
    34
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke Vierlagig, hab meinen Artikel fast gleichzeitig mit dir erastellt.

    Bin jetzt doch drauf gekommen.

    Aber das mit dem Umwandeln von KOP oder FUP ist super.

    Danke

Ähnliche Themen

  1. AX5112 DI/DO konfigurieren
    Von kunse im Forum CODESYS und IEC61131
    Antworten: 10
    Letzter Beitrag: 22.06.2011, 12:14
  2. Balkenanzeige konfigurieren
    Von hATZEnbrECHT im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 30.05.2011, 12:38
  3. Wie Button konfigurieren?
    Von detoto im Forum HMI
    Antworten: 6
    Letzter Beitrag: 04.09.2009, 14:54
  4. S7 konfigurieren
    Von gPunkt im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 21.10.2008, 07:39
  5. TS-Adapter konfigurieren
    Von Anonymous im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 15.02.2005, 17:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •