Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Problem mit Profibuskommunikation Danfoss FU

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich versuche zur zeit einen Danfoss VLT 5000 Frequenzumrichter mittels S7 CPU 315 über Profibus anzusteuern. Das Busnetz steht, ich hab keine Fehler am Bus, ich kann die Ausgänge des FU's beobachten über Bus, kann aber nix an den FU senden.

    Im Baustein DP_CTRL bekomm ich im CTRL_Status die meldung hex 8183, heisst soviel wie Station nicht projektiert. Wie funktioniert das genau?

    oder gibt es ein problem weil ich zum profibusnetz, die programmierung mit Laptop und mpi-adapter am mpi bus mach?

    Wäre für jede Hilfe sehr dankbar!!!!

    grüße uli
    Zitieren Zitieren Gelöst: Problem mit Profibuskommunikation Danfoss FU  

  2. "Hallo Zottel,
    bei VLTxxx mit Bitbus an AEG-Modicon
    ja, das muss man heute bei allen Umrichtern mit Profibus-Anbindung so machen, der Umrichter muss so parametriert werden, dass er weiss, dass er die Signale nicht von den Anschlussklemmen sondern vom Profibus (oder woher auch immer z.B. Fieldbus etc.) annehmen soll. Ist aber auch stark herstellerabhängig.
    Gruss
    Question_mark"


  3. #2
    Anonymous Gast

    Standard

    Hi Uli,

    hast du im VLT und im HW-Konfig den gleichen PPO-Typ eingestellt?

    Ich weiß auch nicht ob der Baustein DP_CTRL der richtige ist??? Er dient zur Übertragung von Steusignalen an einen CP und du willst die Daten ja an den VLT senden!?!

    Ich habe zur Übetragung den SFC15 "DPWR_DAT" eingesetzt (dient zur Übertragung von Daten an einen DP-Normslave).

    Gruß MARS

  4. #3
    snowman Gast

    Standard

    Hallo,

    danke für die Tipps. ja, hab den gleichen PPO Type ausgewählt in der HW Konfig und im VLT. habs mit dem SFC 15 schon probiert, hat aber leider immer noch nicht funktioniert, aber mit dem SFC 14 kann ich ein Bereit Signal vom VLT empfangen!

    Gruß

    uli

  5. #4
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Kann es sein, daß du den Umrichter selbst so konfigurieren mußt, daß er Werte vom Bus annimt, statt von den Anschlußklemmen? Meine mich dunkel zu erinner (ca.15 Jahre her), daß es bei VLTxxx mit Bitbus an AEG-Modicon so war.

  6. #5
    Anonymous Gast

    Standard

    Bei Verwendung der Onboard-DP-Schnittstelle kann direkt auf die Peripherieworte geschrieben werden (T PAW xxx). Dies funktioniert jedenfalls bei der VLT2800-Serie. Ich würde versuchen, falls der FU nicht über den Bus umparametriert werden muß, PPO Typ 3 oder Typ 4 einzustellen. Dann ist auf dem ersten Peripheriewort das Steuerwort. Mit W#16#43F auf das erste Steuerwort geschrieben, sollte der FU stoppen. Bei W#16#47F wird der FU gestartet. Bei der Serie 2800 funktioniert das ohne Probleme.
    Auf das 2. Wort wird der Hauptsollwert (Sollfrequenz) geschrieben. Dieser muß im Bereich zwischen W#16#0 und W#16#4000 geschrieben werden.
    Zum Einlesen der Daten vom FU können ebenfalls direkt die Peripherieworte gelesen werden (L PEW xxx). Ich kann mir vorstellen, das der direkte Datenzugriff über die Peripherieworte auch bei beim VLT5000 funktioniert.

  7. #6
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Standard

    Hallo Zottel,
    bei VLTxxx mit Bitbus an AEG-Modicon
    ja, das muss man heute bei allen Umrichtern mit Profibus-Anbindung so machen, der Umrichter muss so parametriert werden, dass er weiss, dass er die Signale nicht von den Anschlussklemmen sondern vom Profibus (oder woher auch immer z.B. Fieldbus etc.) annehmen soll. Ist aber auch stark herstellerabhängig.
    Gruss
    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)

  8. #7
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Standard

    Hallo Woldo,
    hast ja recht, nur muss der Umrichter wissen, dass er über den Profibus gesteuert wird und nicht über z.B. die Anschlussklemmen.
    Gruss
    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)

  9. #8
    Registriert seit
    11.09.2006
    Beiträge
    20
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Pfeil


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hi.. PPO Typ1
    Der Frequenzumrichter muss erst bereit sein.
    Also schreib erst 16#400 im steuerwort du erhälst als Statuswort 16#630
    danach STW=16#406 , Statuswort 601 als letztes Stw=407 Statuswort=603 .
    Der VLT ist nun bereit.
    zum starten Stw=16#47F rechts drehen 16#847F linksdrehen(Paramerter200 muss=1 sein (drehen in beide Richtungen)
    Zitieren Zitieren Vlt5000  

Ähnliche Themen

  1. Step7: Profibuskommunikation
    Von Karli im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 07.09.2009, 15:28
  2. Problem mit Danfoss -DP /Zustandsübergangdiagramm
    Von kiestumpe im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 14.06.2007, 09:48
  3. Problem 10V mit Danfoss FC302
    Von OschiLePro im Forum Antriebstechnik
    Antworten: 0
    Letzter Beitrag: 12.06.2007, 12:46
  4. Problem mit Drive ES und Danfoss Umrichter
    Von Anonymous im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 03.05.2004, 23:57
  5. Profibuskommunikation S5-115U - S7-200
    Von walu im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 11.08.2003, 13:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •