Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: CP 342-5 und CPU 315-2DP

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe folgendes Problem:
    Ich habe eine CP 342-5 (altes Model) und eine neue (schmale) CPU 315-2DP. Wenn ich beide ueber Profibus verbinde, geht die CP auf Fault (Man muss sie neu starten um den Fehler zu beheben). Im Diagnostikbuffer der CP wird von einem Fehler auf dem K-Bus berichtet (also zwischen CPU (eine alte 314) und dem CP. Kann dieses Problem auf eine fehlende Erdung der Komponenten zurueckzufuehren sein ?
    Das Problem tritt in allen Konfigurationsmoeglichkeiten auf (Master-Slave / Slave-Master / Master-Master).
    Vielen Dank fuer eure Hilfe....
    Zitieren Zitieren Gelöst: CP 342-5 und CPU 315-2DP  

  2. "Serwus
    Auf deiner Stelle würde ich neue Software in CP laden. Im Internet (ich meine bei Siemens) kann man neue Versionen kostenlos laden. Ich hatte identische Probleme. Du kannst online den Softwarestand deiner CP Karte auslesen und neue Version übertragen. Diese Funktion findest du unter Siematic Menager."


  3. #2
    Registriert seit
    06.10.2004
    Beiträge
    278
    Danke
    17
    Erhielt 34 Danke für 30 Beiträge

    Standard

    Serwus
    Auf deiner Stelle würde ich neue Software in CP laden. Im Internet (ich meine bei Siemens) kann man neue Versionen kostenlos laden. Ich hatte identische Probleme. Du kannst online den Softwarestand deiner CP Karte auslesen und neue Version übertragen. Diese Funktion findest du unter Siematic Menager.

  4. #3
    Registriert seit
    27.11.2004
    Beiträge
    69
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Taddy
    Vielen Dank fuer deinen Tip. Ich denke du hast recht mit der Firmware.
    Ich habe bei Siemens nachgefragt, aber leider ist fuer meine cp (6GK7342-5DA00-0XE0) kein Firmwareupdate moeglich. Scheinbar gibt es keine Moeglichkeit mein Problem zu beheben...
    Zitieren Zitieren CP ist zu alt...  

  5. #4
    Registriert seit
    23.11.2004
    Beiträge
    347
    Danke
    2
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Hallo,
    vor langer Zeit hatte ich ein ähnliches Problem.
    Nachdem ich den CP über die Hardwarekonfiguration gelöscht hatte und die Projektierung direkt auf den CP (nicht auf die CPU!) geladen hatte, war das Problem gelöst.
    Kannst es ja mal versuchen, vielleicht hilft es auch bei Dir.
    Viel Glück
    RaiKa

  6. #5
    Registriert seit
    27.11.2004
    Beiträge
    69
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hola muchachos
    Habe den Fehler gefunden....
    Es musste "Zyklisches Verteilen der Busparameter einschalten" deaktiviert werden. Fuer so etwas modernes war meine CP wohl etwas zu altersschwach.
    Jetzt stellt sich mir aber gleich die naechste Frage:
    Welche Vor - und Nachteile bringt das staendige Senden von Busparametern ? Die Step7-Hilfe ist etwas bescheiden und auch im Internet habe ich nichts gefunden.
    Ich dachte eigentlich, dass der Master (mit dieser Konfiguration) nach Ab - und wieder Einschalten eines Slaves dafuer sorgt, diesen mit neuen Parametern zu versorgen.
    Ein Test hat dann aber ergeben, dass der Slave auch so seinen Betrieb wieder aufnimmt. Vieleicht brauchen nur bestimmte Slaves eine neue Parametrisierung ?
    Zitieren Zitieren Problem behoben  

  7. #6
    Registriert seit
    21.05.2004
    Beiträge
    418
    Danke
    31
    Erhielt 16 Danke für 8 Beiträge

    Standard

    Zyklisches Verteilen von Busparametern einschalten

    ... ermöglicht einen sehr einfachen und komfortablen temporären Anschluss von Programmiergeräten an ein in Betrieb befindliches Profibus-Subnetz, auch wenn die am Profibus-Subnetz eingestellten Busparameter dem PG-Benutzer nicht bekannt sind...

    ... soll nicht aktiviert werden, wenn Äquidistanz-Betrieb gewählt wurde (Verlängerung des Buszyklus) oder sich weitere Teinehmer (Fremdgeräte) am Profibus-Subnetz befinden, die den DSAP63 für Multicast-Funktionen benutzen.


    und zu Äquidistanz-Betrieb:
    Dies bedeutet, dass der zeitliche Abstand aufeinanderfolgender Sendeberechtigungen für den DP-Master konstant ist.... ist nur dann möglich, wenn sich nur ein DP-Master (Klasse1) im Subnetz befindet...

    leider nicht von mir sondern aus HIER

    kurt

  8. #7
    Registriert seit
    27.11.2004
    Beiträge
    69
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Kurt
    Danke fuer den Buchtip.
    Ich hatte vor kurzem einen Profibus mit einem Master (CPU 315-2DP) und zwei Slaves (CPU 315-2DP). In dem Projekt war keine PG projektiert und das "Zyklische Verteilen...." war eingeschaltet. Trotzdem konnte ich ueber Profibus die Teilnehmer nicht erreichen. Ich konnte sie zwar sehen, aber nicht auf Daten zugreifen (Obwohl die Slaves "aktiv" waren).
    Erst nach der Projektierung des PG (und des neuen Ladens aller Teilnehmer) war ein Zugriff moeglich.
    Dies wiederspricht eigentlich dem Lehrbuch und es ist mir noch immer ein Raetsel...
    Zitieren Zitieren PG ohne Projektierung  

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •