Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Fehleranalyse Profibus-DP Slave

  1. #1
    Registriert seit
    11.05.2007
    Beiträge
    194
    Danke
    22
    Erhielt 53 Danke für 43 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen

    Habe folgendes Problem:
    Bei einer nicht von uns erstellten Anlage tritt sproradisch (zirka einmal am Tag) ein Profibus-DP-Fehler eines Slaves auf (Adresse 10). Leider nur immer etwa für 140 mSek.

    Verwendete Komponenten:
    Panel PC 670 6AV7 722-2BC10-0AD0
    mit WinLC 6ES7 611-4PY00-0YB7
    und CP5611 (Adresse 2)

    IM151-1 6ES7 151-1AA03-0AB0 (Adresse 10) macht Probleme
    IM151-1 6ES7 151-1AA03-0AB0 (Adresse 11)
    IM151-1 6ES7 151-1AA03-0AB0 (Adresse 12)
    DP/DP-Koppler 6ES7 158-0AD01-0XB0 (Adresse 30)

    Peripherie-Module an IM151 Adresse 10 (Slave der Probleme macht)
    Steckplatz 1 PM-E DC24V 6ES7 138-4CA00-0AA0
    Steckplatz 2 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 3 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 4 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 5 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 6 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 7 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 8 2DI DC24V 6ES7-131-4BB00-0AA0
    Steckplatz 9 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 10 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 11 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 12 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 13 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 14 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 15 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 16 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 17 2DO DC24V 6ES7-132-4BB00-0AA0
    Steckplatz 18 ASCII (8B) 6ES7-138-4DF00-0AB0

    Ins Ereignis-Protokoll werden nur immer folgende Meldungnen eingetragen.

    Ereignis 1 von 15: Ereignis-ID 16# 38C5
    Kein Eintrag in Textdatenbasis. Hex-Werte werden angezeigt.
    Ereignis-ID: 16# 38C5
    OB: 16# 56
    PK: 16# 19
    DatID 1/ 2: 16# 54 C0
    Zusatzinfo1 / 2 / 3: 16# 3FFF 3FFE 010A
    externer Fehler, gehendes Ereignis
    22:51:47.899 15.05.2008

    Ereignis 2 von 15: Ereignis-ID 16# 39C5
    Kein Eintrag in Textdatenbasis. Hex-Werte werden angezeigt.
    Ereignis-ID: 16# 39C5
    OB: 16# 56
    PK: 16# 19
    DatID 1/ 2: 16# 54 C0
    Zusatzinfo1 / 2 / 3: 16# 3FFF 3FFE 010A
    externer Fehler, kommendes Ereignis
    22:51:47.768 15.05.2008

    Soll ich zuerts die IM151 Anschaltung austauschen oder könnte das Problem auch bei einem Peripherie-Modul (I/O's) der Adresse 10 liegen?

    Auswertung mit OB86 und FB125, DB125 oder dem Protokollanalyser ProfiTrace bringen mich auch nicht mehr weiter.
    Leider habe ich keine Ersatzteile im Hause (müsste sie zuerst bestellen). Ich möchte vor einem Hardwareaustauch den Fehler möglicht genau lokalisieren.
    Vielleicht kann jemand von Euch mit meinen Messungen mehr dazu aussagen.


    Gruss Hoyt
    Angehängte Grafiken Angehängte Grafiken
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Fehleranalyse Profibus-DP Slave  

  2. #2
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Hi,


    ich habe mir den Trace mal angeschaut.

    in Zeile 17 die Antwort mit dem Service RS besagt, dass der Slave momentan keine Resourcen für die Kommunikation frei hat.

    in Zeile 37 besagt das 4te Byte im Datenteil, dass der Slave seinen zugehörigen Master nicht mehr weiß (FF normal 02 (Master hat Adresse 2))

    Beides deutet auf Probleme der Kopfbaugruppe hin, entweder ein Problem in der Versorgungsspannung oder ein Defekt der Baugruppe.
    Eher unwahrscheinlich aber auch möglich ist ein Einfluss der ASCII Baugruppe am Ende.

    mfg,
    Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  3. Folgender Benutzer sagt Danke zu centipede für den nützlichen Beitrag:

    Hoyt (21.05.2008)

  4. #3
    Avatar von Hoyt
    Hoyt ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.05.2007
    Beiträge
    194
    Danke
    22
    Erhielt 53 Danke für 43 Beiträge

    Standard

    Hallo Centi

    Besten Dank für deine Analyse.
    Ich werde mir nun doch zuerst einmal eine neue IM151 Kopfbaugruppe besorgen.

    Gruss Hoyt

  5. #4
    Registriert seit
    27.11.2005
    Ort
    im Osten
    Beiträge
    1.183
    Danke
    141
    Erhielt 271 Danke für 248 Beiträge

    Standard

    Es wurde auch schon berichtet, dass diese Produktreihe der ET200S Module probleme macht

    http://www.sps-forum.de/showthread.p...ighlight=1AA03

  6. Folgender Benutzer sagt Danke zu MW für den nützlichen Beitrag:

    Hoyt (22.05.2008)

  7. #5
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    2 Bier darauf, daß die 151winselwinsel03 der Übeltäter sind.

    Die Teile haben schon einige User hier geärgert.

    Tausch sie gegen 151-XXX04 (die aktuellen) aus und du wirst deine Ruhe haben


    MfG

  8. #6
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard

    ... Und Selten Ist Etwas Mit Elektronik Noch Schlechter wollte es nicht glauben...

    Die haben mir dann doch glatt irgendeinen Schlipsträger aus der Entwicklungsabteilung auf die Baustelle geschickt, dann aber auf dessen Bericht hin schön brav Ersatzgeräte geliefert...

    Spass beiseite: RAUS MIT DEM DING!

    griele Füße dtsclipper
    Das Grauen lauert in der Zwischenablage !!

  9. #7
    Avatar von Hoyt
    Hoyt ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.05.2007
    Beiträge
    194
    Danke
    22
    Erhielt 53 Danke für 43 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Der Austausch der IM151-1 Baugruppe (6ES7 151-1AA03-0AB0) gegen eine neue IM151-1 (6ES7 151-1AA04-0AB0) brachte nicht den gewünschten Erfolg. Der Fehler trat immer noch sporadisch auf.

    Erst nach dem Austausch des ASCII-Moduls 6ES7-138-4DF00-0AB0 mit einem neueren Typ 6ES7-138-4DF01-0AB0 läuft die Anlage jetzt seit einer Woche störungsfrei.

    Gruss Hoyt
    Zitieren Zitieren Rückmeldung  

Ähnliche Themen

  1. Profibus Slave
    Von stricky im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 06.05.2011, 13:56
  2. CP 342-5 als Profibus Slave
    Von eYe im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 09.07.2010, 17:11
  3. Progamm zur Fehleranalyse
    Von itchika im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 11.09.2009, 08:56
  4. Antworten: 7
    Letzter Beitrag: 03.04.2008, 21:32
  5. S5 mit Profibus -> S7 als Slave
    Von vido im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 05.06.2005, 23:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •