Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Zeittoleranz bei optischen Drehgebern ?

  1. #1
    Registriert seit
    20.11.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgendes Problem:

    Die Steuerung einer Antenne wird mittels Winkelgeber (absolut) in beiden Achsen betrieben.
    Diese sind über CAN-Bus gekoppelt und liefern zyklisch alle 100ms (geprüft) den aktuellen Winkelgeberwert.
    Die Auflösung der Geber beträgt 16Bit; also ausreichend hoch.

    Da die Antenne sehr langsam dreht (ca. 20min für 2°) dreht sich auch der Geber entsprechend langsam.

    Nun mein Frage: Kann ein optischer Drehgeber bei solch niedrigen Drehzahlen "hängen" und das Signal verspätet ausgeben?

    Der Hintergrund ist der, dass ich mich nicht auf die Werte verlassen kann.
    Die Geber liefern mir oft erst eine Signaländerung von 1Bit nach ca. 20s Fahrzeit, obwohl die Antenne sich
    rechnerisch bereits 7Bit (hätte) drehen müssen und dies auch macht (Abstandsmessung).
    Nach diesem "Sprung" kommen allerdings die Werte meist sauber im Sekundentakt.

    Hat da jemand Erfahrung oder eine Idee woran es liegen könnte?
    Ich stehe da irgendwie auf dem Schlauch.
    Zitieren Zitieren Zeittoleranz bei optischen Drehgebern ?  

  2. #2
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    spontane Idee: ein mechanisches Problem


    Wie wird denn der Geber angetrieben?
    Gibt´s da irgendwo Spiel, welches erst überwunden werden muß?


    MfG

  3. #3
    Logatom ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.11.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die schnelle Antwort.

    Also ich habe mal nachgesehen. Bei den Gebern kommt eine Präzisionskupplung
    zum Einsatz (ähnlich dem roten Teil auf dem Bild).


  4. #4
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    und wie sieht die Mechanik DAVOR aus?


    Schon mal die Geberwelle und den Wert GLEICHZEITIG gesehen?

    Dreht sich wirklich die Geberwelle OHNE daß sich der Wert ändert?


    Bei 20 Sekunden sollte sowas leicht zu prüfen sein.




    MfG

  5. #5
    Logatom ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.11.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    ja, das habe ich schon einmal versucht zu überprüfen, aber bei der langsamen Rotation konnte ich unmöglich eine Bewegung von 0,0055° (entspr. 1Bit) feststellen.

    Ich habe gerade auch das Datenblatt der Kupplung gefunden.
    Siehe Hier !
    Dort steht etwas von Maximaler Winkelfehler = ± 1,5°.
    Ist damit vielleicht das Spiel gemeint?

    Zur Mechanik davor kann ich nicht viel sagen, außer das es sich um eine recht massive Achse handelt.
    Geändert von Logatom (22.05.2008 um 22:13 Uhr)

  6. #6
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hrmpf,


    Irgendwo gibt es einen "Wandler", der aus Strom Bewegung macht (in Fachkreisen "Motor" genannt).

    Nachdem da eine ziemlich hohe Drehzahl erzeugt wird, kommt im Normalfall ein Drehzahl-Umformer zum Einsatz (umgangssprachlich "Getriebe" genannt).

    Am Ende des Getriebes sitzt nun (ggf. über "Richtungs- oder Momenten-Wandler (Zahnräder oder ein Ketten-Strang)) die Welle, auf der die Antenne sitzt.

    Und irgendwo auf der gesammten Konstruktion ist nun ein klitzekleiner Abgriff für deinen Geber.


    WOOOOOOOOOOO genau?


    Schon mal am Antrieb des Gebers rumgefingert, ob sich da was bewegen lässt?



    MfG

  7. #7
    Logatom ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.11.2007
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    also der Geber sitzt direkt auf den Drehachsen der Antenne.
    Der Antrieb sitzt allerdings nicht auf den Achsen sondern ist über eine seitliche bzw. am oberen Radius angebrachte Hubspindeln realisiert.
    Sie drücken und ziehen die Antenne quasi in die gewünschte Richtung.

    In dem Zusammenhang habe ich auch mit einer Messuhr ein mögliches verspätetes Losbrechmoment der Antenne messen wollen,
    aber keins festellen können; d.h. beim Anfahren der Motoren bewegt sich auch sofort die Antenne.

    Die Achsen der Geber selbst lassen sich im ausgebauten Zustand leichtgängig drehen.
    Im eingebauten Zustand lässt sich die Achse mit geringer Handkraft ohne Probleme um 1° (entspr. 200Bit) bewegen,
    was ich aber am Material der Präzisionskupplung zurückführen würde.

  8. #8
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Logatom Beitrag anzeigen
    Im eingebauten Zustand lässt sich die Achse mit geringer Handkraft ohne Probleme um 1° (entspr. 200Bit) bewegen,

    Hallo,

    DA würd ich mal vermuten, daß dein Problem herkommt


    MfG

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •