Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 6 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 54

Thema: Fehlersuche am Profibus

  1. #1
    Registriert seit
    14.06.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Tag miteinander!

    ich habe mich hier im Forum angemeldet, weil ich auf die Schnelle keinen anderen Rat für mein Problem weiß und hoffe nun, ihr könnt mir ein Paar Tipps geben.

    Folgendes:
    Für ein Projekt wurde eine Beckhoff-Steuerung CX1020 mit Profibus-Master CX1500-M310 realisiert, an dem 23 Profibus-DP Salves hängen (Stellantriebe für Wasserversorgung). Die Gesamtausdehnung des Profibus beträgt rund 600m.
    Bei der Inbetriebnahme habe ich den Profibus vom TwinCAT "einscannen" lassen, worauf hin zunächst nur zwei und nach Verringerung der Baudrate auf bis zu 9,6 KBaud (!) nach mehrmaligem (!) scannen irgendwann endlich alle 23 Slaves gefunden und in TwinCAT eingebunden wurden.
    Nun scheint die Signalqualität dermaßen schlecht zu sein, dass ein fehlerfreier Betrieb nicht möglich ist. Es kann keine fehlerfreie Kommunikation zu einem Slave aufgebaut werden. Erst wenn ich mindestens 2/3 aller Salves im TwinCAT deaktiviere funktioniert die Kommunikation manchmal fehlerfrei. Aber richtig gut geht's nur, wenn maximal 4 oder 5 Slaves konfiguriert werden. Und das auch nur, wenn diese die topologisch gesehen vordersten am Bus sind (direkt nach dem Master).
    Vom Betriebselektriker (es sind mehrere Firmen an dem Projekt beteiligt, wobei ich lediglich die Programmerierung gemacht habe) wurde die Verkabelung auf Fehler überprüft (keine Verdrahtungsfehler, Schirme korrekt aufgelegt, uws.). Abschlusswiderstände wurden ebenfalls überprüft.
    Meine Vermutung nach Rücksprache mit dem Hersteller der Stellantriebe ist nun, dass der Spannungsfall auf der Leitung zu groß ist, obwohl das Kabel laut Spezifikation bestens geeignet sein soll und wir bisher nicht an die Grenze kommen, wo Repeater nötig wären. Kann es sein, da am letzten Salve keine 5V-Einspeisung über dem Anschlusswiderstand erfolgt, die Speisung des Master allein nicht ausreicht?
    Man will nun einen Repeater einbauen und erhofft sich dadruch eine Signalverstärkung. Denkt ihr, das könnte das Problem beheben, falls es an der Einspeisung liegt?
    Gibt es noch irgend welche "einfachen" Messmethoden, die man erstmal durchführen könnte? Der Einsatz eines Profibus-Analyzers soll wegen der Kosten nach Möglichkeit vermieden werden (Projekt ist für die öffentliche Hand).
    Erschwerend ist außerdem, dass die Stellantriebe in Wartungsschächten "verbuddelt" sind, das Profibuskabel unter der Erde verlegt wurde.

    Entschuldigt bitte, falls meine Fragen evtl. laienhaft klingen. Leider sind meine Erfahrungen mit Profibus (noch) sehr gering.
    Zitieren Zitieren Fehlersuche am Profibus  

  2. #2
    Registriert seit
    25.09.2005
    Ort
    Neuss
    Beiträge
    278
    Danke
    11
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Nun ja, glauben wir mal, dass die Verdrahtung stimmt (wobei ich weiß, das man hier eine Menge falsch machen kann - auch wenn man meint, dass es augenscheinlich in Ordnung sei).

    Die Länge kann je nach Übertragungsrate und Anzahl Teilnehmer schon problematisch werden. Repeater können hier durchaus hilfreich sein.

    Wenn der Platz knapp wird, lohnt sich vielleich mal ein Blick auf diesen Repeater hier: http://www.helmholz.de/prod.d,17_22,....html?prod=110

    Den wollten wir auch schon mal einsetzen. (Leider) ist daraus nichts geworden, unsere Probleme waren damals wohl doch Fehler in der Verdrahtung!

  3. Folgender Benutzer sagt Danke zu HeizDuese für den nützlichen Beitrag:

    Onkel Dagobert (14.06.2008)

  4. #3
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.774
    Danke
    50
    Erhielt 729 Danke für 434 Beiträge

    Standard

    Hallo jogger

    Ich finde es ja sehr lobenswert, dass Ihr versucht sparsam mit unseren Steuergeldern umzugehen, aber pauschal mal irgenwo einenen Repeater einzubauen, ist nicht unbedingt die richtige vorgehensweise.

    Es gibt Geräte wie den

    http://www.softing.com/home/de/indus...anchor=3010400

    Hier kannst Du direkt an der CPU Deine Messungen machten, und dann gezielt eine Lösung finden.
    Du brauchst das Gerät nicht unbedingt kaufen, es gibt Firmen, die Die Messung gegen Bezahlung für Dich übernehmen.
    Ich gehe davon aus, dass Du und die anderen im Projekt auch nicht nur für Gotteslohn arbeiten.

    Gruss
    Audsuperuser
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  5. #4
    Registriert seit
    06.10.2003
    Beiträge
    3.411
    Danke
    451
    Erhielt 504 Danke für 407 Beiträge

    Standard

    Zitat Zitat von HeizDuese Beitrag anzeigen
    ..Wenn der Platz knapp wird, lohnt sich vielleich mal ein Blick auf diesen Repeater hier: http://www.helmholz.de/prod.d,17_22,....html?prod=110

    Den wollten wir auch schon mal einsetzen. (Leider) ist daraus nichts geworden, unsere Probleme waren damals wohl doch Fehler in der Verdrahtung!
    Wieso "leider", es ist doch von Vorteil wenn es nicht notwendig gewesen ist. Aber es ist ein tolles Teil, kannte ich noch nicht. Kennt jemand den Preis?


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  6. #5
    Registriert seit
    05.06.2006
    Ort
    PLZ 97xxx
    Beiträge
    274
    Danke
    31
    Erhielt 44 Danke für 36 Beiträge

    Standard

    Schau Dir das mal an:

    ftp://ftp.vipa.de/support/Howtodo/de...bel-Messen.pdf

    Anleitung zum Messen des Kabels, es können grobe Fehler wie fehlende
    Terminierung ... gefunden werden.

    Richtlinien:

    http://www.profibus.com/celummdb/doc...v106_Mai06.pdf

    http://www.profibus.com/celummdb/doc...v102_Nov06.pdf

    max. Baudrate sollte bei 600m Länge 187,5KBaud sein

  7. #6
    Registriert seit
    13.12.2006
    Beiträge
    628
    Danke
    109
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Du sagst

    was vom 'Profibus unter der Erde', und 'im Erdschacht'.

    Ich hoffe, dass das Kabel im Rohr liegt?!?. Was machst Du gegen die Feuchtigkeit? Also am Stecker...

    Greetz? Tom

  8. #7
    jogger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.06.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo!
    Danke erstmal für die vielen Tipps.

    @Sarek und @all:
    In den Richtlinien hab ich unter Interface-Test gelesen: "Spannungsversorgung für alle Abschlusswiderstände vorhanden?"
    Könnte hier schon der Fehler liegen? Ich glaube nicht, dass die Abschlusswiderstände auf der Profibusplatine der Schiebern aktiv versorgt werden. Es gibt auf jeder Platine einen Stecker, um 5V DC einzuspeisen. Aber die Schieber werden meines Wissen nach lediglich mit 3-Phasen Wechselstrom versorgt. Ich glaube, dass lediglich am Master 5V eingespeist werden.
    Wenn's daran liegen könnte, würde ein Repeater dann überhaupt helfen?

    @TommyG:
    Ich weiß nicht, wie das Kabel verlegt wurden. Aber ich kann mir vorstellen, dass es wirklich "verschüttet" ist, also nicht in einem Rohr liegt. Die Stellantriebe (Schieber) befinden sich in Schächten, in Schutzart IP67 oder 65, glaub ich.
    Es sind diese:
    http://www.auma.com/cms/Auma/de/prod...003,19353.html

    Benötigen Repeater nicht auch eine aktive Versorgung? Die Umgebungsbedingungen und Verkabelung an den Schiebern erschweren eine zusätzliche Einspeisung, sei's 5V oder 24V.

    Ist die maximale Baudrate eigentlich ein "Maximalwert", oder deutet es allein schon auf ein Problem hin, wenn man bei 600m Leitung die 187,5KBaud nicht fahren kann?

    Problematisch am ganzen Projekt ist, dass das Projekt von Firma A realisiert wird, Firma B die Verkabelung gemacht hat (nur die Verkabelung) und ich von Firma C zur Programmierung angeheuert wurde.
    Die Kosten für eine professionelle Prüfung des Profibus will aber anscheinend keiner übernehmen, da je erstmal nicht klar ist, ob Firma A oder Firma B einen Fehler gemacht hat. Und so richtig Ahnung von Profibus hat anscheinend auch keiner... tja, nicht gerade einfach.

  9. #8
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Zitat Zitat von jogger Beitrag anzeigen
    Hallo!
    Danke erstmal für die vielen Tipps.

    @Sarek und @all:
    In den Richtlinien hab ich unter Interface-Test gelesen: "Spannungsversorgung für alle Abschlusswiderstände vorhanden?"
    Könnte hier schon der Fehler liegen?
    Abschlusswiderstände gibt es nur an den beiden letzten Geräten. Eins davon ist oft der DP-Master. Selbst wenn nicht: Der Bus funktioniert, solange auch nur ein Endgeräte seine Abschlußwiderstände versorgt.
    Zitat Zitat von jogger Beitrag anzeigen
    Ich glaube nicht, dass die Abschlusswiderstände auf der Profibusplatine der Schiebern aktiv versorgt werden.
    Bei Profibus-Geräten sollte das aber so sein!
    Zitat Zitat von jogger Beitrag anzeigen
    Es gibt auf jeder Platine einen Stecker, um 5V DC einzuspeisen.
    Das mag dazu dienen, eine zusätzliche Quelle für die Versorgung der Abschlusswiderstände bei Netzausfall anzuschließen?
    Zitat Zitat von jogger Beitrag anzeigen
    Aber die Schieber werden meines Wissen nach lediglich mit 3-Phasen Wechselstrom versorgt.
    Sie enthalten ganz sicher interne Elektronik, den wie sonst sollte ein Drehstrommotor auf Profibus-Signale reagieren können?
    Diese müssen sie speisen und enthalten dazu ein internes Netzteil.
    Da das Profibus-Interface im Allgemeinen von der internen Elektronik galvanisch getrennt ausgeführt wird, enthält ein Profibus-Slave normalerweise einen DC/DC-Konverter, der die Profibusseite der Signaltrennung (z.B. Optokoppler) und den Leitungstreiber versorgt. Der Leitungstreiber benötigt auch 5V, um die vorgeschriebenen Pegel zu erreichen. Dabei fällt die Versorgung der Abschlusswiderstände nebenbei mit ab. Du kannst sie an den Pins der Buchse messen. Habe keine Lust, nachzusehen, an welchen. Vielleicht steht es in dem VIPA-Papier, sonst einfach mit einem Ohmmeter am geöffneten und gezogenen Stecker nachmessen, welche Pins Verbindung zum Abschlusswiderstand haben, wenn Terminierung eingeschaltet.
    Zitat Zitat von jogger Beitrag anzeigen
    Ich glaube, dass lediglich am Master 5V eingespeist werden.
    Zu welchem Zweck?
    Zitat Zitat von jogger Beitrag anzeigen
    Wenn's daran liegen könnte, würde ein Repeater dann überhaupt helfen?
    Nein, der hilft eigentlich nicht bei Kabelfehlern. Er könnte helfen, bei schlechtem Kontakt, hohen Übergangswiderständen oder elektromagnetische Störung durch benachbarte Leistungskabel. Aber selbst wenn, wäre das ein zufälliger Erfolg.
    Zitat Zitat von jogger Beitrag anzeigen
    Benötigen Repeater nicht auch eine aktive Versorgung?
    Auf jeden Fall. Der genannte Repeater im Stecker von MHJ bezieht sie halt aus der Versorgung der Abschlußwiderstände.
    Zitat Zitat von jogger Beitrag anzeigen
    Ist die maximale Baudrate eigentlich ein "Maximalwert", oder deutet es allein schon auf ein Problem hin, wenn man bei 600m Leitung die 187,5KBaud nicht fahren kann?
    Das deutet auf ein Problem hin.

    Wenn du kein Geld hast, aber Zeit:
    - Schließe aus, daß ein Teilnehmer "schlecht" ist. Klemme dazu jeden Teilnehmer einzeln ab und schaue, ob es was bringt.
    - Klemme auf der Hälfte des Weges das abgehende Kabel ab, schalte den Abschluß ein und schaue, ob es was bringt.
    - Sieh dir die Signale mit einem Oszilloskop an. Ich will nicht malen. Es gibt Beispiele im Internet wie es aussehen soll. Oder schließe einen Slave mit kurzem Kabel an den Master an und schau dir das als Beispiel für gut an.
    - Öffne jeden Stecker und kontrolliere die Verkabelung. Adernbruch? Korrosion? Berührt ein Äderchen vom Schirm irgendetwas anderes?
    - Achte darauf, daß auch der Schirm aufgelegt ist.
    - Vielleicht ist Feuchtigkeit in das Kabel eingedrungen. Miß mit einem Isolationsprüfer Ader-Ader, Ader-Schirm, Adern und Schirm gegen Erde. ACHTUNG! DAZU UNBEDINGT VORHER STECKER ALLER TEILNEHMER ABSTECKEN! ABSTECKEN!

  10. #9
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    Ich wollte gerade so richtig schön loslegen, aber da habe ich gesehen, dass Zottel schon das Meißte genannt hat. C'est la vie ...

    Zitat Zitat von Zottel Beitrag anzeigen
    Abschlusswiderstände gibt es nur an den beiden letzten Geräten. Eins davon ist oft der DP-Master. Selbst wenn nicht: Der Bus funktioniert, solange auch nur ein Endgeräte seine Abschlußwiderstände versorgt.
    Dennoch kann ich einen Punkt so nicht stehen lassen (siehe Zitat). Nach meiner Erfahrung führt schon bei einer wesentlich kürzeren Profibus-Länge das Wegfallen der Versorgung eines der Abschluß-Widerstände zu einem fehlerhaften Verhalten am Bus bzw. sogar ggf. zur Nicht-Funktion.

    Gruß
    LL

  11. #10
    Registriert seit
    05.06.2006
    Ort
    PLZ 97xxx
    Beiträge
    274
    Danke
    31
    Erhielt 44 Danke für 36 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wie ist das DP-Kabel in Bezug zum Leistungskabel verlegt?
    Falls die direkt nebeneinander liegen, dann gute Nacht!

Ähnliche Themen

  1. Fehlersuche S7 300
    Von olnet im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 18.11.2010, 19:30
  2. Tipps zur Fehlersuche...
    Von petzi im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 03.06.2010, 06:26
  3. Fehlersuche: Profibus Ausfall
    Von olitheis im Forum Simatic
    Antworten: 56
    Letzter Beitrag: 07.07.2007, 17:41
  4. Fehlersuche Profibus
    Von x108 im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 20.06.2007, 19:50
  5. Praxistip Fehlersuche Profibus-DP
    Von x108 im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 25.10.2006, 03:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •