Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: DP/DP Koppler mit Busfehler

  1. #1
    Registriert seit
    03.11.2004
    Beiträge
    44
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    2x CPU 313C-2DP über eine DP/DP Koppler zusammengefummelt.

    An den CPU's sind die BF aus. Am Koppler volle beleuchtung SF,BF und die 2 LED für die Spannung sind an.
    Wenn ich mich nun direkt an die CPU hänge sehe ich den Koppler mit der richtigen Adresse. Hänge ich mich direkt an den Koppler sehe gar keinen Teilnehmer.
    In der HW Config sehe ich unter Online Partner auch nicht den DP/DP Koppler.

    Ach Ja ==> datenaustausch mit L PEW und T nach DBxxx ist auch nicht möglich.

    Ich krieg noch die Kriese mit den schei* Ding, bei den Außentemperaturen zur Zeit.

    Ist mein erster DP/DP Koppler, hatte ich mir einfacher vorgestellt.

    Wenn jemand ein paar heise Tipps hat, ich bin für jeden Tipp Dankbar.
    haltet schön alle bits zusammen
    Zitieren Zitieren DP/DP Koppler mit Busfehler  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    hier im handbuch findest du ein beispiel für die diagnose

    wichtig beim DP/DP-Koppler ist der E/A-bereich, der muß in beiden steuerungen stimmig sein ... ansonsten ist das eigentlich gar nicht so schwer

    im notfall einfach mal deine hw-config posten
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #3
    Registriert seit
    03.11.2004
    Beiträge
    44
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    habe jetzt wieter zurück noch eine Beitrag gefunden http://www.sps-forum.de/showthread.p...hlight=DP%2FDP scheint das gleich problem zu sein. Die Endgültige Lösung wurde aber damals auch nicht zurückgemeldet. Ich werd morgen mal den Tipps von damals nachgehen.

    Nochwas: wenn die CPU startet geht die BF mal kurz aus und nach 5 sek ist sie wieder da.
    haltet schön alle bits zusammen

  4. #4
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    wie vl das bereits angesprochen hat, ist es wichig, dass beide kopplerseiten übereinanderpassen.

    sagen wir mal du definierst auf cpu1 in hw-config
    1 aw und 1 ew
    dann muss in cpu2 die reihehenfolge sein
    1 ew und 1 aw

    welchen ae-bereich du für die jeweilige seite wählst ist egal solange die cpu diesen bereich unterstützt
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  5. #5
    Registriert seit
    03.11.2004
    Beiträge
    44
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage

    Müssen die beiden CPU's in einen Projekt sein?
    haltet schön alle bits zusammen

  6. #6
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von totalfuchs Beitrag anzeigen
    Müssen die beiden CPU's in einen Projekt sein?
    nein, das gehört zum vorteil eines DP/DP-Kopplers
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  7. #7
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Nein, das ist ja gerade das Gute an dem DP-Koppler. Du fügst in beiden Projekten jeweils in der HW-Konfig den Koppler ein und definierst wie oben beschrieben die EA-Bereiche. Wenn der Koppler eingefügt ist, darfst Du nicht vergessen, die gewünschten Module (EA's) in den Koppler einzufügen. Hier wird definiert, wie groß die Datenmenge sein soll (64 Byte, 128 Byte usw.)

    Diese EA-Bereiche müssen dann bei beiden Projekten "invers" vergeben werden, d.h. bei Projekt A meinetwegen EW20 u. AW30 ergo bei Projekt B: EW30 und AW 20.

    Keine Gewähr, das habe ich mir eben aus meiner Gehirn-Schublade gezogen, aber so in etwa hab ich das glaub ich mal gemacht...

    Gruß Appro
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  8. #8
    Registriert seit
    04.01.2007
    Ort
    Euskirchen
    Beiträge
    136
    Danke
    23
    Erhielt 37 Danke für 31 Beiträge

    Standard

    Zitat Zitat von Approx Beitrag anzeigen
    Diese EA-Bereiche müssen dann bei beiden Projekten "invers" vergeben werden, d.h. bei Projekt A meinetwegen EW20 u. AW30 ergo bei Projekt B: EW30 und AW 20.
    das ist so nicht ganz richtig: "invers" müssen nur die Richtungen sein, also z.B. 1EW-1AW und umgekehrt. Wie Volker schon schrub, sind die Adressen auf beiden Seiten völlig egal, da können ja sogar ganz verschiedene Steuerungen dranhängen, z.B. eine SPS und ein Leitsystem.

    Was man aber noch beachten sollte: die Konsistenzlängen müssen auf beiden Seiten ebenfalls übereinstimmen, also wenn eine Seite Worte sendet und die andere 2 Byte erwartet geht das ebenfalls schief. Das ist besonders bei Leitsystemkopplungen oft schwierig, weil das da (nach meiner Erfahrung) nicht so einfach einstellbar ist.

    Gruß Michael aka Dumbledore

  9. #9
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Zitat Zitat von Approx Beitrag anzeigen

    Keine Gewähr, das habe ich mir eben aus meiner Gehirn-Schublade gezogen, aber so in etwa hab ich das glaub ich mal gemacht...
    Alles klar! War auch schon etwas her...
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  10. #10
    Registriert seit
    03.11.2004
    Beiträge
    44
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Erstmal Danke an alle für die Ratschläge.

    zuerst die gute Nachricht alles leuchtet grün, keine rotes Licht mehr zu sehen.

    Der weg dahin ist mir eigentlich aber immer noch unklar.
    Im laufe des Tages hatte ich noch Problem mit anderen Slaves(z.B. Pnoz multi) der Slave war plötzlich auch rot, aber an der CPU alles grün.
    Stecker ab vom Slave immer noch alles grün. Onlinepartner in der HW Slave nicht ansprechbar. Erreichbare Teilnehmer Slave vorhanden. Mittlerweile hat sich noch ein Kollege dazugesellt der schüttelt auch nur mit den Kopf.
    Am Ende des Tages haben wir in den erreichbaren Teilnehmern alles per Hand gelöscht, alle Baustein/Systemdaten und dann die Hardware neu übertragen=> plötzllich lief alles.
    Zum Schluß habe ich noch die Slave Adresse eines ABB Robis geändert. Nach dem Neustart CPU auf Stopp. Betriebsartenschalter kurz auf Stopp und Neustart, immer noch Gelb. Das ganze nochmals mit den Schalter alles Grün.

    Ich hab das Zeug so stehengelssen und bin nach Hause!


    Irgendwie habe ich den Eindruck das beim übertragen der HW nicht komplett die vorhergende überschrieben wird. Kann sowas sein??

    Urlöschen, was passiert da mit der HWconfig?

    Wie bekomme ich die CPU wieder in den Auslieferungszustand?
    haltet schön alle bits zusammen
    Zitieren Zitieren CPU macht was sie will  

Ähnliche Themen

  1. Busfehler
    Von Tommy1981 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 23.09.2008, 09:48
  2. Busfehler
    Von tomk im Forum Feldbusse
    Antworten: 9
    Letzter Beitrag: 06.04.2008, 19:02
  3. S7 414-2DP - Busfehler
    Von dete im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 19.07.2007, 07:46
  4. Busfehler
    Von sushi7776 im Forum Feldbusse
    Antworten: 13
    Letzter Beitrag: 04.10.2006, 16:47
  5. Busfehler
    Von Outrider im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 08.10.2004, 08:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •