Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 6 von 6 ErsteErste ... 456
Ergebnis 51 bis 60 von 60

Thema: Profibus DP

  1. #51
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von crash Beitrag anzeigen
    Code:
     
          U M10.0         //Handmerker
          SPBN  M001      //wenn nicht Handmerker dann Sprung zu M001
          L MD100         //MD laden (enthält Realwert)
          T MD2           //und in MD2 schreiben
     
    M001: U M10.1         //Automatikmerker
          SPBN  M002      //wenn nicht Automatikmerker dann Sprung zu M002
          L MD104         //MD laden (enthält Realwert)
          T MD2           //und in MD2 schreiben
     
    M002: NOP 0           //und weiter im Programm
    Super....
    nur noch zum Verständnis
    SPBN // Sprungbedingt?
    NOP // das kann ich mir nicht herleiten
    lg flo

  2. #52
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von florian1234 Beitrag anzeigen
    SPBN // Sprungbedingt?
    springe wenn das VKE=0 -> SPringeBedingtNicht

    Zitat Zitat von florian1234 Beitrag anzeigen
    NOP // das kann ich mir nicht herleiten
    nulloperation, an dieser stelle als platzhalter an der sprungmarke M002, da eine marke ohne befehl nicht funktioniert. NOP 0 macht nischts - nur zykluszeit verbraten
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #53
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Daumen hoch

    Danke für die Erläuterung
    doch gleich die nächsten Fragen...

    Was bedeutet VKE

    und nun zu euren Hilfestellungen,
    habe das programm von hier nicht zur Hand gehabt und mein Kopf ist ein Sieb.
    #
    Deshalb habe ich etwas Programmiert, konnte aber noch nicht testen.

    Habe 3 anstatt Zwei Werte: Hand, Auto und Regelung
    alle auf das gleiche MD2

    NW1: Hand

    UND mit mehreren Eingängen,
    diese sind dann untereinander Verriegelt,
    als Einschaltbedingung für einen Move Baustein,
    IN: Handeingabe->MDx
    der Ausgang dann auf MD2


    NW2: Auto

    UND mit mehreren Eingängen,
    diese sind dann untereinander Verriegelt,
    als Einschaltbedingung für einen Move Baustein,
    IN: Festwert->50.0
    der Ausgang dann auf MD2


    NW3:Regelung

    UND mit mehreren Eingängen,
    diese sind dann untereinander Verriegelt,
    als Einschaltbedingung für einen Move Baustein,
    IN: Wert aus Regelung->MDy
    der Ausgang dann auf MD2

    Ist dies möglich.
    Entspricht dann doch SPBN, oder?
    Wie gesagt ich muß das Programm so anschaulich wie möglich halten und FUB ist da die erste wahl.

    Für eure hilfe ein dank nochmal
    lg flo

  4. #54
    Registriert seit
    18.01.2008
    Beiträge
    40
    Danke
    7
    Erhielt 6 Danke für 6 Beiträge

    Standard

    VKE ist das Verknüpfungsergebniss, also die logische Verknüpfung deiner Signale!

    Code:
    U E 1.0
    U E 1.1
    = M1.0
    Wenn der E1.0 & der E 1.1 = True, dann ist das VKE = True und der Merker 1.0 wird dann auch auf True gesetzt.

    Wieviele Eingänge oder Signale du vor den SPBN setzt ist, ist uninteressant, da ja die Signale wieder verknüpft werden zu seinem VKE.

    Zitat Zitat von florian1234 Beitrag anzeigen
    Wie gesagt ich muß das Programm so anschaulich wie möglich halten und FUB ist da die erste wahl.
    Da kann man drüber streiten, denke ich.

    Das Programm das Crash dir geschrieben hat, trifft ja schon fast alles was du brauchst, das bekommst du schon hin!
    Geändert von schoeneberg (17.12.2008 um 06:52 Uhr)

  5. #55
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen

    Hallo Hallo.....

    haben nun alle Grundlegenden Bedingungen in der Anlage geschaffen.
    FU läuft
    Hand Betreib läuft
    Auto Betrieb läuft
    Regelbetreib läuft.

    Nun wollen wir den Regler optimieren.
    Standregelung eigentlich PI Regler da I Strecke.
    Jedoch hat der FU im moment eine Hochlaufzeit von 10sec.
    Dies beeinflusst das Regelverhalten enorm.
    Darf man im FU diesen Sanftanlauf abstellen oder hat er eine Funktion.

    Und wenn ist es möglich diesen über das Steuerwort zu Steuern.
    Sprich nur für die Regelung zurückzusetzen?
    FU ist der MM420 von Siemens.

    lg flo
    lg flo
    Zitieren Zitieren Regelung  

  6. #56
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo...

    habe die regelung mit hilfe der Siemens Standartapplikation in griff bekommen.
    Die Hoch-Runterlaufzeit auf 2sec. gesenkt.

    So nun hab ich ein neues Problem
    Der OB100 wird nicht mehr bearbeitet....
    habe sie S7 Urgelöscht alles neu eingespielt.
    Den ob100 neu geschrieben.
    Dann nur noch ein Netzwerk erstellt und eine logische 1 erzeugt.
    Jedoch wenn ich auf run gehe passiert nichts ausser das ich online bin.

    Woran kann es liegen....

    lg und schojn mal nen frohes fest
    flo
    lg flo

  7. #57
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Der OB100 wird ja nur einmal beim Hochlauf der SPS durchlaufen, der zyklische OB ist der OB1. Was also wird genau nicht bearbeitet?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. #58
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hab ich mir nach weiterem lesen auch schon fast gedacht...
    aber mein problem löst es nicht...

    im ob 100 setze ich mir ne 1
    und setze einige merker zurück

    leider wird der merker den ich setzt nicht 1
    habe mir jetzt fürs erste so geholfen und setze den merker im fc1
    aber das ist nur ne notlösung, möcht schon wissen warum das net mehr klappt...

    hatte nen busfehler und habe dann die spannung abgestelllt.
    Der Bus-arbeitet einwandfrei. Bekomme nur keine 1 mehr aus dem ob100....

    kann man ihn irgenwie abschiessen?
    lg flo

  9. #59
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Man kann den OB100 in der SPS löschen, das war's aber ich denke nicht daß es daran liegt. Wird der Merker vielleicht noch irgendwo gesetzt/rückgesetzt? Ehe dein PG das beim Beobachten-Modus anzeigt ist alles gelaufen, denn der OB100 wird ja ganz am Anfang angesprungen. Ich hab noch nie erlebt, daß der OB100 nicht ging oder darin etwas nicht funktionierte, es lag immer am Programm/Programmierer
    Schreib mal bitte genau vor dem S Mx.y ein SET

    also:

    SET
    S Mx.y
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  10. #60
    Registriert seit
    31.10.2008
    Beiträge
    32
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich hatte den merker ersten gesetzt und in 4oder 5 ten wieder zurücksetzen lassen....
    dachte wenn ich es wieder lösche klappts...#
    ja ja der gute programmierer...

    vllt hab ich ihn nicht richtig gelöscht werd morgen nochmal urlöschen.
    und mit deinem vorschlag arbeiten.
    hab irgendwie das gefühl das sich dieser zurücksetzen wieder eingeschlichen hat. kommt mir nämlich echt spanisch vor....

    im übrigen hab ich ihn nicht in awl gesetzt.
    sondern mit nen s/r und nen negierten eingang....

    gibt es hier im forum ne liste von befehlen in awl die gängig sind...
    so langsam kann ich mich auch für awl begeistern
    lg flo

Ähnliche Themen

  1. Profibus Abhören (Profibus-Sniffer)
    Von tomi_wunder im Forum Feldbusse
    Antworten: 9
    Letzter Beitrag: 17.09.2007, 21:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •