Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 16 von 16

Thema: Busabschlusswiderstand

  1. #11
    Registriert seit
    19.04.2009
    Beiträge
    302
    Danke
    31
    Erhielt 40 Danke für 32 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ja genau es sollte reichen wenn du nur an der CPU einen Abschlusswiderstand hast. Falls es doch nicht funktioniert musst du halt ein T-Stück nachrüsten, was ich aber nicht glaube.

    Ausserdem sind bei deinen 3 Slaves 1,5 Mbit mehr als ausreichend. Man sollte es eh vermeiden so hohe Geschwindigkeiten zu fahren wie du im moment da bei 12 Mbit alles perfekt sein muss. Schirmung sowie Kabelverlegung sind sehr störanfällig was ich erfahren habe.

  2. #12
    INST ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    28.01.2004
    Ort
    Bodensee
    Beiträge
    260
    Danke
    18
    Erhielt 15 Danke für 13 Beiträge

    Standard

    @Proxy

    das T-Stück muß ich integrieren, da ich sonst die variable Station nicht mit einbinden kann. Wenn ich die Bustopologie so umbauen, dann kostet dies ca. 200€. Frage, ist dieser Mehraufwand bzw. Kosten/Nutzen sinvoll?
    Jetzt geht der Bus immer auf Störung durch abkoppeln der variablen Station (Busabschlußwiederstand wird dadurch enfernt). Ist dies auf dauer problematisch?

    Danke für die Hilfe!

    INST

  3. #13
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Wenn ich es richtig verstehe stört dich der SF-Fehler (bei S7) an der CPU.
    Mittels SFC12 kannst du diesen Fehler ausblenden.

    Suche im Forum nach SFC12, z.B. hier ... und ff.

    http://www.sps-forum.de/showpost.php...06&postcount=4

    oder auf des SIEMENS-SEITE

    Ich verwende den SPC12, wenn bestimmte Profibus-DP Ventilinseln nicht angebaut sind.

    Gruß

  4. #14
    Registriert seit
    27.04.2006
    Ort
    Sauerland
    Beiträge
    623
    Danke
    183
    Erhielt 88 Danke für 81 Beiträge

    Standard

    Ich denke der Bus schmiert ihm wegen des Endwiederstandes ab.
    Warum hängt man die Station nicht einfach in die Mitte? Also Kabel hin trickeln und wieder zurück?
    Und dann wie IBFS das beschrieben hat, die Station abmmelden.
    Mann kan natürlich auch was aktives hinten dranhängen, all das würde gehen.
    Die Kunst in der Personalführung ist es
    die Mitarbeiter so über den Tisch zu ziehen,
    dass sie die Reibungshitze als Nestwärme empfinden.

  5. #15
    Registriert seit
    09.01.2009
    Ort
    Wernberg-Köblitz
    Beiträge
    203
    Danke
    17
    Erhielt 4 Danke für 4 Beiträge

    Cool

    Zitat Zitat von Proxy Beitrag anzeigen
    Hallo,

    ja genau es sollte reichen wenn du nur an der CPU einen Abschlusswiderstand hast. Falls es doch nicht funktioniert musst du halt ein T-Stück nachrüsten, was ich aber nicht glaube.

    Ausserdem sind bei deinen 3 Slaves 1,5 Mbit mehr als ausreichend. Man sollte es eh vermeiden so hohe Geschwindigkeiten zu fahren wie du im moment da bei 12 Mbit alles perfekt sein muss. Schirmung sowie Kabelverlegung sind sehr störanfällig was ich erfahren habe.
    Du solltest Dich nicht wundern, wenn dann bei Dir komische Fehler sporadisch auftauchen! (Wenn Du es nicht glaubst, dann mach mal einen Bustrace)

    Ich kann von Deinem Vorhaben nur abraten!

    Es gibt da einen guten Link im Profibushandbuch!

    Die Überschrift lautet ungefähr so:

    Schritt 4.4 Qualität der Übertragung überprüfen
    Wenn eine PROFIBUS Installation ohne Anzeige von Fehler-LEDS funktioniert, bedeutet dies nicht auch
    eine fehlerfreie Funktion (vergleiche dazu auch den Fachartikel). Wir können mit einem Busmonitor wie
    dem ProfiTrace genauere Messungen durchführen:
    · Wie gross ist die aktuelle Zykluszeit des PROFIBUS-DP?
    · Wie oft werden die Telegramme von der Steuerung wiederholt?


    Hier der Link zum Artikel ->
    http://www.felser.ch/download/FE-TR-0602.pdf

    Quelle: Profibushandbuch (frei Verfügbar!)
    Nur mal so falls Du undefinierte Fehler haben solltest!
    Schwarz ist Rot und Plus ist Minus!!!
    Zitieren Zitieren Nur einen Busabschluß!???  

  6. #16
    Registriert seit
    04.07.2008
    Beiträge
    11
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Schönen guten Tag,
    ich messe Profibus.

    Um die Bautrate im Profibus zu ermittelt solltest du mal auf deine Zykluszeit deines Masters schauen. Rate dir das der Bus ca. 3mal so schnell sein sollte wie die Zykluszeit deines Masters.
    Was bringt dir eine Bautrate von 12 Mbit wenn du eine Zykluszeit von 30ms hast???? Was soll dein Master machen?? Ich kann dir sagen dass er in der Zeit wo kein Datenverkehr auf dem Bus ist, er z.B. nach Teilnehmern sucht. Oder aber er fragt die Slaves nach Sachen die sie noch garnicht in der Zeit bearbeitet haben können. Je schneller dein Bus desto Störanfälliger ist er. Die Bautrate ist so langsam wie möglich und so schnell wie nötig zu wählen.

    Desweitern mit den Abschlußwiderständen. Es sind immer Widerstände am Busanfang und am Busende zuschalten. Egal welche Bautrate. Die Widerstände haben nichts mit der Bautrate zu tun. Wer das behauptet sollte mal seine Grundkenntnisse in Elektrotechnik aufbessern. Und überlegen warum man überhaupt Widerstände braucht.

    Ich kenne dieses T-Stück leider auch nicht. Kann deswegen dazu auch keine Aussage treffen.

    Stichleitungen sind verboten.
    Wenn du nun keine andere Möglichkeit hast außer einer Stichleitung, setzte ein Repeater ein. Dann ist es keine Stichleitung mehr sondern ein neuer Strang. (Abschlußwiderstände nicht vergessen)

    Kann mich meinem Vorgänger nur anschließen, nur weil alle grünen LEDs leuchten heißt es noch lange nicht das Bus korrekt läuft. Froh sein können wir, dass der Profibus uns sehr viele Fehler die bei der Installation und während des Betriebes gemacht werden verzeiht. Nur warum fällt auf einmal ein Profibusgerät aus?? Hat sich da schon mal einer Gedanken gemacht??? Ich kann aus meiner Erfahren sagen das das Gerät was ausgefallen ist, nicht die Fehlerquelle ist, sondern nur der Leittragende.

    Zur Verlegung der Kabel. würde dir raten jedes Profibuskabel beim Austritt aus dem Schaltschrank mittels Schirmklemme zu erden. Kannst ja mal deinen Schirmstrom mit einer entsprechenden Leckstromzange messen. Wenn da z.B. hohe Ströme fließen, fließt der Strom auch über dein Profibusgeräte. Schon mal ein Gerät geöffnet und nachgeschaut wie das mit der Masse so intern weitergeht?? Die Leiterbahn laufen auf jeden Fall genau über deine Profibus ICs. Wenn da über die kleine Leiterbahn hohe Ströme zur Erde abfließen will ich nicht wissen was deine ICs dazu sagen. Auf jeden Fall werden die irgendwann ihren Dienst einstellen.

    Stecker sind auch so eine Sache. Die schönsten Stecker sind die mit den LEDs oder mit den eingabauten Repeatern. Kann ich nur jedem von abraten. Da die eingebauten Geräten mit der Busspannung versorgt werde. Die Busspannung ist aber für den Bus und nicht irgendwelche LEDs oder anderen Geräte gedacht!!!
    Wenn Ihr FastConnect Stecker verwendet, nehmt auch das enstsprechende Kabel dazu, sonst werdet Ihr Probleme bekommen.
    Wobei ich die FastConnect Stecker auch nicht so toll finde. Auch wenn alle sagen sie hätten diese schon seit Jahren im Einsatz und noch nie Probleme damit gehabt. Haben die Kollegen mal ihren Bus gemessen oder wird sich auf die grüne LED an den Geräten verlassen????

    Gebe allen einen Tip. Es gibt für den Profibus eine Spezifikation wie er Aufzubauen ist usw. haltet euch daran und es wird keine Probleme geben.

    Gruß kanusnice

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •