Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21

Thema: mit Delphi per Modbus/TCP mehrere SPSen auslesen

  1. #11
    Registriert seit
    07.06.2008
    Beiträge
    55
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe nun alle Dateien.
    Dazu gehören zwei Packages für Delphi 2009.

    Das Package "dclDelphiModbus2009.bpl" könnte ich durch öffen und installieren recht einfach einbinden.
    Das andere Package "DelphiModbus2009.bpl" bringt mir beim Installieren die Fehlermeldung, das es kein Entwurfszeitpackage ist.
    Peinlich: Wie binde ich dieses ein?

  2. #12
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Reden

    Hallo,

    Zitat Zitat von jank-automation
    Wie binde ich dieses ein?
    In Deinem Zip-File liegt eine weitere Datei ganz unschuldig, aber unbeachtet, herum. Sie heisst "readme.txt" und beschreibt die Installation der Packages.

    Gruß

    Question_mark
    Zitieren Zitieren Unschuldig und unbeachtet im Zip-File  

  3. #13
    Registriert seit
    07.06.2008
    Beiträge
    55
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Leider funktioniert es so nicht.

    Das designtime package bekomme ich installiert.
    Ich kann in einem neuen Projekt auch die Server- bzw. Client-Komponente anlegen.
    Jedoch bleibt TIdModbusServer rot unterlegt und es funktioniert nicht.
    Was mache ich falsch?

  4. #14
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Lächeln

    Hallo,

    Zitat Zitat von jank-automation
    Was mache ich falsch?
    Driss (auf Deutsch Sche..) auf die roten Kringel, da hat die IDE von Delphi so einige Macken. Versuche doch endlich mal das Programm zu compilieren und stelle die Fehlermeldungen hier im Forum ein. Du bist wohl eher ein Theoretiker, versuch es doch einfach mal mit Pragratismus und starre nicht wie das Kaninchen auf die Schlange, wenn mal etwas nicht wie theoretisch gedacht, nach Deinen Wünschen funktioniert.

    Gruß

    Question_mark
    Zitieren Zitieren ...  

  5. #15
    Registriert seit
    07.06.2008
    Beiträge
    55
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe endlich wieder etwas Zeit für das Thema gefunden.
    Auf meinem alten Rechner ging es absolut nicht.
    Da kamen jeden Tag andere Fehlermeldungen.
    Nun habe ich einen Rechner neu aufgesetzt, jetzt geht es.

    Aber da stellen sich neue Fragen.
    Warum kann ich nur 125MB aus dem Merkerbereich lesen?
    Die Stelle "<=125" habe ich gefunden.
    Wenn ich die Zahl hochnehme funktioniert es nicht mehr.

    Vielleicht hat jemand eine Lösung.
    Habe den Lesebefehl erstmal in eine Schleife gelegt.

  6. #16
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Zitat Zitat von jank-automation Beitrag anzeigen
    Habe endlich wieder etwas Zeit für das Thema gefunden.
    Auf meinem alten Rechner ging es absolut nicht.
    Da kamen jeden Tag andere Fehlermeldungen.
    Nun habe ich einen Rechner neu aufgesetzt, jetzt geht es.

    Aber da stellen sich neue Fragen.
    Warum kann ich nur 125MB aus dem Merkerbereich lesen?
    Die Stelle "<=125" habe ich gefunden.
    Wenn ich die Zahl hochnehme funktioniert es nicht mehr.

    Vielleicht hat jemand eine Lösung.
    Habe den Lesebefehl erstmal in eine Schleife gelegt.
    Weil das die maximale Anzahl der Register ist die in einem Telegramm übertragen werden können.
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  7. #17
    Registriert seit
    07.06.2008
    Beiträge
    55
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das ist leider nicht das was ich hören wollte.
    Aber danke für die schnelle Antwort.

  8. #18
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Zitat Zitat von jank-automation Beitrag anzeigen
    Das ist leider nicht das was ich hören wollte.
    Aber danke für die schnelle Antwort.
    Was wolltest Du denn sonst hören?

    Ich denke die Antwort von Lars ist doch eindeutig.
    Zudem hast Du ja selber schon die richtige Lösung genannt.

    Oder habe ich etwas falsch verstanden?
    Geändert von argv_user (08.06.2010 um 08:21 Uhr)

  9. #19
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Jep, des frag ich mich auch grad
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  10. #20
    Registriert seit
    07.06.2008
    Beiträge
    55
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    SORRY!

    Ich hatte gehofft, das es eine Möglichkeit gibt, mehr Daten auf einmal zu lesen.

    Nochmals DANKE für die Hilfe!

Ähnliche Themen

  1. Eine Visualisierung mehrere SPSén
    Von daniel1987 im Forum CODESYS und IEC61131
    Antworten: 19
    Letzter Beitrag: 31.08.2011, 12:00
  2. Antworten: 0
    Letzter Beitrag: 05.08.2010, 08:14
  3. Mehrere SPSen ein Ventil
    Von Tupo13 im Forum Programmierstrategien
    Antworten: 13
    Letzter Beitrag: 15.10.2008, 21:47
  4. Prodave in Delphi einbinden zum auslesen von DBs in S7-400
    Von Anonymous im Forum Hochsprachen - OPC
    Antworten: 12
    Letzter Beitrag: 02.10.2005, 12:13
  5. Modbus TCP - mit Delphi
    Von Kurt im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 07.10.2004, 21:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •