Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: redundante anbindung mit 2 CP341

  1. #1
    Registriert seit
    05.06.2006
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Servus,

    ich habe eine S7-317 CPU an die über einen ET200M aus Redundanzgründen 2 Stk. CP341 (RS422/485) angeschlossen sind zur Kommunikation mit einem Fremdsystem (DCS).
    Sobald allerdings das "vordere" der beiden hintereinander eingebauten Module ausfällt, geht das "hintere" auf Störung (SF, TXD u. RXD leuchten) und die Baugruppe wird auch nicht mehr von der SPS erkannt, was nun leider nicht im Sinne der geplanten Redundanz ist.
    Zitieren Zitieren redundante anbindung mit 2 CP341  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von spsrookie Beitrag anzeigen
    Sobald allerdings das "vordere" der beiden hintereinander eingebauten Module ausfällt, geht das "hintere" auf Störung (SF, TXD u. RXD leuchten) und die Baugruppe wird auch nicht mehr von der SPS erkannt, was nun leider nicht im Sinne der geplanten Redundanz ist.
    Wie fällt die denn aus? Wie testest Du das?
    Wäre es nicht sinnvoller eine 341 zur CPU zu setzen und nur die zweite zur ET200?
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. #3
    spsrookie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.06.2006
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Tja, ob die Konstellation so wie sie ist besonders sinnvoll ist, kann ich nicht wirklich beurteilen. Mir persönlich gefällt sie eigentlich auch nicht. Ist aber so vorgegeben und ich war heute auch zum ersten Mal auf der Anlage (komme zu dem Projekt leider wie die Jungfrau zum Kind).
    Mit "Ausfall der vorderen Baugruppe" meine ich - als ganz simplen Test - ihr die Stromversorgung zu kappen. Wenn ich allerdings länger darüber nachdenke, weiß ich nicht ob das der beste Test ist (war auch nicht meine Idee). Habe leider keine wirkliche Erfahrung mit CP341 und habe auch im Handbuch (in dem ich derzeit immer noch lese) bis jetzt nichts Hilfreiches gefunden.
    Bin für jeden Hinweis (z.B. Testmöglichkeiten) dankbar, da ich derzeit weit, weit weg von zu Hause und ziemlich in Zeitnot bin.

  4. #4
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von spsrookie Beitrag anzeigen
    Mit "Ausfall der vorderen Baugruppe" meine ich - als ganz simplen Test - ihr die Stromversorgung zu kappen. Wenn ich allerdings länger darüber nachdenke, weiß ich nicht ob das der beste Test ist (war auch nicht meine Idee). Habe leider keine wirkliche Erfahrung mit CP341 und habe auch im Handbuch (in dem ich derzeit immer noch lese) bis jetzt nichts Hilfreiches gefunden.
    Ja das Problem kenne ich. Seitdem bekommt der CP von mir immer den gleichen Plus wie die CPU, damit sie gemeinsam hoch laufen.
    Wie es sich hinter einer ET200M verhält kann ich nicht sagen weil ich das noch nie gemacht habe. Wenn die aber eine separate Spannungsversorgung hat könnte das bei einem Sicherungsfall auch Probleme machen.

    Einen wirklichen Ausfall simulieren ist schwierig, darum hat es mich ja auch interessiert wie Du das gemacht hast.
    Aus Erfahrung kann ich sagen, dass ich schon ein paar defekte CPs hatte.
    Die funktionierten einfach nicht mehr, gaben aber keine Störung oder Sammelfehler aus.
    Von daher sollte Deine Redundanz schon funktionieren.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  5. #5
    spsrookie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.06.2006
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann deine Erfahrungen mit defekten CPs nun auch bestätigen. Ein CP war wirklich defekt, ohne jegliche Anzeige eines Fehlers. Wurde getauscht und jetzt passt die Kommunikation.

Ähnliche Themen

  1. Redundante AO möglich?
    Von cosmosis im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 21.07.2010, 16:02
  2. redundante Steuerung
    Von michael82 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 03.03.2010, 15:53
  3. Redundante Anbindung einer S7-400H
    Von knarf im Forum HMI
    Antworten: 4
    Letzter Beitrag: 20.07.2009, 13:14
  4. Antworten: 0
    Letzter Beitrag: 08.01.2007, 09:39
  5. Redundante Pumpen
    Von charlie im Forum Programmierstrategien
    Antworten: 23
    Letzter Beitrag: 28.06.2006, 10:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •