Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: TCP/IP-Verbindungsabbruch durch Partner

  1. #1
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.

    Ich möchte mit Hilfe eines CP443-1 und des FC60 ein 120Byte langes Telegramm verschicken. Die TCP-Verbindung ist aufgebaut und ich kann sehen das im "Ruhezustand" diverse Telegramme ausgetauscht werden. (Broascast u.ä.) Jetzt stosse ich den FC60 an und sofort bricht die Verbindung ab und baut sich kurz danach wieder auf. AM FC60 wird als Status "keine Verbindung" angezeigt. Im Diagnosepuffer steht "Verbindungsabbruch durch Partner". Der "Partner" ist leider ratlos und ich irgendwie auch. Ich habe solche Verbindung schon öfters mal aufgebaut und nie gab es dieses Problem. Hier ist nur die mir zugewiesen Portnummer 50000 anders. Meist hab ich irgendwas im 2000er-Bereich. Kann das ein Problem sein ?
    Früher gab es Peitschen .... heute Terminkalender
    Zitieren Zitieren TCP/IP-Verbindungsabbruch durch Partner  

  2. #2
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Hängt der Partner im gleichen Netzwerk? Ist da ein konfigurierbarer Switch dazwischen oder eine Firewall? Softwarefirewall beim Partner auf dem PC (falls es ein PC ist)?

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Hallo Lila,

    ich kann mich erinnern, daß es irgendwelche Probleme mit den hohen Portnummern (>20.000?) gab, finde das aber gerade nicht wieder.
    Im Moment suche ich im Siemens-Forum.

    Falls Du an der Anlage sitzt: versuche mal, auf beiden Seiten einen Port 2000..2999 zu nutzen.

    Gruß
    Harald

  4. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Lipperlandstern (07.05.2010)

  5. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Welchen CP hast Du genau? MLFB und FW-Version?
    Das Problem wurde (glaube ich) in irgendeinem FW-Update behoben.

    Gruß
    Harald

  6. #5
    Avatar von Lipperlandstern
    Lipperlandstern ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Hallo Harald.

    Jepp es scheint an der Ports zu liegen. DALBI hat da was in der Doku (Seite137) gefunden. Ich werd das am Montag mal ausprobieren (lassen)...

    Der CP ist schon etwas älter ( ca. 8 Jahre ). Aber von der Firmware lass ich lieber die Finger


    Vielen dank für die Hilfe

    Axel
    Früher gab es Peitschen .... heute Terminkalender

  7. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    DALBI hat da was in der Doku (Seite137) gefunden.
    Das ist für mich der bisher eindeutigste Hinweis von Siemens.
    Ich habe nur diese beiden indirekten Hinweise auf die Portbegrenzung 2000 - 5000 gefunden:
    http://support.automation.siemens.co...ew/de/34010717
    http://www.automation.siemens.com/WW...48&language=de

    Laut erstem Link soll die Begrenzung aber nur bei einigen 31x-2PN-CPUs bis zu einem gewissen Firmwarestand existieren.

    Gruß
    Harald

  8. #7
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von PN/DP
    Laut erstem Link soll die Begrenzung aber nur bei einigen 31x-2PN-CPUs bis zu einem gewissen Firmwarestand existieren.
    Zitat Zitat von Lipperlandstern
    mit Hilfe eines CP443-1
    Womit das Problem wohl weiter offen bleibt..
    Aber trotzdem kann der LilaStern mal versuchsweise einen Portbereich zwischen 2000 bis 4999 testen, man weiss ja nie.

    Ausserdem hat uns der LilaStern noch nicht den Typ des Kommunikationspartner genannt (also S7, S5, PC oder was auch immer).

    Meistens tritt der vom LilaStern genannte Fehler bei einer fehlerhaften Projektierung der Verbindung auf. Das kann natürlich eben auch auf der Gegenseite falsch projektiert sein.

    Gruß

    Question_mark
    Zitieren Zitieren ???  

  9. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Zitat Zitat von Lipperlandstern Beitrag anzeigen
    Im Diagnosepuffer steht "Verbindungsabbruch durch Partner".
    Vielleicht ist ja der Partner eine solche betroffene 31x-2PN-CPU?
    Da kann der CP443-1 von Axel ja nichts dafür.

    Gruß
    Harald

  10. #9
    Avatar von Lipperlandstern
    Lipperlandstern ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Moin Moin.

    Also.... das Ding ist ein CP443-1
    BestNr 6GK7 443-1EX11-0XE0. Version 2.4.7 HW-Stand4.

    Der Partner ist ein WindoofPC. Ich glaube XP Prof bin aber nicht wirklich sicher. Auf diesem PC läuft eine selbstgeschriebene Applikation.

    Wie gesagt. Am Montag werden die Ports geändert und dann sehen wir weiter.
    Früher gab es Peitschen .... heute Terminkalender

  11. #10
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das S7-CPs für Industrial Ethernet Projektieren und in Betrieb nehmen Projektierungshandbuch (05/2008)
    ist etwas detaillierter bei der Auflistung der empfohlenen und nicht empfohlenen Portnummern.
    Die Port−Adressen ab 5000 werden vom System genutzt!

    Anmerkung:
    Wenn der Partner einen Port in diesem Bereich für den aktiven Verbindungsaufbau nutzt,
    dann ändern Sie den Port des Partners möglichst in einen Bereich <5000.
    Portbereiche Tabelle 5-3 Seite 151.gif
    Bild: Portbereiche Tabelle 5-3 Seite 151

    Gruß
    Harald
    Zitieren Zitieren Empfohlene Portbereiche  

  12. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Lipperlandstern (08.05.2010)

Ähnliche Themen

  1. Freelancer oder Partner [Voranfrage]
    Von jabba im Forum Suche - Biete
    Antworten: 4
    Letzter Beitrag: 19.07.2010, 16:17
  2. Antworten: 4
    Letzter Beitrag: 12.04.2010, 16:08
  3. Antworten: 3
    Letzter Beitrag: 07.03.2010, 16:14
  4. Antworten: 6
    Letzter Beitrag: 22.12.2009, 16:13
  5. Keine Rückmeldung bei Kommunikation mit Partner
    Von Guenther_Schild im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 29.10.2009, 20:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •