Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Was tun wenn Interbus IBS S7 300 DSC-T in Störung

  1. #1
    Registriert seit
    13.02.2006
    Beiträge
    130
    Danke
    14
    Erhielt 9 Danke für 7 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, ich habe eine S7-300 mit einem Phoenix-Interface IBS S7 300 DSC-T laufen. Am Interbus hängen 10 Slaves.
    Alles soweit gut, die Anzeige am DSC ist grün und "RUN".
    Doch bei Auftritt eines Fehlers am Bus (z.B. Spannungsausfall an einem Slave oder Defekt desselben) blockiert der Bus mit Fehler. Der Datenaustausch mit der Siemens-CPU wird beendet.

    Nach Behebung des Fehlers (z.B. Spannungswiederkehr beim Slave) geht der Bus wieder in RUN und läuft.

    Wenn ich jedoch einen defekten Slave habe und diesen eliminiere (d.h. Ein- und Ausgangsleitungen koppeln) oder den Bus ab diesem Punkt einfach abhänge, bringe ich den Bus nicht laufen, da er nicht mit der Konfig im Speicher des DSC-T übereinstimmt.
    Gibt's hierfür eine Möglichkeit, den Bus wieder laufen zu bringen? Kann ich die Slaves mittels Software (bzw. S7-Code) ein- und ausschalten (bzw. im Bus aktivieren und deaktivieren)?

    Wie kann ich in der S7 auslesen, an welchem Slave die Probleme aufgetreten sind? Ich habe mit dem DIAG-Baustein nur erhalten, dass ein Problem ansteht...


    Hat jemand Programmierbeispiele?

    Danke für eure Hilfe
    kassla
    Zitieren Zitieren Was tun wenn Interbus IBS S7 300 DSC-T in Störung  

  2. #2
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    da gehts von Phoenix einen Baustein DEVMOD. Der kann schalten, brücken usw.

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....
    Zitieren Zitieren Ibs  

  3. Folgender Benutzer sagt Danke zu sps-concept für den nützlichen Beitrag:

    kassla (03.09.2010)

  4. #3
    kassla ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.02.2006
    Beiträge
    130
    Danke
    14
    Erhielt 9 Danke für 7 Beiträge

    Standard

    kann den FC26 DEVMOD leider auf der CD nicht finden. Kann ihn mir jemand zur Verfügung stellen? Ev. mit Beispiel?

    Danke

  5. #4
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Zitat Zitat von kassla Beitrag anzeigen
    Wenn ich jedoch einen defekten Slave habe und diesen eliminiere (d.h. Ein- und Ausgangsleitungen koppeln) oder den Bus ab diesem Punkt einfach abhänge, bringe ich den Bus nicht laufen, da er nicht mit der Konfig im Speicher des DSC-T übereinstimmt.
    Gibt's hierfür eine Möglichkeit, den Bus wieder laufen zu bringen? Kann ich die Slaves mittels Software (bzw. S7-Code) ein- und ausschalten (bzw. im Bus aktivieren und deaktivieren)?



    Danke für eure Hilfe
    kassla
    Mittels der CMD-Software, mit der du den Aufbau projektiert und in die Anschaltbaugruppe geladen hast, kannst Du auch Teilnehmer ausblenden, welche du aus dem Busaufbau entfernt hast bzw ab da wo du den Bus abgehängt hast.

    Was Deine CPU zu den fehlenden E/A meint musst Du selbst im entsprechenden OB programmieren.

    Thomas

  6. #5
    kassla ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.02.2006
    Beiträge
    130
    Danke
    14
    Erhielt 9 Danke für 7 Beiträge

    Standard

    Das mit der CMD-Software ist mir schon klar. Doch ich möchte den Betreiber der Anlage nicht mit der Konfig-SW arbeiten lassen (müssen), lieber wär mir über ein angeschlossenes Siemens-Touchpanel in der SPS die Slaves zu steuern (ein/aus).

    Leider habe ich den FC26 immer noch nicht gefunden - nur einen FB26, doch auch diesen ohne Kommentar/Hilfe. Somit kenn ich seine genaue Funktion nicht . Vielleicht kann mir jemand für den FC26 Unterstützung liefern...
    Danke

  7. #6
    Registriert seit
    29.07.2008
    Beiträge
    143
    Danke
    4
    Erhielt 27 Danke für 21 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    rufe bei der Hotline von Phoenix an, die geben dir den Baustein und helfen dir auch bei der Umsetzung, insbesondere was dabei alles zu beachten ist

  8. Folgender Benutzer sagt Danke zu Oerw für den nützlichen Beitrag:

    kassla (07.09.2010)

Ähnliche Themen

  1. Störung des MPI zum PG
    Von action im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 30.03.2009, 20:16
  2. Störung MPI Adapter
    Von thome im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 07.02.2008, 08:33
  3. Profibus-störung
    Von johnij im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 12.11.2007, 15:03
  4. Störung auf der IM 157 DP/PA - Link
    Von JandeFun im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 27.05.2007, 15:51
  5. CPU Störung mit CP 343-1
    Von Lars Bizare im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 05.01.2007, 14:40

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •