Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Profibus Fehler

  1. #1
    Registriert seit
    25.10.2010
    Beiträge
    239
    Danke
    107
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich gehe von der PG per Profinet zu einer 315 PN/DP, die Peripherie will ich aber mit per Profibus ansprechen. Im Netpro ist an die PN-OI Schnittstelle das PG verbunden. An das MPI/Dp ein Buskoppler per Profibus. Die Perepherie müsste richtig projektiert sein.

    die sps macht folgende Fehlermeldung:

    Code:
    Ereignis 10 von 10:  Ereignis-ID 16# 2942
    Peripherie-Zugriffsfehler, lesend 
    P-Bereich , Wortzugriff, Zugriffsadresse:    288
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse:  1
    externer Fehler, kommendes Ereignis
    SF Fehler ist an. BF1 blinkt.

    wie kann ich das Probelm beheben ?

    Grüße und Danke
    Zitieren Zitieren Profibus Fehler  

  2. #2
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Zitat Zitat von Limette Beitrag anzeigen
    Hallo,

    ich gehe von der PG per Profinet zu einer 315 PN/DP, die Peripherie will ich aber mit per Profibus ansprechen. Im Netpro ist an die PN-OI Schnittstelle das PG verbunden. An das MPI/Dp ein Buskoppler per Profibus. Die Perepherie müsste richtig projektiert sein.

    SF Fehler ist an. BF1 blinkt.

    wie kann ich das Probelm beheben ?

    Grüße und Danke
    Der Eintrag des Diagnosepuffers besagt ja, dass im Programm an einer Stelle das PEW288 gelesen werden soll - und dieses PEW nicht vorhanden ist. Was ist das denn für ein Buskoppler? Ein DP/DP-Koppler? Falls ja, ist auch die projektierte Adresse am "Mäuseklavier" eingestellt (Spannungslos)? Mach am besten mal einen Screenshot deiner HW-Konfig und stell den hier rein... Hast Du die HW-Konfig auch in die CPU geladen?

    Gruß Approx
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  3. #3
    Limette ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2010
    Beiträge
    239
    Danke
    107
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von Approx Beitrag anzeigen
    Der Eintrag des Diagnosepuffers besagt ja, dass im Programm an einer Stelle das PEW288 gelesen werden soll - und dieses PEW nicht vorhanden ist. Was ist das denn für ein Buskoppler? Ein DP/DP-Koppler? ? Mach am besten mal einen Screenshot deiner HW-Konfig und stell den hier rein... Hast Du die HW-Konfig auch in die CPU geladen?

    Gruß Approx
    ein beckhoff BK 3120. Daran hängen DIs und DOs. Hab eigentlich alles nach Anleitung projektiert. Kann leider grad kein Screenshot liefern. Morgen früh aber auf jeden Fall.

    Ja, HW-Konfig habe ich geladen.
    Falls ja, ist auch die projektierte Adresse am "Mäuseklavier" eingestellt (Spannungslos)
    Das kann natürlich gut sein. Ich weiß nicht mal genau welche er in Step 7 hat. Nur die Diagnoseadresse 2047 sticht ins Auge.

  4. #4
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Zitat Zitat von Limette Beitrag anzeigen
    ein beckhoff BK 3120. Daran hängen DIs und DOs. Hab eigentlich alles nach Anleitung projektiert. Kann leider grad kein Screenshot liefern. Morgen früh aber auf jeden Fall.

    Ja, HW-Konfig habe ich geladen.
    Das kann natürlich gut sein. Ich weiß nicht mal genau welche er in Step 7 hat. Nur die Diagnoseadresse 2047 sticht ins Auge.
    Kenne dieses Bauteil zwar nicht, aber wie ich sehe hat das Teil zwei Adresswahlschalter, wo die DP-Adresse für Step7 eingestellt wird (im Bild z.B. 11).
    BK3120.jpgDiese Adresse stellst Du in der HW-Konfig von Step7 ein. Eine installierte GSD und eingefügtes BK3120 setze ich jetzt mal voraus.
    Gruß Approx
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  5. #5
    Limette ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2010
    Beiträge
    239
    Danke
    107
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von Approx Beitrag anzeigen
    Kenne dieses Bauteil zwar nicht, aber wie ich sehe hat das Teil zwei Adresswahlschalter, wo die DP-Adresse für Step7 eingestellt wird (im Bild z.B. 11).
    BK3120.jpgDiese Adresse stellst Du in der HW-Konfig von Step7 ein. Eine installierte GSD und eingefügtes BK3120 setze ich jetzt mal voraus.
    Gruß Approx
    danke.

    Jetzt bringt er noch das:

    Ereignis 4 von 10: Ereignis-ID 16# 4304
    STOP durch PG-Stop-Bedienung oder wegen SFB 20 "STOP"
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    kommendes Ereignis

  6. #6
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Besser Du postest den gesamten Inhalt des Diagnosepuffers. Der Eintrag kommt auch beim Laden der HW-Konfig. Ohne einen Zusammenhang zu kennen, ist es schwierig. Der Screenshot der HW-Konfig steht ja auch noch aus. Hier will keiner deine Anlage nachbauen- verstehe das "allesausdernaseziehenmüssen" irgendwie nicht.
    Approx
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  7. #7
    Limette ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2010
    Beiträge
    239
    Danke
    107
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von Approx Beitrag anzeigen
    Besser Du postest den gesamten Inhalt des Diagnosepuffers. Der Eintrag kommt auch beim Laden der HW-Konfig. Ohne einen Zusammenhang zu kennen, ist es schwierig. Der Screenshot der HW-Konfig steht ja auch noch aus. Hier will keiner deine Anlage nachbauen- verstehe das "allesausdernaseziehenmüssen" irgendwie nicht.
    Approx
    "allesausdernaseziehenmüssen"


    Ereignis 1 von 5: Ereignis-ID 16# 4302
    Betriebszustandsübergang von ANLAUF nach RUN
    Anlaufinformation:
    - Anlauf mit geändertem Systemausbau
    - Soll-/Istdifferenz vorhanden
    - Uhr für Zeitstempel bei letztem NETZ-EIN gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Bisheriger Betriebszustand: ANLAUF (Neustart/Warmstart)
    Angeforderter Betriebszustand: RUN
    kommendes Ereignis
    10:23:13.910 25.03.2011


    Ereignis 2 von 5: Ereignis-ID 16# 1381
    Manuelle Neustart (Warmstart)-Anforderung
    STOP-Ursache: STOP durch PG-Stop-Bedienung oder wegen SFB 20 "STOP"
    Anlaufinformation:
    - Anlauf mit geändertem Systemausbau
    - Soll-/Istdifferenz vorhanden
    - Uhr für Zeitstempel bei letztem NETZ-EIN gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Angeforderter OB: Anlauf-OB (OB 100)
    Prioritätsklasse: 27
    kommendes Ereignis
    10:23:13.908 25.03.2011


    Ereignis 3 von 5: Ereignis-ID 16# 4301
    Betriebszustandsübergang von STOP nach ANLAUF
    STOP-Ursache: STOP durch PG-Stop-Bedienung oder wegen SFB 20 "STOP"
    Anlaufinformation:
    - Anlauf mit geändertem Systemausbau
    - Soll-/Istdifferenz vorhanden
    - Uhr für Zeitstempel bei letztem NETZ-EIN gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN gepuffert
    Bisheriger Betriebszustand: STOP (intern)
    Angeforderter Betriebszustand: ANLAUF (Neustart/Warmstart)
    kommendes Ereignis
    10:23:13.761 25.03.2011


    Ereignis 4 von 5: Ereignis-ID 16# 5371
    Dezentrale Peripherie: Ende der Synchronisation mit einem DP-Master
    Steckplatz des DP-Masters: 2
    Anzahl der dezentralen Stationen: 0
    kommendes Ereignis
    10:23:02.709 25.03.2011


    Ereignis 5 von 5: Ereignis-ID 16# 4304
    STOP durch PG-Stop-Bedienung oder wegen SFB 20 "STOP"
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    kommendes Ereignis
    10:22:50.524 25.03.2011
    screenshot
    http://img145.imageshack.us/i/unbenanntus.jpg/

  8. #8
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Der Diagnosepuffer besagt, daß die in die CPU geladene HW-Konfiguration nicht mit dem übereinstimmt, was die CPU an angeschlossenen Komponenten erkannt hat. Zu deutsch: Nicht das angeschlossen, was dran sein soll. Hast Du die Teilnehmeradresse des BK3120 auch tatsächlich am Gerät auf "11" eingestellt? Nach Adresseinstellung auch mal die Spannung am Gerät aus/eingeschaltet? Sind real noch weitere Teilnehmer am Profibus angeschlossen? Wenn nicht, sind sowohl an der CPU, als auch am BK3120 die Abschlußwiderstände am Stecker auf "ON" eingestellt?

    Approx
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  9. #9
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Ein Fehler könnte auch sein, dass die Module am Buskoppler nicht mit der HW-Konfig übereinstimmen.
    and we all support the team (S.King - Die Arena)

  10. #10
    Limette ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2010
    Beiträge
    239
    Danke
    107
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe den Fehler jetzt gefunden:

    ich habe die klemmen falsch zusammen gesteckt. Nach dem Buskoppler muss erst die analoge Klemme kommen, danach erst die DI/DO. Wusste nicht dass man da eine Reihenfolge beachten muss.

    Danke für eure Hilfe.

Ähnliche Themen

  1. Profibus Fehler?
    Von hbedir im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 06.01.2010, 20:01
  2. Profibus-Fehler
    Von ATRÖ im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 17.02.2009, 07:35
  3. S7-400 Kommunikations-Fehler (Profibus)
    Von ugums im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 21.10.2008, 09:17
  4. Erkennung Profibus Fehler
    Von zwerg77 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.04.2008, 14:55
  5. Profibus Fehler
    Von Rose im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.08.2006, 07:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •