Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 30 von 30

Thema: Neue AS-I Geräte einbinden

  1. #21
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von MW Beitrag anzeigen
    Die Zahl muss dort aber auch als Hex-Zahl ran, also nix mit Dezimal !!!


    PS: Bei der Zahl Null gibts natürlich nicht viel zu wandeln.

    Wenn die Hardware stimmt, kann er doch direkt auf die Eingänge zugreifen.


    bike

  2. #22
    omega ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.09.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Problem mit der Adresse scheint gelöst. Habe die 10 genommen, die in Klammern vor dem Link20E im HW-Konfig steht.

    Nächstes Problem:

    Wenn ich dem FC_ASI jetzt sagen will, dass er die adresse ändern soll, Passiert gar nichts er bleibt quasi im Status "Auftrag wird bearbeitet" stehen und gibt mir keinen "Done" oder "Error" zurück. Also habe ich nochmal das Handbuch genommen und da steht folgendes:

    Gestalten Sie im Anwenderprogramm die Kommandobearbeitung wie folgt:

    1. Im Neustartzweig Ihres S7–Anwenderprogrammes rufen Sie den FC ASI_3422 einmalig mit dem Parameterwert STARTUP = TRUE auf.


    2. Im Anwenderprogramm spezifizieren Sie in einem Sendepuffer den Kommandoaufruf. Diesen Sendepuffer übergeben Sie mit dem Aufrufparameter SEND.
    3. Je nach Kommandotyp benötigen Sie einen Antwortpuffer. Diesen Antwortpuffer übergeben Sie mit dem Aufrufparameter RECV. Für Statusinformationen wird der Antwortpuffer bei dieser FC–Schnittstelle nicht benötigt.

    4. Aktivieren Sie den Auftrag über den Parameter ACT=1;

    5. Anschließend fragen Sie die Parameter DONE, ERROR und STATUS ab. Beachten Sie für die Hantierung im Anwenderprogramm den unten dargestellten Signalverlauf für diese Parameter

    .......

    Also hab ich versucht, den "Startup" zu setzen, allerdings kann ich die CPU nicht einfach mal so stoppen, da jede minute Stop mal eben 300 Euronen kostet. Und nach einem Stop hab ich ca. 15 minuten Arbeit, um alles wieder zu starten.
    Wenn ich das mache, siehts folgendermaßen aus:



    Der Code in Status sagt laut Handbuch: Kennung nach Neustart (STARTUP=TRUE)
    Und wie man Sieht ist der Error-Ausgang gesetzt.

    Muss ich die CPU wirklich neustarten, oder hab ich da vielleicht noch nen anderen Fehler drin?

  3. #23
    Registriert seit
    01.11.2007
    Beiträge
    1.235
    Danke
    91
    Erhielt 406 Danke für 367 Beiträge

    Standard

    Zitat Zitat von omega Beitrag anzeigen
    ... da jede minute Stop mal eben 300 Euronen kostet. Und nach einem Stop hab ich ca. 15 minuten Arbeit, um alles wieder zu starten.
    D.h., pro Versuch könntest du ca. 15 Adressiergeräte kaufen!
    Hast du denn keine Ersatzteile, mit denen du dir einen Testaufbau machen kannst?

    Grüße von HaDi

  4. #24
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.476
    Danke
    1.140
    Erhielt 1.238 Danke für 971 Beiträge

    Standard

    Mal ne "blöde" Frage:
    Bist du sicher, dass du den DP-ASI-Gateway mit dem FC342 parametrieren kannst? Ich kenn den Baustein eigentlich nur in Verbindung mit der CP342-2.
    Da ergibt auch der Parameter LADDR einen "richtigen" Sinn. Dort ist es nämlich die Baugruppenadresse.

    Ansonsten würde ich auch sagen, dass ein Adressiergerät sinnvoll ist.

    Gruß
    Dieter

  5. #25
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also laut Handbuch des Links funktioniert der FC3422 auch beim Link.
    Allerdings verrät mir das ganze auch, das dieses vom TE schlicht und ergreifend
    in keinster Weise gelesen wurde.

    LADDR muss in seinem Fall nämlich 0 sein, um mal mit was ganz elementaren zu beginnen.

    Neueres Handbuch:
    http://support.automation.siemens.co...ew/de/33563718
    Älteres Handbuch:
    http://support.automation.siemens.co...iew/de/5281638

    Allerdings sind die Handbücher zugegebenermaßen nicht so schön geschrieben,
    als das man das von einmal drüberlesen begreifen würde.

    Nach wie vor ist aber zu sagen, das das Adressierungsgerät unterm Strich erheblich billiger kommt,
    als dieses Gebastel was der TE nun anfangen wird müssen, insbesondere vor dem Hintergrund "Produktionsausfall".

    Mfg
    Manuel
    Geändert von MSB (23.09.2011 um 07:52 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. #26
    omega ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.09.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ok, ich denke Ihr habt recht, so teuer kann das PG für die Slaves nicht sein.
    Werde mich mal schlau machen...

  7. #27
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von omega Beitrag anzeigen
    da jede minute Stop mal eben 300 Euronen kostet.
    Und nach einem Stop hab ich ca. 15 minuten Arbeit, um alles wieder zu starten.
    Bei diesen Preisen würde ich mir jemanden ins Haus holen, der es kann.


    bike

  8. #28
    omega ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.09.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Nochmal zur Info:

    Etwas nicht zu können, ist (für mich) noch lange kein Grund aufzugeben.

    Ich mache soweit mir möglich ist, alles selbst. Vom Haus verputzen übers Programmieren, bis hin zum Zylinderkopfdichtungswechsel bei meinem V6 hab ich schon viel hinter mich gebracht. Da werd ich es doch wohl hinbekommen, diese drei dämlichen Slaves einzuprogramieren.

    Und zum Thema zurück:
    Wer hat schonmal mit dem FC_ASi 3422 gearbeitet? Gibts irgendwas, was ich dabei beachten muss, oder vergessen habe, oder einen Tipp, warum es nicht funktioniert?
    (LADDR auf 0 setzen, hab ich bisher noch nicht ausprobiert, wird aber heute erledigt.)
    Geändert von omega (26.09.2011 um 09:22 Uhr)

  9. #29
    omega ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.09.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab mir ein Programmiergerät ausgeliehen. Die Adressen waren übrigens werksseitig auf 1a eingestellt. Das Adressen einstellen hat insgesamt ne halbe Stunde gekostet. Ohne Produktionsausfall. Das Tasterprojektieren kann ich nun mal zwischenrein schieben, ohne dass die BHKW's dafür ausgemacht werden müssen.

    Grüße

  10. #30
    Registriert seit
    03.09.2006
    Ort
    bei Ulm
    Beiträge
    210
    Danke
    82
    Erhielt 8 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Einfach mal ein neues ASI Modul auf Adresse 21 einstellen. Wenn das ne ältere Anlage ist wird die noch auf "A" laufen max 32 Modul und schauen ob die eingäne ab Byte 9 reinkommen

    Geändert von Guste (13.10.2011 um 21:17 Uhr) Grund: fehler

Ähnliche Themen

  1. pvi für mobile geräte
    Von knorpe im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 15.11.2010, 08:56
  2. System Manager findet keine neue Geräte
    Von Cheburashka im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 28.02.2010, 20:57
  3. Preisliste HMI Geräte
    Von Ralf62 im Forum HMI
    Antworten: 8
    Letzter Beitrag: 22.06.2009, 18:02
  4. Geräte Schalten
    Von MatMer im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 09.08.2005, 10:00
  5. WinCE Geräte
    Von Jochen Kühner im Forum HMI
    Antworten: 5
    Letzter Beitrag: 09.07.2004, 09:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •