Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Interbus LWL Terminierung

  1. #1
    Registriert seit
    03.06.2012
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe eine Schweißsteuerung die als INTERBUS-Slave mit eingebauten ANYBus-Modul AB3120 per LWL-Fernbus mit einer Robotersteuerung(Master) kommuniziert! Funktioniert seit Jahren!
    Nun soll ein weiter Slave an den LWL-Fernbus angeschlossen werden! Laut HMS-Doku terminiert sich ein ANYBUS Modul selbst, d.h. es merkt ob ein weiter Teilnehmer im Ring folgt, wenn ja sendet es Daten an diesen, wenn nein schließt es den Ring automatisch!?

    Der neue Slave2 hängt also an Remote-Out des ersten Slave1. Am Slave 2 kommen laut Status-LEDs keine Fernbusverbindung an. Zieht man die LWL-Kabel ab, sieht man das Slave2 auf der Sendeleitung permanent sendet(Licht in Remote-IN LWL Sende-Buchse). Merkwürdig ist das Verhalten des SLAVE1, dort ist bei abgezogenen Kabeln die REMOTE-OUT-Sende-Buchse ohne Licht, Zieht man die REMOTE-IN-Kabel ab(also komplett unbeschaltet), haben beide Sende-Buchsen (Remote IN und REMOTE-OUT) Licht- Sobald man REMOTE-IN ansteckt, geht SLAVE1 ordnungsgemäß ans Netz aber REMOTE-OUT-Buchse schaltet Licht sofort ab-ok wäre ja in Ordnung, da kein weiterführendes LWL Kabel angeschlossen ist erfolgt automatische Terminierung!? Wenn ich aber Kabel anschließe, kommen aber am Slave 2 laut Status-LEDs keine Fernbusverbindung an. Ich habe also das Gefühl, das der Slave1 kein Licht an Slave2 aussendet!? Das Verhalten ist unabhängig davon, ob ich im CMD-TOOL einen oder beide Slaves konfiguriere!? CMD-Diagnose bringt immer Busfehler, kein Teilnehmer 3(Slave2) gefunden!? LWL-Kabel ist getestet und ok!

    Fragen:
    1. Ist das normal, das an REMOTE-OUT eines INTERBUS-Slaves kein Licht zu sehen ist wenn REMOTE-OUT unbeschaltet ist?
    2. Ist die interne Terminierung eines Slave abhängig von der Konfiguration des Masters oder macht das der Slave selbst?

    Danke für Eure Hilfe

    dust2
    Zitieren Zitieren Interbus LWL Terminierung  

  2. #2
    Registriert seit
    28.06.2009
    Beiträge
    16
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo dust2,

    der Interbus benötigt keine Terminierung, allerdings können die Teilnehmer Ihre weiterführende Schnittstellen schliessen und damit den Interbusring abschliessen. Aktuelle Teilnehmer (egal ob Kupfer oder LWL) erkennen auch ob ein weiterer Teilnehmer folgt oder nicht, entsprechend erkennt der Master auch ob mehr Module vorhanden sind als projektiert. Bei älteren TN (so um die 10 Jahre) brauchte es bei Kupfer eine Brück im Out Stecker oder ein Switch bei LWL (End/Next).

    Der beschriebende Fehler ist aber seltsam. Ich könnte mir aber vorstellen das die automatische Erkennung des TN1 nicht mehr funktioniert.
    Normal ist das die Out Schnittstelle Dauerlicht gibt wenn In abgezogen ist, bzw. der Bus im Reset ist, dann ist die Regelung nicht aktiv und die Diode gibt Dauerlicht.

    Versuch mal folgendes:
    - Falls TN 1 und 2 gleich sind tausche Sie mal miteinander, wenn TN 1 defekt ist sollte er an der Out von TN 2 funktionieren.
    - Ich weiss nicht welchen Master du hast, aber bring ihn mal in den Modus Ready (kein Projekt geladen) und lese mal den Konfigurationsrahmen ein,
    Mal schaun was er findet.

    Gruss

    Frank

  3. #3
    dust2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.06.2012
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Frank,
    habe die Sache zum Laufen bekommen, Problem war TN2(Slave2), dort war falsche VME-Bus-Adresse für das VME-Rack gejumpert, so das die Karte gar nicht richtig lief! Hatte vorher miteinen PHÖNIX-DIO-Modul als Slave2 getestet das lief sofort!Warum TN1 trotzdem kein Dauerlicht auf REMOTE-OUT gab, bleibt ein Rätsel, alle anderen Slaves tuen dies!
    Danke nochmals für Deine Hilfe!
    dust2
    Geändert von dust2 (23.07.2012 um 10:52 Uhr)

Ähnliche Themen

  1. Hirschmann LWL - Koppler
    Von felix_77 im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 06.03.2012, 16:45
  2. Terminierung und Anzahl OLM im DP
    Von xstef im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 26.12.2010, 23:21
  3. INTERBUS IBS S7 300 BC-T mit LWL-Anbindung
    Von pretender2009 im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 07.12.2009, 23:33
  4. Feldbus über LWL
    Von MarkusP im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 19.01.2007, 11:24
  5. Datenübermittlung via LWL
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 04.12.2005, 13:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •