Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Profibus via IBH-Link

  1. #1
    Registriert seit
    08.08.2011
    Beiträge
    57
    Danke
    34
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich versuche gerade meinen Laptop per Profibus mit einer S7 zu verbinden. Dazu soll eine IBH-Link verwendet werden. Folgende Informationen könnten nützlich sein:
    - Der IBH Adapter setzt MPI bzw Profibus auf Ethernet um
    - Ich verwende STEP7
    - mit MPI funktioniert alles problemlos
    - Wenn ich auf Profibus umstelle und auf Diagnose gehe werden alle Busteilnehmer richtig angezeigt.
    - ABER es werden keine Stationen gefunden
    - gleicher IBH-Adapter funktionert am Laptop eines Kolegen tadellos (Ebenfalls STEP7)
    - Ich verwende Windows7 (wie der Kolege) und habe die IBH-Treiber von der gleichen CD wie der Kolege installiert.
    - Ich verwende eine 32Bit Windowsinstallation auf 64Bit Hardware (Thinkpad W520)

    hoffe das dass die wichtigsten Punke sind. Kann mir jemand weiterhelfen? Danke im Vorraus


    lg
    Zitieren Zitieren Profibus via IBH-Link  

  2. #2
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Du legst ja für den IBH-Adapter eine Station an (unter PC-PG-Schnittstelle IBHNet(Profibus) und dan Eigenschaften). Die ist vielleicht nicht identisch mit dem, was der Kollege auf seinem Laptop hat, z.B. die PB-Adresse, die der IBH_Link benutzt.

  3. #3
    alb ist offline Benutzer
    Themenstarter
    Registriert seit
    08.08.2011
    Beiträge
    57
    Danke
    34
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    danke für die Antwort. Ich glaube du meinst die Stelle an der ich die Parameter wie Baudrate, Teilnehmeradresse, etc. in den IBH-Link schreiben kann. Das Haben wir verglichen und es stimmt überein. Unter Diagnose werden die Stationen auch richtig angezeigt. Noch weitere Ideen?

  4. #4
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    bild2.GIFbild1.GIFIch meine die BEIDEN Stellen, die die Bilder zeigen:

  5. Folgender Benutzer sagt Danke zu Zottel für den nützlichen Beitrag:

    alb (11.06.2013)

  6. #5
    alb ist offline Benutzer
    Themenstarter
    Registriert seit
    08.08.2011
    Beiträge
    57
    Danke
    34
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    es stimmt an beiden Stellen überein. ich versuche es jetzt gerade mit einer ReserveCPU auf dem Schreibtisch. Ziel ist es den Laptop via IBH-Link als PG an die X2 Profibusschnittstelle anzuschließen. Ich würde jetzt mal Schritt für Schritt beschreiben wie ich es versucht habe:
    Ich starte mit einem leeren Step 7 Projekt und einer urgelöschten CPU.
    Ich stecke den IBH-LInk(mpi) auf die MPI schnittstell + Stationen laden in PG -> Die Haredware erscheint im Projekt (Netzteil, CPU, Backplane)
    Ich öffne die Hardwarekonfig, Profibusmaster einfügen an X2.
    Objekteigenschaften: 1,5 Mbit, Adresse 2, Subnetz Profibus, Betriebsart Master, Modus S7-kompatibel
    Hardwarekonfig in CPU schreiben.

    PG-Schnittstelle auf Profibus stellen (Baudrate 1,5 Mbit Adresse 1)
    Dass stelle ich an zwei Stellen um: einmal den IBHLink (Dauerhaft speichern + Neustart) und dann die Station.
    IBH-Link auf X2 stecken
    Bei einer Diagnose wird die CPU als Busteilnehmer erkannt.

    Aber, wenn ich bei Stationen Laden in PG auf aktualisieren klicke kommt die Meldung "Online: Netzwerkfehler (33:1666"

    Ich hoffe man kann meinem gescreibsel folgen. irgendjemand ne Idee?

    nochmal danke im vorraus

  7. #6
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    ok du lädst eine CPU über MPI hoch, änderst offline den Modus auf PROFIBUS und versuchst dann auf die unkonfigurierte Schnittstell mit PROFIBUS online zu gehen ? So lese ich das

    Vorschlag:
    Den Adapter erstmal auf MPI lasen und die geänderte HWConfig über MPI laden, nach neustart der CPU den Adapter auf PROFIBUS umstellen/umstecken und fertig ist die Laube

    Es ist auch nie verkehrt zu erwähnen welche CPU da eigentlich verwendet wird

  8. #7
    alb ist offline Benutzer
    Themenstarter
    Registriert seit
    08.08.2011
    Beiträge
    57
    Danke
    34
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    Hochladen und neustart habe ich natürlich gemacht. Sorry falls das uneindeutig beschrieben war. funktionieren tuts leider trotzdem nicht. Dass die CPU bei Schnittstellen Diagnose als Profibusteilnehmer angezeigt wird nehme ich mal als Indiz dafür das die Änderungen wirksam sind. sehe ich das richtig?

    Könnte es irgendein Problem im Hintergrund sein? Treiber-Neuinstallation und Firmwareupdate des IBH-Links haben bisher aber nicht geholfen.

    ps: CPU ist eine 414-2-DB
    Geändert von alb (11.06.2013 um 16:57 Uhr)

  9. #8
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    moment. Problem ist doch das du nicht mehr auf die CPU online kommst nachdem du den Adapter umgesteckt hast und umprojektiert hast.
    Versuch doch einfach mal deine Projektierung zu laden ohne den Adapter umzustecken und einfach die HW Config über MPI zu laden und danach erst umstecken auf x2

  10. #9
    alb ist offline Benutzer
    Themenstarter
    Registriert seit
    08.08.2011
    Beiträge
    57
    Danke
    34
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, genau so mach ich dass
    und danach möchte ich per Profibus auf die CPU, was dann nicht geht

Ähnliche Themen

  1. IBH Link S7++ & CPU314 & TP177B mit Profibus
    Von CrazyMC im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 25.03.2012, 22:12
  2. IBH Link S7 Plus, Profibus Problem
    Von Samiel im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 07.10.2011, 08:13
  3. IBH Net für IBH Link S7 Plus frisst Systemleistung
    Von vierlagig im Forum PC- und Netzwerktechnik
    Antworten: 2
    Letzter Beitrag: 30.08.2011, 17:16
  4. IBH Link Ethernet/MPI/Profibus ??
    Von B72 im Forum Feldbusse
    Antworten: 21
    Letzter Beitrag: 13.11.2007, 22:19
  5. S7-Netlink Plus / IBH Link S7 Plus
    Von Christoph Mohr im Forum Werbung und Produktneuheiten
    Antworten: 1
    Letzter Beitrag: 19.09.2006, 16:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •