Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: CANopen: Modicon M340 <-> Altivar 71 (beide Schneider), rätselhaftes NMT-Verhalten

  1. #1
    Registriert seit
    01.09.2008
    Ort
    Berlin
    Beiträge
    172
    Danke
    51
    Erhielt 51 Danke für 44 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Leute,

    ich bin grade dabei eine Modicon M340 (SPS) mit einem Altivar 71 (FU) via CANopen zu verbinden.
    Dabei befinden sich noch 2 weitere Geräte im Netz, die man aber erstmal vernachlässigen kann.

    Das Problem besteht darin, das beim FU sporadisch (alle 2 Minuten, teilweise öfters) die Verbindung abbricht.
    Der FU geht dann wieder in den NMT-Status "Startbereit" und wechselt nach kurzer zeit zu "Betrieb". Der Status hällt
    jedoch nicht sehr lange an, so das es wieder zu einen Zusammenbruch kommt. Das Ganze pendelt so hin und her.
    Und leider kann ich mir den Fehler nicht erklären, bzw. ihn nicht weiter eingrenzen.

    Der FU sagt: (5) Fehler im NMT-Zustandsdiagramm
    Die SPS sagt: Ein- oder mehrere Slaves nicht verfügbar oder in Run.

    Problem ist, das ich das zeitliche aussteigen nicht mit irgendwelchen Parametern in Verbindung bringen kann. Zum Beispiel hat die Variation der Heartbeat-Zeit zu keiner Änderung in der Fehlerhäufigkeit geführt.

    Langsam bin ich jetzt leider überfragt. Die Doku macht auch keine präzisen Angaben.

    Hat einer von euch damit bereit's Erfahrung, oder vielleicht noch einen Tipp?

    Danke schonmal,

    Gruß
    ect'ler

    PS: Der Support von Schneider will mir seit 4 Werktagen nicht antworten.
    Zitieren Zitieren CANopen: Modicon M340 <-> Altivar 71 (beide Schneider), rätselhaftes NMT-Verhalten  

  2. #2
    Registriert seit
    25.05.2011
    Ort
    Holzgerlingen
    Beiträge
    99
    Danke
    7
    Erhielt 19 Danke für 17 Beiträge

    Standard

    Hallo H. ect'ler,

    Hört sich nach einem EMV Problem an.

    Folgende Vorgehenseise würde ich empfehlen.
    1) Schritt 1: Prüfen der Hardware, Wellenphysikalisch- Telegramverkehr abschalten Schleifenwiderstand bei beiden eigelegten Busabschlüssen 60 Ohm.
    CAN ground nur an einer Stelle auf Masse gelegt. Schirm beidseitig auf Masse gelegt. Masse sollte ruhig sein. Überwachen des Schirmstromes mit AC 50 A. Beobachten der Error Telegramme. usw. Messgeräte zum Prüfen der Hardware leihen wir gegen geringe Gebühr auch aus.
    2) Schritt 2 : Prüfen der Software ohne den Antrieb in Regelung zu nehmen.


    Hans-Ludwig Göhringer

    mit freundlichen Grüßen aus dem Schönbuch
    Hans-Ludwig Göhringer
    IVG Göhringer Mönchweg 5 71088 Holzgerlingen Tel.:07031 607880 Fax: 07031 607881 Mobil.:0172-7671463 eMail: H-L.Goehringer@t-online.de <http://www.i-v-g.de>

    Messgeräte für Bussysteme, Dienstleistungen an Bussystemen: Abnahmemessungen, Troubleshooting und Schulungen für Profibus,Profinet, CAN, AS-Interface, usw.

  3. Folgender Benutzer sagt Danke zu Hans-Ludwig für den nützlichen Beitrag:

    ebt'ler (08.07.2013)

  4. #3
    Avatar von ebt'ler
    ebt'ler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.09.2008
    Ort
    Berlin
    Beiträge
    172
    Danke
    51
    Erhielt 51 Danke für 44 Beiträge

    Standard

    Das Problem besteht auch wenn der FU nicht läuft. Daher hatte ich EMV-Probleme erstmal ausgeschlossen.
    Andere EMV-Einkopplungen sollten nicht bestehen. Aber so 100pro sicher kann man sich da ja nicht immer sein.

    Danke schonmal für die Tipps.

  5. #4
    Registriert seit
    25.05.2011
    Ort
    Holzgerlingen
    Beiträge
    99
    Danke
    7
    Erhielt 19 Danke für 17 Beiträge

    Standard

    Hallo H. ect'ler,

    sind beide Busabschlüsse eingelegt? 120 Ohm
    bei CAN müssen diese oft in den Stecker eingelötet werden.


    Hans-Ludwig Göhringer

    mit freundlichen Grüßen aus dem Schönbuch
    Hans-Ludwig Göhringer
    IVG Göhringer Mönchweg 5 71088 Holzgerlingen Tel.:07031 607880 Fax: 07031 607881 Mobil.:0172-7671463 eMail: H-L.Goehringer@t-online.de <http://www.i-v-g.de>

    Messgeräte für Bussysteme, Dienstleistungen an Bussystemen: Abnahmemessungen, Troubleshooting und Schulungen für Profibus,Profinet, CAN, AS-Interface, usw.

  6. #5
    Avatar von ebt'ler
    ebt'ler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.09.2008
    Ort
    Berlin
    Beiträge
    172
    Danke
    51
    Erhielt 51 Danke für 44 Beiträge

    Standard

    Oh, habe gesehen das oben mein nick falsch geschrieben ist. Ich nenn mich ebt'ler, nicht ect'ler. Sorry, aber auch sowas von egal.

    Die Busabschlüsse können in den (speziellen) CAN-Steckern zugeschaltet werden. Wäre nur zu prüfen ob Sie dann auch wirklich drin sind. Habe nur kontrolliert, das sie an den Enden auch auf "on" stehen, aber noch nicht gemessen.

  7. #6
    Registriert seit
    25.05.2011
    Ort
    Holzgerlingen
    Beiträge
    99
    Danke
    7
    Erhielt 19 Danke für 17 Beiträge

    Standard

    Hallo ebt'ter,

    Nächster Schritt wäre Kabelquerschnitt, Leitungslänge Arbittrierung. Der Grund ist: wenn ein TN das Telegramm nicht versteht sendet er einen Errorrframe und macht damit das Telegramm kaputt.
    Machmal gibt es eine Errorframe LED die zu viele Telegrammfehler anzeigt.

    Hilfe gibts unter http://www.can-cia.com/index.php?id=canopen oder besser ist
    http://vector-elearning.com/vl_index_de.html

    wenn die Prüfung der Hardware abgeschlossen ist können wir uns der Software zuwenden.

  8. Folgender Benutzer sagt Danke zu Hans-Ludwig für den nützlichen Beitrag:

    ebt'ler (09.07.2013)

  9. #7
    Avatar von ebt'ler
    ebt'ler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.09.2008
    Ort
    Berlin
    Beiträge
    172
    Danke
    51
    Erhielt 51 Danke für 44 Beiträge

    Standard

    Hi,

    ich bin Heute leider nicht dazu gekommen.
    Leitungslängen sollten ok sein, 4m< l <10m. Bei 250kbit/s.
    Querschnitt habe ich nicht im Kopf, ist aber offensichtlich "original" CAN-Leitung, daher sollte es ok sein.

    Der einfachste Schritt wäre aus meiner Sicht erstmal mit einer separaten Leitung jedes Gerät einzeln zu testen. Momentan schaue ich grade nach den Spezifikationen, eigentlich sollte man so etwas ja auch selber bauen können.

  10. #8
    Registriert seit
    12.04.2010
    Beiträge
    300
    Danke
    22
    Erhielt 54 Danke für 52 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    falls du Zugriff auf einen Can-Analyzer hast, würde ich mal so einen reinhängen. (z.B. PCAN USB - CAN Adapter). Der Analyzer zeigt dir auch Error-Frames. Jedenfalls kannst du sicher rausfinden ob der Zusammenbruch nicht doch mit bestimmten Telegrammen in Zusammenhang stehen welche eben genau vorher übertragen werden.

    BG
    BB

Ähnliche Themen

  1. Schneider M340 Verbindung zum Laptop
    Von shevek im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 29.02.2012, 01:30
  2. Schneider Electric suche für M340 eine Spannungsversorgung
    Von mkRE im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 10.11.2010, 23:37
  3. Antworten: 3
    Letzter Beitrag: 10.11.2010, 23:36
  4. Rezepturen - Rätselhaftes verhalten
    Von ssound1de im Forum HMI
    Antworten: 1
    Letzter Beitrag: 24.03.2009, 09:12
  5. Zykluszeit mit der Modicon M340 von Schneider
    Von peterpan im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 18.11.2007, 21:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •