Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: im151-3 pn wird nicht erkannt

  1. #1
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo

    habe ihr ein problem mit einer et200s im151-3

    ich habe der im einen namen und eine ip-adresse vergeben und das ganze auf die im übertragen.
    die im ist unter erreichbare teilnehmer zu sehen und reagiert auch auf einen ping.
    in der diagnose ist die im projektiert aber nicht vorhanden.
    ein blinktest an der im funktioniert.

    aufbau:
    cpu 315-2pn/dp <-> scalance x208 <-> im151

    ist meine erste im über profinet.

    im anhang mal ein paar bilder
    Angehängte Grafiken Angehängte Grafiken
    Geändert von volker (23.12.2013 um 11:54 Uhr)
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation
    Zitieren Zitieren im151-3 pn wird nicht erkannt  

  2. #2
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    noch ein bild
    Angehängte Grafiken Angehängte Grafiken
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  3. #3
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    gib der IM doch mal den Namen "SP-IM151-3PN"

  4. #4
    Registriert seit
    13.10.2007
    Beiträge
    12.064
    Danke
    2.793
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Vielleicht hilft dir auch das neue Tool von Siemens:

    http://support.automation.siemens.co...ew/de/67460624
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. Folgende 3 Benutzer sagen Danke zu rostiger Nagel für den nützlichen Beitrag:

    Blockmove (24.12.2013),Ottmar (29.12.2013),volker (23.12.2013)

  6. #5
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    an ChristophD
    Das einzige was wirklich zählt ist der Name, dieser muss 100 Prozentig mit der HW-Konfig übereinstimmen.

    Alles andere wie Topologie und IP-Adresse ist reiner Luxus und im Anfang Ballast.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  7. Folgende 2 Benutzer sagen Danke zu MSB für den nützlichen Beitrag:

    Ottmar (29.12.2013),volker (23.12.2013)

  8. #6
    Registriert seit
    30.08.2003
    Beiträge
    2.197
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    also ich würde erstmal auf Umlaute bei den Namen verzichten... ÜGS

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....

  9. #7
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    @rn
    nettes tool

    @msb
    ja das mit dem namen war es

    danke
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  10. #8
    Registriert seit
    29.04.2012
    Beiträge
    195
    Danke
    13
    Erhielt 42 Danke für 37 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    Alles andere wie Topologie und IP-Adresse ist reiner Luxus und im Anfang Ballast.
    Vorsicht. Es stimmt, dass die reine IO Kommunkation auf MAC Ebene läuft (die MAC wird über den PN Namen ermittelt).
    Aber die anfängliche Parametrierung läuft über UDP/IP. Das mag/kann noch funktionieren, wenn die Device IP im selben Subnetz ist und der Controller mit der empfangenen (statt der projektierten) IP weiterarbeitet.
    Spätestens wenn die Device IP in einem anderen Subnetz liegt, funktioniert das nicht mehr.
    There are two kinds of fools. One says, “This is old, and therefore good.” And one says, “This is new, and therefore better.”

  11. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Zitat Zitat von Pipboy Beitrag anzeigen
    Vorsicht. Es stimmt, dass die reine IO Kommunkation auf MAC Ebene läuft (die MAC wird über den PN Namen ermittelt).
    Aber die anfängliche Parametrierung läuft über UDP/IP. Das mag/kann noch funktionieren, wenn die Device IP im selben Subnetz ist und der Controller mit der empfangenen (statt der projektierten) IP weiterarbeitet.
    Spätestens wenn die Device IP in einem anderen Subnetz liegt, funktioniert das nicht mehr.
    Das ist aber so auch nicht richtig ... oder wenigstens genau so unvollständig wie mein Statement.
    Das "Suchen" des Namens, sowie die Vergabe der IP-Adresse werden normalerweise ja von der CPU (basierend auf der HW-Konfig erledigt) mit dem DCP Protocol, welches jeder PN IO RT Teilnehmer beherrschen muss,
    insofern ist es vollkommen unnötig, dem Device sozusagen Initial neben dem Namen auch noch eine IP zu verpassen.
    In Step7 wiederum ist es nich möglich, dem IO Device eine nicht zum Subnetz der CPU passende Adresse zu verpassen.
    Der Rest der Kommunikation ab dem Zuweisen der IP wird dann wohl mit UDP erfolgen.
    Bleibt also noch ein kleiner Rest an Devices, welche feste IP-Adressen, oder DHCP-IPs akzeptiert (wozu die IM151-3 m.W. aber nicht gehört).

    Heißt also:
    Die initiale Parametrierung, Device <-> CPU ist DCP-Multicast-Basiert, der Rest ist dann ganz normaler IP-Verkehr.

    Mfg
    Manuel
    Geändert von MSB (29.12.2013 um 11:28 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  12. #10
    Registriert seit
    29.04.2012
    Beiträge
    195
    Danke
    13
    Erhielt 42 Danke für 37 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das stimmt schon, was oben steht kann nur bei Geräten passieren, die selbst noch eine Projektierung unabhängig vom Controller haben.
    There are two kinds of fools. One says, “This is old, and therefore good.” And one says, “This is new, and therefore better.”

Ähnliche Themen

  1. ET200S wird nicht erkannt
    Von qpec_hagen im Forum Simatic
    Antworten: 53
    Letzter Beitrag: 31.01.2012, 21:15
  2. TON wird nicht erkannt
    Von tahren im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 05.08.2010, 14:43
  3. CP5611 wird nicht erkannt
    Von Phase im Forum PC- und Netzwerktechnik
    Antworten: 14
    Letzter Beitrag: 10.03.2009, 11:03
  4. Pg 710 FP wird nicht erkannt
    Von Poetter im Forum PC- und Netzwerktechnik
    Antworten: 4
    Letzter Beitrag: 23.06.2007, 19:48
  5. License Key wird nicht erkannt
    Von brainless im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 11.04.2006, 13:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •