Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 28

Thema: M-Bus bei Wachendorff Gateway

  1. #1
    Registriert seit
    26.04.2010
    Beiträge
    144
    Danke
    18
    Erhielt 6 Danke für 6 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich versuche einen Diehl Metering (früher EWT) Wärmemengenzähler Scylar Int M über ein Wachendorff HD67053-B2 Profibus/M-Bus Gateway an eine S7-400 zu koppeln.
    Es gibt dazu ein Tool von Wachendorff, mit dem man die Parametrierung erstellt, diese dann in das Gateway lädt und eine *.gsd Datei generiert die man dann in die HW-Konfig der S7-400 einfügen kann.
    Die Kopplung Siemens-Wachendorff funktioniert auch, nur bekomme ich keine Daten vom M-Bus.

    Leider sind sowohl die Beschreibungen von Wachendorff als auch von EWT mehr als dürftig.

    Hat von euch jemand schon mal so etwas gemacht und kann mir hier Schützenhilfe geben?
    Danke schonmal.

    mfg mephisto
    __________________________

    Zitieren Zitieren M-Bus bei Wachendorff Gateway  

  2. #2
    Registriert seit
    10.11.2009
    Beiträge
    33
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Mephisto
    hast du den Zähler schon mit einem Auslesegerät ausgelesen?
    Dann siehst du die Positionsnummern der Variablen.

    In der Software des Gateways stellst du unter Nodes ganz unten bei Variablenlist auf By Position.
    Dann legst du dir unter dem Menü Variables deine gewünschten Variablen mit der Positionsnummer an.

    mfg
    holschin

  3. #3
    Registriert seit
    10.11.2009
    Beiträge
    33
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Mephisto

    Nur als Beispiel für einen EWT Wärmemängenzähler

    Energie Position 1
    Volumen Position 4
    Leistung Position 5
    Vorlauftemp Position 7
    Rücklauftemp Position 8
    Tempdifferenz Position 9

    hoffe es hift dir
    mfg
    holschin

  4. #4
    Registriert seit
    21.10.2010
    Beiträge
    158
    Danke
    21
    Erhielt 29 Danke für 17 Beiträge

    Standard

    Wir benutzen auch einige Wachendorff-Geräte (eigentlich ADFWEb), und auf MBus-Seite ist die Paremetrierung immer wieder eine kleine Herausforderung, wenn man ein neues MBus-Gerät auslesen will. Ich lese die Werte nicht über die Position ein, aber man muss wissen ob ein Wert 16, 24 oder 32 Bit lang ist. Ich würde in die Projektierung nur eine Variable einfügen und dann verschiedene Konfigurationen testen. Leuchtet die MBus-Fehler-LED oder hat dieses Gerät keine?

  5. #5
    Avatar von Mephisto
    Mephisto ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.04.2010
    Beiträge
    144
    Danke
    18
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo!

    Danke für die Antworten!
    Das mit "by Position" will ich auch gerade ausprobieren. GSD und Parametersatz hab ich schon erstellt. Am Monag geht's dann ab auf die Baustelle zum Einspielen und Testen.
    Leider hab ich keinen Protocollanalyzer. Somit kann ich nicht kontrollieren, ob die EWT Zähler in Ordnung sind.
    Ich hoff halt mal das Beste.
    __________________________


  6. #6
    Avatar von Mephisto
    Mephisto ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.04.2010
    Beiträge
    144
    Danke
    18
    Erhielt 6 Danke für 6 Beiträge

    Standard

    @funkey:
    MBUS-Fehler leuchtet. Wie liest du denn die Werte sonst ein? Über die VIF oder über die vordefinierten Werte aus der ADFWeb Software?
    Messwerte lese ich alle als 32Bit Real ein.
    __________________________


  7. #7
    Registriert seit
    21.10.2010
    Beiträge
    158
    Danke
    21
    Erhielt 29 Danke für 17 Beiträge

    Standard

    Solange der MBus-Fehler leuchtet werden auch keine Werte gelesen! Stimmt die MBus-Adresse des WMZ? Stimmt die eingestellte Baudrate? Ich wähle einfach die vordefinierten Werte aus. Bei Kamstrup-Zählern sind alle Werte auf 32Bit einzustellen, dei einem techem-Gerät musste ich die Temperaturen auf 24Bit stellen. Diese Einstellungen sagen aber nur etwas darüber aus, ob der Wert richtig umgewandelt werden kann oder nicht. Das beeinflusst abe nicht die Fehler-LED. Probier mal die MBus-Adresse 253 aus und schaue ob der Fehler dann verschwindet.

  8. #8
    Avatar von Mephisto
    Mephisto ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.04.2010
    Beiträge
    144
    Danke
    18
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo!

    Das mit Adresse 253 konnte ich nicht probieren, da mein Wachendorff nur 1-250 zulässt.

    Ich hab auf jeden Fall aus purer Verzweiflung heraus 1000 Einstellungen probiert und mit der 1000sten hat's dann geklappt.
    Danke auf jeden Fall für eure Hilfe!

    mfg mephisto
    __________________________


  9. #9
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Zitat Zitat von Mephisto Beitrag anzeigen
    Ich hab auf jeden Fall aus purer Verzweiflung heraus 1000 Einstellungen probiert und mit der 1000sten hat's dann geklappt.
    Ja das klingt meistens typisch. Ich freu mich auch immer ganz besonders wenn ich irgenwas mit MBUS und dem Wachendorf-Gateway machen darf.

    Das letzte mal hatte ich einen Zähler bei dem weder ByType- noch ByPosition-Informationen in den Handbüchern angegeben waren. Ruft man dann beim Support an
    und fragt nach den "ByPosition"-Informationen sagen einem die dann,
    Zitat: "Wie Positionsnummern? Sowas gibt's im MBUS-Standard ja gar nicht. Sie müssen die in der Dokumentation beschriebenen Protokolle nutzen. Unser Zähler ist Standard-Konform..."

    Da wollte ich dem Mann auch mal kurz durchs Telefon ins Gesicht springen.
    Ich hab damals so gar den technischen Support von Wachendorf und den von EWT direkt mit dem Telefon zusammen gespannt,
    weil's mir bald als Mittelsmann zu blöd wurde. Die sind einfach beide auf keinen grünen Zweig gekommen. Aber beide Geräte sind absolut MBUS-Standardkonform klar.
    Ich hatte da so einen Hass damals.

    Nach tausend mal probieren hab ich die nötigsten Infos aus dem Zähler raus gebracht.
    Solange man die ByPosition oder ByType-Angaben vom Hersteller hat geht's meistens, aber wehe wenn nicht.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  10. #10
    Avatar von Mephisto
    Mephisto ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.04.2010
    Beiträge
    144
    Danke
    18
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, so ähnlich ging's mir auch.

    Hab bei EWT mal wegen dem Busprotokoll gefragt.
    Antwort: "Damit kenn ich mich nicht aus und wir haben auch keinen hier in der Firma, der das kann. Der Zähler ist normkonform. Sie müssen sich die Daten aus der Norm raussuchen."

    Bitte versteht mich jetzt nicht falsch aber:
    Das kommt raus, wenn Installateure Elektrogeräte vertreiben. - Schuster bleib bei deinen Leisten!

    Bei Wachendorff lief's übrigens nicht besser. Der Typ am Support hat offensichtlich noch nie mit dem Gerät gearbeitet. Der hat mir von Funktionen erzählt, die's so gar nicht gibt und auch nicht geben kann.


    mfg mephisto
    __________________________


Ähnliche Themen

  1. Modbus Gateway auf M-Bus
    Von BTDA im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 22.08.2013, 18:11
  2. M-Bus Gateway 4-20 mA
    Von C7633 im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 24.10.2012, 19:34
  3. Antworten: 7
    Letzter Beitrag: 12.09.2012, 15:18
  4. Gateway M-Bus nach Profibus DP
    Von WachMark im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 16.02.2010, 11:41
  5. GSM-Gateway bei PC-Visu
    Von Schnick und Schnack im Forum HMI
    Antworten: 4
    Letzter Beitrag: 12.05.2008, 17:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •