Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: S7-1513 und Schneider LMC400 gemeinsam an Profinet

  1. #1
    Registriert seit
    11.11.2008
    Ort
    U.S.A...unser schönes Ammerland
    Beiträge
    23
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    folgende Konstellation habe ich hier:
    Programmiersoftware: TIA V13 (erstes Update ausgeführt) und SoMachine Motion V4.0
    Übergeordnete Steuerung ist eine S7-1513 und als autarke Servosteuerung habe ich hier eine Schneider LMC 400. Die LMC ist am Profinet leider nicht als Slave zu betreiben, also wollte ich die S7 als IO-Device konfigurieren, so dass Controller/Controller Kommunikation möglich ist. Habe testweise einen Transferbereich festgelegt und dann die enstprechende GSD (xml) exportiert. Nun zum eigentlichen Problem, diese GSDML lässt sich an der LMC nicht installieren sondern bricht mit " Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt" ab. Grundsätzlich funktioniert das Installieren von Fremdgeräten aber, habe das mit einer XML Datei von Lenord&Bauer an der LMC ausprobiert. Um das Ganze noch etwas zu verwirren - die erzeugte GSDML lässt sich aber problemlos bei TIA installieren, sogar bei S7-Classic (V5.5).
    Die Service-Hotline bzw. die Produktunterstützung von Siemens und Schneider konnte bis dato noch nichts herausfinden - ich denke das Problem wird naturgemäß erstmal in der jeweils anderen Steuerung vermutet.
    Was ich bis jetzt weiss, wenn man bei S7-Classic beim Exportieren der GSD keinen Katalogkommentar angegeben hat, gab es auch das Problem, dass sich die GSD nicht installieren ließ.
    Nur bei TIA gibt es dieses Feld scheinbar nicht mehr bzw. gefunden habe ich keins.
    Hatte von euch schon jemand ein ähliches Problem und evtl. eine Lösung, bzw. einen Ansatz?
    Achso, was mir noch aufgefallen ist, die xml Dateien von Schneider, Lenord&Bauer sind ISO codiert, die Generierte von Siemens aber in UTF-8 - mehr grundsätzliche Unterschiede waren leider adhoc nicht zu finden in der xml.

    Grüße aus dem Norden,

    wernersens
    Zitieren Zitieren S7-1513 und Schneider LMC400 gemeinsam an Profinet  

  2. #2
    herrwernersens ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.11.2008
    Ort
    U.S.A...unser schönes Ammerland
    Beiträge
    23
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kleines Update: Habe eine GSD von S7 Classic aus exportiert, diese lässt sich bei SoMM installieren.....

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 28.10.2016, 08:11
  2. SPS-Forum und SPS-Magazin gemeinsam auf der Hannover Messe
    Von Martin Buchwitz im Forum Stammtisch
    Antworten: 0
    Letzter Beitrag: 27.03.2014, 16:36
  3. Antworten: 8
    Letzter Beitrag: 15.02.2012, 09:25
  4. Codesys 2.x und 3.x gemeinsam nutzen
    Von RobiHerb im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 23.11.2011, 09:41
  5. Antworten: 6
    Letzter Beitrag: 03.03.2011, 12:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •