Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24

Thema: Sporadische Ausfall eines Profibusteilnehmers

  1. #11
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Evtl. liegt es auch an den Busparametern.
    Was hast du denn für ein Busprofil eingestellt? Mit mehreren Mastern ist das Profil auf "Universell" einzustellen, und dein Panel ist im Normalfall ein zusätzlicher Master.
    In Step7 kannst du in der Buskonfiguration noch die Anzahl der Repeater und Streckenlänge eingeben, und dann die Parameter anhand der Werte neu berechnen lassen. Bei "Universell" ist dann noch die Anzahl der Master einzustellen. Wenn du das nicht machst kommt dein Panel womöglich nicht in den Ring.

    Da du wahrscheinlich dein Panel in TIA und die SPS in Step7 projektierst, musst du die Busparameter am Panel manuell nachpflegen.

  2. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Georgius (18.07.2014)

  3. #12
    Registriert seit
    06.10.2003
    Beiträge
    3.410
    Danke
    449
    Erhielt 504 Danke für 407 Beiträge

    Standard

    Zitat Zitat von Georgius Beitrag anzeigen
    .. Ich habe an der Hälfte der Teilnehmer die offenen DP-Stecker von Siemens, also die mit PG-Schnittstelle, könnte das Probleme verursachen?
    Diese Busstecker sind tatsächlich nachteilig für die Stabilität. Wenn ich die Quelle meiner Erinnerung wiederfinde, reiche ich sie nach.

    Verringere doch mal testweise die Baudrate!


    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    .. und dein Panel ist im Normalfall ein zusätzlicher Master...
    Thomas, kann es sein dass du "aktiver Teilnehmer" mit "Busmaster" gleichsetzt? Ein Panel oder sonstiges HMI-System ist bestimmt kein Busmaster.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  4. Folgender Benutzer sagt Danke zu Onkel Dagobert für den nützlichen Beitrag:

    Georgius (18.07.2014)

  5. #13
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Ein Panel oder sonstiges HMI-System ist bestimmt kein Busmaster.
    Doch ... ist es. Es führt ja auch seine Kommunikation mit der SPS aktiv eigenständig durch (wenn es den Token bekommt).

    Gruß
    Larry

  6. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    Georgius (18.07.2014)

  7. #14
    Registriert seit
    07.05.2008
    Beiträge
    63
    Danke
    8
    Erhielt 2 Danke für 2 Beiträge

    Standard

    So nun melde ich mich mal wieder. Danke für die Tipps. Der Hinweis von Thomas scheint in die richtige Richtung zu gehen. Ich habe alles soweit eingestellt, nur "neu berechnen" war bei mir ausgegraut. Leider habe ich jetzt das Problem, dass die Profibus - Teilnehmer zu langsam miteinander kommunizieren. Teilweise so langsam dass es kritisch für den Prozess ist. Schaut man sich die Bus Parameter an ist ist dies auch völlig logisch. So steigt die Soll-Token Umlaufzeit um den Faktor zehn im Gegensatz zum Profil DP. Auch Standard hat einen Faktor von circa 7 was wahrscheinlich immer noch zu langsam ist. An die Einstellung cbenutzerdefiniert" traue ich mich nicht so recht ran. Ich werde nochmal Siemens kontaktieren und schauen was die dazu sagen weil so ungewöhnlich ist meine Konfiguration ja eigentlich nicht.
    Über weitere Hinweise freu ich mich natürlich...

  8. #15
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    @Onkel
    Wir haben beide in gewisser Weise Recht

    Eine SPS ist DP-Master Klasse 1.
    Ein Bediengerät wie auch z.B. ein Programmiergerät ist ebenfalls DP-Master, aber einer der Klasse 2.

    Ein Klasse 2 DP-Master (z.B. HMI) hat andere Zugriffsrechte.
    Der Klasse 1 Master (z.B. SPS) erkennt den Klasse 2 Master wenn er dem Bus beitritt. Hat die SPS in ihrem Zyklus die Slaves abgefragt, wird der Token an das HMI weitergegeben. Allerdings hat dieser Teilnehmer nur in der Gap-Time Zugriff auf den Bus. Siehe Information aus diesem [1] Artikel.

    Darum ist er im Busprofil nicht als zusätzlicher Master - wie ich fälschlicherweise schrieb - in den Netzeinstellungen anzugeben, sondern als zusätzlicher S7-Kommunikationsteilnehmer. Dann erhöht sich in den Busparametern (wenn man diese automatisch berechnen lässt) der Wert für die Ttr.
    Die Gap Time lässt sich in Step7 nicht direkt einstellen. Dieses ist imho die Zeit zwischen der projektierten maximalen Token-Umlaufzeit Ttr und der aktuellen Token-Umlaufzeit.

    Wenn diese Zeit zu gering ist, bekommt der Master Klasse 2 das Token entweder überhaupt nicht, oder muss es sofort wieder abgeben und es kommt keine Kommunikation zustande.

    Wahrscheinlich wurde bei dir durch den zusätzliche projektierten Master die Ttr zu hoch berechnet. Ich würde diesen wieder rausnehmen / Anzahl herunterstellen, und dann die Anzahl der Kommunikationsteilnehmer erhöhen. Dass sich die Tokenumlaufzeit erhöht lässt sich aber bei einem zusätzlichen Teilehmer generell nicht vermeiden.
    Du kannst auch in dein Step 7 eine Dummy-HMI-Station einfügen, dann erkennt Step7 die Teilnehmer automatisch und stellt die Anzahl passend ein.

    [1] http://www.automation.com/library/ar...to-profibus-dp

  9. Folgende 2 Benutzer sagen Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Georgius (18.07.2014),Onkel Dagobert (20.07.2014)

  10. #16
    Registriert seit
    07.05.2008
    Beiträge
    63
    Danke
    8
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Danke für die Erklärung. Habe mal die Anzahl der Master auf 1 gesetzt (vorher 2) und die Anzahl der Kommunikationsteilnehmer von 1auf 2 erhöht. Scheint leider kaum Einfluß zu haben. Dass der Bus durch das Panel mehr belastet wird, ist klar, aber so doll, dass ich den Bus dann kaum noch nutzen kann ist ja auch nicht im Sinne des Erfinders. Da der Bus ja mit 3 Slaves weniger und HMI lief, sollte also noch etwas gehen. Sind die Einstellungen in den Busparametern alle Einstellungen oder wird noch was im Hintergrund geändert. Was ich sagen will, könnte ich nicht die DP Einstellungen in "benutzerdefiniert" übernehmen und nur etwas verändern bis es funktioniert? Würde jetzt mal intuitiv die Soll-Token Umlaufzeit erhöhen. Oder macht da was anderes mehr Sinn?

    Gruß und erstmal ein schönes Wochenende

  11. #17
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Es gibt von Siemens ein Dokument wie man die Werte selber berechnen kann. Ich habe das mal bei einer Anlage mit einem umfangreichen Profibus-Netz mit Ringstruktur und einigen OLMs zu Fuß gemacht. Letztenendes kamen so gut wie die gleichen Werte heraus die auch das Siemens-Tool berechnet hat. Mit Rumprobieren kommst du aber nicht weit. Entweder du nimmst die Werte vom Tool (NetPro) oder du rechnest selber.

    Aber mal zusammengefasst:
    Du hast nur die Masteranzahl erhöht (und dementsprechend auch die Tokenumlaufzeit), und damit läuft der Bus dann stabil?

    Womit projektierst du deine SPS, und womit das HMI? Hast du die HMI-Station ebenfalls mit den geänderten / gleichen Parametern geladen?

  12. #18
    Registriert seit
    07.05.2008
    Beiträge
    63
    Danke
    8
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Habe nach Ihren Tips auf "Universal" statt DP gestellt. Denke, dass das ausschlaggebend war. Dadurch steigt die Zeit ja schon um den Faktor 10. Habe gleichzeitig aber auch den Repeater und die Leitungslänge angegeben und die Zahl der Master von 1 auf 2 erhöht. Ich nutze für die Steuerung Step 7 V5.5 und für das Panel Tia Portal V13. Die Werte habe ich sowohl in der Hardware als auch im Hmi eingestellt, also in Step 7 und Tia Portal.

  13. #19
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Du kannst auch mal Standard probieren, da lassen sich auch die Parameter für zusätzliche Teilnehmer einstellen. Dann gehen die Zeiten nicht ganz so hoch.

  14. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Georgius (18.07.2014)

  15. #20
    Registriert seit
    07.05.2008
    Beiträge
    63
    Danke
    8
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    OK, vielen Dank für die Hilfe. Werde ich Montag mal ausprobieren. Wenn ich es aber Offline einstelle bekomme ich folgenden Ttr - Zeiten Universal mit einem Master und 2 aktiven Teilnehmer 852 ms, bei Standard mit gleichen Einstellungen immerhin noch 510 ms und bei DP 62 ms. Ich habe nun auch mal ein HMI-Dummy in Netpro eingefügt, dann geht's überall minimal hoch. Wäre das noch einen Versuch bei DP Wert? Oder ist DP generell ungeeignet bei mehreren Master?

Ähnliche Themen

  1. Simodrive 611U Ausfall eines Leistungsteils
    Von LarsVader im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 27.05.2011, 12:21
  2. Störung bei Abstecken eines Profibusteilnehmers
    Von technikchef im Forum Feldbusse
    Antworten: 5
    Letzter Beitrag: 17.10.2010, 12:29
  3. Ausfall eines IO-Devices
    Von Serdar G im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 13.11.2009, 12:37
  4. Stop beim Ausfall eines Slaves
    Von jas im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 15.01.2007, 17:12
  5. Testen eines Profibusteilnehmers nur mit Laptop
    Von Stefan H. im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 07.04.2006, 18:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •