Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Siemens S7-300 mit B&R X20IF1063-1

  1. #1
    Registriert seit
    11.07.2006
    Beiträge
    126
    Danke
    40
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich versuche die beiden Dinge miteinander zum laufen zu bekommen.
    Hat das schon mal jemand gemacht??

    S7-300 ist eine CPU315PN/DP mit dem Slave von B&R.
    Habe die gsd-Datei von der B&R HP runtergeladen und in der Hardware Konfig
    angebunden.
    B&R Projekt mit einer X20 CPU und dem Slave aufgebaut.
    Als Datenaustausch nur jeweils 1 Wort eingerichtet.
    Klappt leider nicht.
    Der Siemens Master meldet Baugruppe nicht projektiert oder vorhanden.
    Weiss jetzt nicht ob es an Siemens oder B&R liegt?

    Kann da vielleicht jemand helfen??

    Gruß bernd67
    Zitieren Zitieren Siemens S7-300 mit B&R X20IF1063-1  

  2. #2
    Registriert seit
    06.03.2008
    Ort
    Herisau
    Beiträge
    44
    Danke
    8
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo bernd67

    Ist zwar schon eine Weile her, aber ich habe das schon ein paar mal erfolgreich aufgebaut. Darf mich jetzt mit CoDeSys rumschlagen und habe leider kein AS oder Step7 zu Verfügung. Mit einem detaillierteren Beschrieb währe es sicherlich einfacher Dir unter die Arme zu greifen.

    1. welche AS Version und welche Step7 Version?
    2. wie sehen die HW Konfigurationen aus?
    3. Screenshots Konfigurationen?
    4. was sagt der Status des IF1063-1 (LED)?
    5. erreichbare TN in Step7


    Ich bin jeweils so vorgegangen (AS3.0.90 und Step7 V5.5):
    1. IF im AS eingefügt
    2. Module im IF mittels netX PlugIn im AS eingefügt
    3. DP-Adresse des IF-Moduls eingestellt
    4. IF so parametriert, dass die Kommunikation automatisch startet
    5. Laden und starten der X20CPU
    6. dasselbe in Step7


    Ich kann mich an einen Fall erinnern, wo es auch nicht funktionierte -> IF1063-1 gelöscht und noch einmal von vorne und siehe da es kommunizierte...

    Greets Flash

  3. #3
    bernd67 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.07.2006
    Beiträge
    126
    Danke
    40
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Info.
    Problem behoben.
    Die Reihenfolge der Daten muss natürlich stimmen!

  4. #4
    Registriert seit
    01.09.2014
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Frage stellt sich nicht, du MUSST einen FC1 je CP verwenden, da du damit immer das Prozessabbild der daran angeschlossenen Slaves beschreibst.
    Wenn du einen DB herrichtest mit einem Struct EIN bzw. Aus ist das auch gar nicht Quick and Dirty ...
    Our Johns Hopkins University Exams and pass4sure 640-875 exam Provide you 100% pass guarantee. You can get access to Washington University in St. Louis and therefore get Youtube with multiple prep resources of Facebook .

Ähnliche Themen

  1. b&r automation studio mit I/O-Peripherie von Siemens
    Von oORichOo im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 22.08.2013, 21:44
  2. Wie Siemens S7-300 mit PC-Verbinden?
    Von Anaconda55 im Forum Simatic
    Antworten: 26
    Letzter Beitrag: 10.06.2013, 19:32
  3. Siemens S7-200 & TSAP & LibnoDAve
    Von Dominique Van Huffel im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 19.09.2011, 17:57
  4. Antworten: 0
    Letzter Beitrag: 25.03.2009, 10:38
  5. Siemens SPS S7 300 mit CoDeSys programmieren
    Von mwissen im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 12.03.2009, 12:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •