Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Interbus an S7 Siemens

  1. #1
    Registriert seit
    15.04.2011
    Beiträge
    20
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich darf heute an einer Anlage arbeiten die Jahre lang schon ohne Probleme lief.

    Mein derzeitiges Problem ist aber das mein Istwert von einem Umrichter nicht mehr auf meiner SPS ankommt.
    Das Statuswort des Umrichters wird aber noch gesendet und kommt auch richtig an.

    Zu meiner Anlage ich habe ein Emerson Control Technique Umrichter mit einem UD74 Modul.
    Dieses ist auch soweit ich es sehen kann richtig Parametriert.
    IBS s7 300 DSC-T ist mein InterbusMaster (mit Display)

    Wenn ich mir jetzt auf meinem IBS Master das Eingangswort ansehe sehe ich folgendes.
    EW 28 = Statuswort = 0005 // also kommen hier schonmal Werte
    EW 30 = Istdrehzahl = 0000 // hier passiert nichts!

    Mein EW 28 kommt auch richtig auf der sps an



    Jetzt habe ich mir gedacht vielleicht ist die Länge des Teilnehmers falsch parametriert.
    Leider verstehe ich den Zusammenhang zwischen Eingangswort Teilnehmer und Startadresse nicht...

    Ich habe hier vor Ort nur das Display .. Software ist nicht vorhanden
    Zitieren Zitieren Interbus an S7 Siemens  

  2. #2
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    das ging die ganze Zeit und es hat keiner etwas dran geändert? Evtl gibt es ja der Umrichter - warum auch immer - nicht mehr aus. Hast du die bg4-Datei?

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....

  3. #3
    Registriert seit
    11.02.2009
    Ort
    01968 Brieske
    Beiträge
    105
    Danke
    25
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,
    ich hatte schon mal ein ähnliches Problem, allerdings nicht mit dem Interbus sondern mit einer S7 (300 oder 400). Bei einer Steuerung konnte ich den FU direkt mit den Eingans- und Ausgansadressen ansprechen. Bei einer anderen Steuerung ging das nicht. Da konnte ich nur mittels dem SFC14 "DPRD_DAT" und SFC15 "DPWR_DAT" aus der Standard Library eine Verbindung aufnehmen.
    Ich vemute, dass das am FU liegt und dieser nicht dierekt das höherwertige Word lesen oder schreiben kann. Denn diese SFC machen das mit einem mal.

    Ob das beim Interbus auch so ist weiß ich nicht. Aber vielleicht ist es ja ein Ansatz.


    LG Dirk
    >>> Bestandsschutz gibt es nicht - allenfalls ein: "Nichtvorhandensein einer Anpassungspflicht" <<<

Ähnliche Themen

  1. Interbus Fragen ...
    Von stricky im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 01.10.2013, 20:53
  2. Siemens SPS und Interbus
    Von Mechi im Forum Feldbusse
    Antworten: 11
    Letzter Beitrag: 23.07.2013, 06:45
  3. Interbus an S5
    Von Alexo im Forum Feldbusse
    Antworten: 5
    Letzter Beitrag: 13.03.2008, 15:57
  4. S7 an Interbus
    Von thommymalta im Forum Feldbusse
    Antworten: 5
    Letzter Beitrag: 29.07.2005, 09:24
  5. S5 + Interbus
    Von Anonymous im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 03.01.2005, 09:43

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •