Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Kuka Profibus kommunikation mit SPS

  1. #1
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo SPS-Forum,

    ich habe schwierigkeiten eine Kuka Roboter mit meiner SPS reden zu lassen. Im Prinzip möchte ich via Profibus vorerst ein Byte austauschen, aber leider ist mein Latein jetzt am Ende.
    Der Kuka Roboter ist ein KR3 von 2005 mit KRC Software und hat eine Profibus PCI-Karte CP5613 bekommen.
    Dazu habe ich noch zur Auswahl zwei SPS'en eine älter 314er IFM mit Profibusmodul CP 342-5 und eine neue 314C-2 PN/DP.

    Ich würde die neue CPU bevorzugen, weil ich dort kein FC1 und FC2; DP_Send, DP_Receive brauche, sollte aber doch mit beiden Realisierbar sein, oder?

    Nachdem die CP5613 noch eine der ersten Karten ist, kann die nur als Master in Betrieb gehen(?) und somit ist die SPS Slave;
    Ich wollte es zwar erst anders herum haben, aber das ist im Rahmen meines Projekts bzw. Gegebenheiten nicht möglich.

    Das Problem besteht darin, dass ich immer egal welche CPU einen Busfehler bekomme und lediglich die grüne LED auf der PCI-Karte leuchtet.

    Ich hab hier mal einen Auszug der logfile Datei vom Roboter:

    FILE_PTR_POS=001559
    26/09/05 07:12:32 : Logfile for Profibus CP5613/14 (V2.01.0.8)
    26/09/05 07:12:32 : Downloading Firmware and Database.........
    26/09/05 07:12:33 : CP5613/14 started!
    26/09/05 07:12:33 : Master Application registered at the CP!
    26/09/05 07:12:33 : Accessed pointer to DPR from CP!
    26/09/05 07:12:33 : Hardware version: 1.09
    26/09/05 07:12:33 : Firmware version: 2.01
    26/09/05 07:12:33 : Master baudrate : 1,5 MB
    26/09/05 07:12:34 : next CP state: DP_STOP
    26/09/05 07:12:34 : DP_Master has changed mode to: DP_STOP
    26/09/05 07:12:34 : next CP state: DP_CLEAR
    26/09/05 07:12:34 : DP_Master has changed mode to: DP_CLEAR
    26/09/05 07:12:36 : Waiting for all modules being in state ready!
    26/09/05 07:12:37 : Waiting for all modules being in state ready!
    26/09/05 07:12:38 : Waiting for all modules being in state ready!
    26/09/05 07:12:39 : Waiting for all modules being in state ready!
    26/09/05 07:12:40 : Waiting for all modules being in state ready!
    26/09/05 07:12:40 : next CP state: DP_OPERATE
    26/09/05 07:12:40 : DP_Master has changed mode to: DP_OPERATE
    ===== LAST_ENTRY =====

    Das war das höchste der Gefühle was ich erreicht habe, dazu kommt die Fehlermeldung: "Profibus: Kommunikationsfehler in Modul 3" (--> Slave 3)

    Hier noch ein Auszug aus den Konfig-Datei pfmbs:

    [CP_5613/14]
    DEBUG=1
    LOGFILE_PATH=log/pfbms.log
    ERROR_TEXT=German
    FORCE_RESET=1
    OLD_ERROR_DB=0

    [MASTER]
    MASTER_USED=1
    DATABASE_PATH=init/ROB.ldb
    FIRMWARE_PATH_A1=drivers/FW_5613.bin
    ;FIRMWARE_PATH_A2=drivers/fw5613A2.bin
    WATCHDOG_TIME=3
    MAPPING_USED=0
    MAPPING_PATH=init/
    ;DEACTIVATED_SLAVES=3

    [SLAVE]
    MODUL_USED=0
    MODUL_ADDRESS=3
    ;START_TIME=20
    ERROR_ACTION=0
    STANDBY=0
    SLAVE_TIMEOUT=0
    CHECK_CONFIGURATION_DATA=0
    ACCEPTABLE_INPUT_LENGTH=244
    ACCEPTABLE_OUTPUT_LENGTH=244
    IO_DATA_BASE=0
    CONSISTENCE=1

    Und der iosys:

    [DRIVERS]
    DSEIO=14,dseIoInit,dseiodrv.o
    ;CNKE2=21,cnke2CPInit,cnke2drv.o
    ;DNSC6=20,dnsc6Init,dnsc6drv.o
    ;DNSC5=19,dnsc5Init,dnsc5drv.o
    ;DNSC4=18,dnsc4Init,dnsc4drv.o
    ;DNSC3=17,dnsc3Init,dnsc3drv.o
    ;CNKE1=16,cnke1CPInit,cnke1drv.o
    ;INTERBUSPCI=15,ibsCPPciInit,ibpcidrv.o
    ;DNSC2=13,dnsc2Init,dnsc2drv.o
    ;DNSC1=12,dnsc1Init,dnsc1drv.o
    PBMASL=11,pbmsInit,pfbmsdrv.o
    ;DEVNET=2,dnInit,dn2drv.o
    ;INTERBUS=1,ibusInit,ibusdrv.o
    ;MFC=0,mfcEntry,mfcdrv.o

    [PBMASL]
    ;E/A-Zuordnungen PROFIBUS
    INB8=3,0,x1 ;$IN[65-72]
    OUTB9=3,0,x1 ;$OUT[73-80]

    Ich hab noch meine Projekte angehängt für noch mehr Infos
    alte_SPS.zip neue_SPS.zip

    Entschuldigung für die ganze Infos und Text, aber ich bin am verzeifeln mit der Kiste.....
    Vielen Dank vorab für die Hilfe

    Gruß

    Philinger
    Zitieren Zitieren Kuka Profibus kommunikation mit SPS  

  2. #2
    Registriert seit
    19.10.2010
    Beiträge
    325
    Danke
    15
    Erhielt 36 Danke für 31 Beiträge

    Standard

    Guten abend,

    Bist du dir sicher, dass diese Karte nur Master kann?

  3. #3
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    Zumindest hatt die Karte nur einen Port…Und somit müsste es eine A1 sein
    Und in einer Siemens Produkte Beschreibung stand nur DP-Master bzw in der Hardware Konfig gibt's auch nur Master anzuwählen
    Ah und ich wollte die Karte sogar aufn Kuka schon als Slave laufen lassen und dann hat er sie gleich wieder ausgeschaltet

  4. #4
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    In der Hardware sollte die GSD (Gerätestammdatei CP5613) von Kuka installiert werden.
    Dann kannst rechts die Karte (bei mir ne andere) auswählen und auf den DP-Strang ziehen.
    Jetzt die E/A-Breite (bei Dir 1 byte) unten platzieren

    .c2.JPGc1.JPG

  5. #5
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Verpolt,

    Okay, also ich habe eine gsd datei auf den Roboter gefunden, dann muss ich mit dieser gsd datei die hardware konfig machen, aber meine karte is dann weiter hin master, oder geht dann die Karte auch als Slave ? Die datei glaub ich hieß s100008.gsd oder so ähnlich kann es sein?
    Mein Problem ist ich hab den Roboter einfach so bekommen mit der Karte als Projekt und so gut wie keine Doku und natürlich hat man die Karte irgendwo gefunden und wurde nicht von Kuka bestellt

    Danke für eure Unterstützung

  6. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von philinger Beitrag anzeigen
    Hi Verpolt,
    dann muss ich mit dieser gsd datei die hardware konfig machen, aber meine karte is dann weiter hin master, oder geht dann die Karte auch als Slave
    So wie es aussieht, ist die Karte nur als Master einsetzbar

    Zitat Zitat von philinger Beitrag anzeigen
    Die datei glaub ich hieß s100008.gsd oder so ähnlich kann es sein?
    jo, kann sein. Nach der Installation steht das im Klartext drin. Oder die GSD entpacken und mit einem Editor anschauen.

  7. #7
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Gut dann werde ich am Freitag eine projektierung mit diesem GSD File machen, ich hatte mal ein gsd file von Kuka dort war die Karte allerding nur als Slave konfigurierbar, aber auch für eine CP 5614 so wie bei dir, hoffentlich ist die gsd nicht auch so eine.....

    Ich werde mich melden wie's ausschaut

  8. #8
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich hab's jetzt ausprobiert mit der gsd datei, die auf dem roboter ist, leider ist es genau die selbe die schon mal runter geladen habe, also eine für die CP5614 als Slave und leider nicht für die CP 5613 als Master

    Hat noch jemand Ideen, wie ich die zwei miteinander reden lassen kann

  9. #9
    Registriert seit
    06.01.2011
    Beiträge
    66
    Danke
    1
    Erhielt 11 Danke für 10 Beiträge

    Standard

    Anbei ein Dokument von KUKA, wo beschrieben wird, wie man einen Roboter Master einrichtet. Du braucht dafür Step7 oder den NCM Manager und musst eine lbd Datei erzeugen.
    Vielleicht hift es dir ja. Deinen beschriebenen Fall hatte ich selber so nicht. Immer nur den Fall Roboter Master von Slave EA Modulen. Daher kann ich auch nicht sagen, was auf SPS Seite für den Slavezustand eingetragen werden muss.K_NCM_Profibus.doc

  10. #10
    Registriert seit
    06.01.2011
    Beiträge
    66
    Danke
    1
    Erhielt 11 Danke für 10 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Und hier noch ein Dokument zum Einrichten auf KUKA Seite. Vielleicht hilft das auch weiter. Ansonsten im roboterforum mal vorbeischauen und fragen.

    Das sind alles offizielle Dokumente, dass letzte hier liegt auch jedem Roboter auf CD/DVD bei.

    Proghbkonfig_r5.2_de.pdf

    edit:
    ich seh gerade, du hast schon im roboterforum gepostet
    Geändert von Dos6.22 (05.01.2015 um 12:04 Uhr)

Ähnliche Themen

  1. Step 7 Profisafe Kommunikation mit KUKA (KR C4)
    Von dgehri im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 04.11.2013, 19:36
  2. Kuka - Profibus Analogsignale erzeugen / verwalten
    Von petermeter im Forum Feldbusse
    Antworten: 10
    Letzter Beitrag: 10.05.2012, 18:05
  3. Antworten: 12
    Letzter Beitrag: 04.05.2010, 08:45
  4. Kommunikation zweier SPS über Profibus
    Von Gerri im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.09.2009, 16:18
  5. Kommunikation VIPA -> KUKA über 1 Byte
    Von olitheis im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 18.10.2008, 15:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •