Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Start verzögerung Profibus

  1. #1
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo SPS-Forum,

    ich habe ein hoffentlich banales Problem. Ich habe eine CPU 314C-2 PN/DP als DP Master und eine CP5614 in einem Kuka Roboter als DP Slave.
    Erstmal Entwarnung die Kommunikation steht und funktioniert.
    Mein Problem ist follgendes:
    Ich schalte die Anlage ein die SPS ist zuerst hochgefahren und geht in RUN aber auch in Busfehler und somit Systemfehler, weil der Roboter noch einige Zeit braucht zum hochfahren...
    Wenn der Roboter hochgefahren ist und sich der Slave "anmeldet" dann geht die SPS von RUN in STOP....Ich muss dann jedesmal die SPS von RUN in STOP schalten und wieder zurück so dass die SPS wieder in RUN geht und dann passt alles erst kein Busfehler oder Systemfehler mehr

    Gibt es eine Möglichkeit den Profibus zeitverzögert zu starten oder ähnliche Quitierungsmöglichkeiten, so dass sich die SPS nicht "aufhängt"??

    Vielen Dank vorab
    Zitieren Zitieren Start verzögerung Profibus  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Bei Ausfall und auch bei Wiederkehr eines DP-Teilnehmers wird der OB 86 aufgerufen. Ist dieser in der CPU nicht vorhanden, so geht die SPS in Stop.
    Willst du ein Stop verhindern, kannst du einen leeren OB86 erstellen und ihn in die CPU laden.

    Es gibt noch andere Fehler-OBs die bei Ausfall eines DP-Teilnehmers aufgerufen werden könnten, z.B. wenn du per PEW/PAW auf die Daten eines Teilnehmers zugreifst und dieser ist nicht vorhanden, wird der OB122 aufgerufen.
    Wenn du dir den Diagnosepuffer der CPU ansiehst, wirst du dort wiederfinden welche OBs aufgerufen wurden.

  3. #3
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank für die Antwort, das hört sich machbar an, ich werde am Montag gleich mal eine blick in den Diagnosepuffer werfen...

  4. #4
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Man könnte auch (zusätzlich zum OB oder generell) unter dem Punkt

    "Hardwarekonfig --> Doppelklick auf die CPU (Eigenschaften) -->Anlauf --> Überwachungszeit für --> Fertigmeldung für Baugruppen "

    die Zeit hochsetzen, so dass der Slave es schafft rechtzeitig hochzulaufen. Dann hätte man auch keine Fehlermeldung vom Profibus bei jedem Neustart der Anlage.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. #5
    Registriert seit
    06.10.2003
    Beiträge
    3.409
    Danke
    449
    Erhielt 504 Danke für 407 Beiträge

    Standard

    L.b.n.l. könnte man den Hochlauf der CPU im OB100 verzögern.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  6. #6
    philinger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2014
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich hab heute in den Diagnosepuffer geschaut und zwei OB aufrufe gefunden ein OB86 & OB 82 aufruf
    Somit habe ich die zwei Bauteine leer eingefügt und fertig!!!
    Vielen Dank für eure Hilfe sowie Tipps und Tricks

Ähnliche Themen

  1. Step 7 Dynamik ( Verzögerung) einbauen
    Von chipchap im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 25.12.2014, 09:41
  2. Reset und Start oder nur Start???
    Von blimaa im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 9
    Letzter Beitrag: 25.08.2013, 14:44
  3. verzögerung zeit bilden
    Von zigelei im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 15.01.2010, 13:00
  4. verzögerung sfb30, frequenzmesser
    Von jo81 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 14.08.2006, 10:59
  5. Verzögerung S7- 200
    Von mmeu im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 05.10.2005, 20:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •