Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Profinet Störung durch BDE Kommunikationsausfall

  1. #1
    Registriert seit
    25.09.2014
    Beiträge
    28
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sehr geehrte Forums-Gemeinde,

    wir haben bei uns an einer Anlage mal wieder ein grössers Problemchen.

    Die BDE Abfragen zum Anlagenzustand stören ab und zu die Profinet Kommunikation.
    Dadurch geht die Anlage in Störung.

    Firmennetz ---> Router ---> Siemens Scalance X216 ---> SPS
    ---> HMI
    ---> Antriebe
    ---> usw.
    ---> CP (zusätzlich an CPU) zur BDE Abfrage

    Eine saubere Trennung ist nicht möglich, da ja auch die Ethernet-Signale für BDE über den Switch laufen.

    Was kann man tun?


    Danke

    Viele Grüße Sven
    Zitieren Zitieren Profinet Störung durch BDE Kommunikationsausfall  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Mit welcher Meldung fallen denn die Profinet-Teilnehmer aus?
    Wenn diese bei hoher Netzlast mit Stationsausfall ausfallen und dann nach kurzer Zeit wiederkommen, läuft höchstwahrscheinlich der Watchdog-Timeout für den Teilnehmer ab. Wenn deine Anlage es zulässt, könntest du diese Zeit entsprechend hochsetzen. Etwas anderes wird dir wohl nicht übrig bleiben, wenn du keine Trennung vornehmen willst/kannst.

    Und vielleicht nochmal prüfen, ob alle Router / Switche die in der Strecke eingebaut sind auch Profinet-tauglich sind, d.h. das Prioritäts-Flag beachten. Bei Nicht-Industrie-Routern reicht auch eine Angabe von VoIP-fähig oder etwas in der Art, zumindest für Profinet-IO.

  3. #3
    Registriert seit
    15.09.2014
    Ort
    Schmölln
    Beiträge
    35
    Danke
    0
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Wäre schon interessant zu wissen warum die Teilnehmer ausfallen und vor allem welche.
    Hier solltest Du erstmal mit einer Diagnosetechnik an die Sache rangehen und die Ursache genauer bestimmen (Wieviel Netzlast, Jitter etc.).
    Das hochsetzen des Watchdog Timers (Ansprechüberwachungszeit) würde ich aber nicht in Betracht ziehen. Eher würde ich die voreingestellten Aktualisierungsraten
    prüfen und sehen ob man diese optimieren kann.

    Wenn es aufgrund von Netzlast zu einem Problem in einer PN Linie kommt, dann wird die PN Priorisierung auch nicht viel bringen, da die Devices in der Linie mit hoher Wahrscheinlichkeit
    im Cut-Through arbeiten. Das heisst die Telegramme werden garnicht erst bis zum Prioritäts-Flag (weder Ethernet noch PROFINET) gelesen.
    Gruß Marco

    Technik & Support @ Indu-Sol

  4. #4
    Registriert seit
    25.05.2011
    Ort
    Holzgerlingen
    Beiträge
    99
    Danke
    7
    Erhielt 19 Danke für 17 Beiträge

    Standard

    Hallo Bonsai32,
    Bitte zuerst die Physik prüfen. Kabelzertifizierer
    Dann das Thema EMV prüfen. Schirmströme
    Dann das Thema Software. Wenn es ein Überlast Thema ist im Projekt den Antwortabstand von 3 auf 4 hochsetzen und schauen was sich verändert.
    Verändert sich nichts, so könnte das auf ein größeres Problem hindeuten.
    Hans-Ludwig Göhringer
    http://www.i-v-g.de/

  5. #5
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.242 Danke für 973 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also wenn ich es richtig verstehe dann hast eine Profinet-CPU an der die Profinet-Teilnehmer und das HMI hängen und zusätzlich hast du einen CP für das BDE-System.
    Alles hängt an einem Scalance X216.

    Falls das so ist, warum hängst du das BDE-System nicht direkt an den CP?

    Hast du die Profinet-Topologie eingetragen?
    Du kannst - wie es auch Marco vorschlägt - mal die Aktualisierungszeiten hochsetzen.
    Damit verringert sich die Kommunikationslast.
    Auch wenn es immer so einfach dargestellt wird, so ist bei Profinet die Verkablung und der Schirm auch extrem wichtig.
    Gerade ET200S-Stationen sind hier teilweise recht ekelhaft. Im Zweifelsfall mal die Schirmströme mit einer Schirmstrommesszange messen.

    Wenn das alles nicht hilft, dann gibt es entsprechende Testgeräte (Softing, Indu-Sol).

    Gruß
    Dieter

Ähnliche Themen

  1. Kommunikationsausfall WinCC <> SPS S7
    Von mmuehlbach im Forum HMI
    Antworten: 10
    Letzter Beitrag: 26.01.2013, 20:29
  2. Bachmann Lightbus Störung durch Vibration
    Von Licht9885 im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 25.11.2012, 10:33
  3. Kommunikationsausfall WinCC <> SPS S7 melden
    Von Dagobert1987 im Forum HMI
    Antworten: 8
    Letzter Beitrag: 01.10.2012, 16:16
  4. Freeware-BDE
    Von Ralle im Forum Werbung und Produktneuheiten
    Antworten: 20
    Letzter Beitrag: 25.11.2009, 10:46
  5. BDE mittels DB
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 31.01.2004, 19:32

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •