Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: GSDML Installation von Hilscher-Modulen in CodeSys V3.5 SP6

  1. #1
    Registriert seit
    05.06.2015
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo werte Forengemeinde,

    ich versuche gerade verzweifelt in CodeSys V3.5 einen Industrial Ethernet Adapter von Hilscher als Profinet Device zu installieren. Normalerweise geht das ja per GSDML-Datei über das Menü Tools -> Geräte-Repository. Nach Auswahl der Datei kommt bei mir die Fehlermeldung "stIdentifier has to be be unique according stLanguage". Komischer Weise liegt dieser Fehler quasi bei sämtlichen GSDMLs für die Module von Hilscher vor.
    Wer das gerne mal bei sich testen möchte, dem wäre ich sehr dankbar. Hier gibt es die GSDMLs für eines dieser Module:

    http://www.hilscher.com/en/products/.../?&techCats=35

    Wirklich korrupt scheinen diese Dateien nach dem Profinet GSD-Checker der PNO nicht zu sein, aber vielleicht ist jemand von euch versierter darin und kann etwas mit diesem Phänomen anfangen. Ich tappe derzeit noch im dunkeln.

    Vielen Dank bis hierhin!

    HAL9001
    Zitieren Zitieren GSDML Installation von Hilscher-Modulen in CodeSys V3.5 SP6  

  2. #2
    Registriert seit
    28.03.2012
    Ort
    Hessen
    Beiträge
    116
    Danke
    4
    Erhielt 20 Danke für 18 Beiträge

    Standard

    Die Datei für FW v3.5 kommt nicht durch dem GSD-Checker (v2.31_01), ist leicht korrigierbar.

    In beide Dateien finden sich die gleiche SubModuleIdentNumber für SubSlot 32768 und SubSlot 32769/32770, das wirft im Check zwar nur ein Warnung, müsste aber von der Zertifizierungsstelle abgelehnt werden.
    Das dürfte auch das Problem sein das bei Dir bemängelt wird. Könnte in die Datei geändert werden, dann dürfte es aber im PROFINET Anlauf ein Fehler geben.

    Das kann nur Hilscher lösen.
    Kaum macht man es richtig, schon funktioniert es.

  3. #3
    Registriert seit
    15.11.2016
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    I have the same problems with importing the file to ABB Automation Builder v1.1.2_1846.
    With version ABB Automation Builder V1.2.0_3296, the problem is 'solved'. Unfortunatelly, we have to use the 'old' version 1.1.2. We can not upgrade!
    So I have to solve this issue, I have checked with Hilscher, but they dont think it is their problem.
    Did you solve this issue?

    Please let me know!

  4. #4
    HAL9001 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.06.2015
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi TrebborX,

    I had that problem a long time ago. As far as I can remember updating the CODESYS environment from 3.5 SP6 to 3.5 SP7 solved that problem. At that time it was only for testing pursoses. After that I used my own GSDML file and the Hilscher module was used with more deeper configuration on target side (own definition of DAP, modules, submodules and records) which is not comparable to the Hilscher default config.
    So, maybe editing your own GSDML which suits to your purposes may help. I also recommend the PNO's GSDML checker.

    HAL9001

  5. #5
    Registriert seit
    15.11.2016
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von HAL9001 Beitrag anzeigen
    Hi TrebborX,

    I had that problem a long time ago. As far as I can remember updating the CODESYS environment from 3.5 SP6 to 3.5 SP7 solved that problem. At that time it was only for testing pursoses. After that I used my own GSDML file and the Hilscher module was used with more deeper configuration on target side (own definition of DAP, modules, submodules and records) which is not comparable to the Hilscher default config.
    So, maybe editing your own GSDML which suits to your purposes may help. I also recommend the PNO's GSDML checker.

    HAL9001

    Hi HAL9001,

    thanks for your reply...
    I finally found the issue; it was about a stupid GSDML item:

    Original Hilscher, which gave the error in ABB 1.1.2.1846:
    Graphics>
    <GraphicItemRef GraphicItemTarget="1" Type="DeviceSymbol"/>
    <GraphicItemRef GraphicItemTarget="1" Type="DeviceIcon"/>
    </Graphics>

    Modified:
    <Graphics>
    <GraphicItemRef GraphicItemTarget="1" Type="DeviceSymbol"/>
    </Graphics>

    Now it works, also in the old version of the ABB Automation Builder

    Cheers!
    Robbert

Ähnliche Themen

  1. [SUCHE] NL 50N-MPI-ATVISE von Hilscher
    Von poppycock im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 23.06.2012, 21:37
  2. Codesys -> Hilscher CIF50PB
    Von röhrengertl im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 08.12.2010, 07:31
  3. Codesys-Hilscher Cif50PB-WagoI/O
    Von Jason88 im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 29.11.2010, 18:26
  4. CoDeSys V2.3 Installation auf WHS
    Von Pietpinguin im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 20.10.2010, 15:23
  5. cif 50pb von Hilscher
    Von bernd7 im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 17.12.2006, 22:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •