Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: 315-2DP Master und eine 315-2PN/DP als DP Slave

  1. #1
    Registriert seit
    21.05.2004
    Beiträge
    412
    Danke
    26
    Erhielt 16 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    habe eine alte Anlage mit 315-2DP und nun soll eine 315-2PN/DP als Slave gekoppelt werden.

    Es funktioniert:
    Wenn ich in Step7 auf "Erreichbare Teilnehmer" gehe, sehe ich meinen Knoten 39 (315-2PN/DP) und kann auch das Baustein Verzeichnis anzeigen.
    Somit funktioniert die Kommunikation grundlegend.

    Nicht funktioniert jedoch der Datenaustausch.
    Step7:
    Im Master habe ich die Baugruppe per GSD vom S eingefügt und Master_E_Slave_A 16By Einheit 150..165 angelegt (analog dazu die Ausgänge)

    TIA
    Im Slave habe ich I-Slave-Kommunikation
    I150..165 Länge 16 Byte Konsistenz Einheit und analog Q150... angelegt

    TIA = zufrieden.
    Step7 = zufrieden.

    HWkonfig - Step7 teilt mir beim Knoten 39 (mein 315 Slave) mit "Problem"
    Allgemein:
    Baugruppe projektiert, aber nicht vorhanden
    Soll-/Ist-Abweichung:
    - Soll-Typ: DP-Slave (6ES7 315-2EH14-0AB0)
    - Ist-Typ: Nicht vorhanden

    DP-SlaveDiagnose:
    DP-Slave noch nicht für den Datenaustausch bereit
    Unterschiedliche Konfigurationsdaten
    Slave-spezifische Diagnosedaten
    DP-Slave muss neu parametriert werden.

    Ich schreibe im Master auf PEW 150, im Slave kommt nix an.

    Jemand eine Idee was ich hier falsch mache?

    Bitte Danke
    Zitieren Zitieren 315-2DP Master und eine 315-2PN/DP als DP Slave  

  2. #2
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.142
    Danke
    27
    Erhielt 728 Danke für 635 Beiträge

    Standard

    Hi,

    da wären die Konfigurationen als screen sehr interessant.
    Ich lese es so das du die falschen Reihenfolgen projektiert hast.
    Wenn du im Masterprojet angefangen hast mit Master_E_Slave_A dann darfst du im TIA nicht mit einem Inputslot anfangen sondern genau spiegelverkehrt zum Master mit einem Ausgang.

    Und das schreiben auf einen PEW dürfte auch nicht viel bringen da Eingänge naturgemäß eher nur zum lesen dienen, daher also PAW!
    Gruß
    Christoph

  3. Folgender Benutzer sagt Danke zu ChristophD für den nützlichen Beitrag:

    Kurt (20.07.2016)

  4. #3
    Kurt ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.05.2004
    Beiträge
    412
    Danke
    26
    Erhielt 16 Danke für 8 Beiträge

    Standard

    Danke,
    es stimmt, in beiden Projekten ist zuerst der E Bereich definiert und dann der A Bereich. Werde ich morgen früh sofort testen.
    Das Schreiben auf PEW ist ein Schreibfehler - ist natürlich PAW!

  5. #4
    Kurt ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.05.2004
    Beiträge
    412
    Danke
    26
    Erhielt 16 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke - hat geholfen!
    Ich habe die Definition der E/A Bereiche ausgedreht und
    Master und Salve Lesen/Schreiben Zugriff über PEW und PAW.

    Kurt

Ähnliche Themen

  1. Antworten: 21
    Letzter Beitrag: 27.03.2012, 20:32
  2. 315-2DP als Slave, Master aber inaktiv
    Von L.T. im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 30.06.2011, 11:57
  3. Antworten: 1
    Letzter Beitrag: 10.02.2008, 16:36
  4. Antworten: 6
    Letzter Beitrag: 09.08.2007, 21:10
  5. Antworten: 2
    Letzter Beitrag: 11.01.2005, 17:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •