Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: CP 343-1 als I-Device konfigurieren

  1. #1
    Registriert seit
    09.01.2012
    Beiträge
    56
    Danke
    17
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Leute,

    ich bin absoluter Neuling was Profinet angeht. Ein Kunde von uns möchte gerne 2 SPSen via Profinet kommunizieren lassen, wobei eine SPS von uns betreut wird, die andere von einem anderen Fremdhersteller. Der Kunde hat hierzu gewünscht, dass es über einen zusätzlichen CP an unserer SPS laufen soll, der sich dann in das bestehende Profinet-Netz einfügt.

    Leider schaffe ich es trotz Vorgehen wie von Siemens beschrieben bisher nicht, den CP in STEP7 so zu konfigurieren, dass die resultierende GSD Datei im Projekt der anderen Firma nutzbar ist. Das Hauptproblem: Sie können dem Teilnehmer keine IP-Adresse zuweisen, und obwohl das Device bei mir als vernetzt und mit Adresse versehen ist, steht in deren HWConfig nachher, dass das Gerät nicht vernetzt sei ("nicht gekoppelt"). Der Button "Ethernet" ist zudem ausgegraut.

    Folgende habe ich beim Anlegen des I-Devices gemacht:
    1. CP 343-1 in unser Rack gezogen
    2. Objekteigenschaften von X1 -> I-Device angehakt
    3. Dort auch Applikationstransferbereiche angelegt
    4. Unter "Allgemein->Schnittstelle->Eigenschaften" ein neues Netz angelegt, mit selbem Namen und selber S7-Subnetz-ID wie in der anderen Steuerung
    5. IP und korrekte Maske vergeben
    6. Gerätename eingetragen
    7. Alles gespeichert und übersetzt
    8. I-Device GSD Datei exportiert


    Ich habe mir die GSD Datei auch mal im Editor angeschaut. Dort taucht die IP-Adresse überhaupt nicht auf!! Wie bekomme ich das dann überhaupt konfiguriert? Die Anleitungen von Siemens sind hier, finde ich, auch ziemlich schwerfällig formuliert und etwas knapp.

    Vielen Dank im Voraus!
    Zitieren Zitieren CP 343-1 als I-Device konfigurieren  

  2. #2
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.430
    Danke
    27
    Erhielt 825 Danke für 713 Beiträge

    Standard

    Hallo,

    IP Adresse wird beim i-Device gar nicht exportiert, aus dem einfachen Grund das nicht das Device Gerät bestimmt welche IP es hat sondern der Controller.
    Sie müssten also in dem Engineering der anderen Steuerung eine IP und einen Namen für das Device festlegen.
    Genauso mit dem Netzwerk. Solche Daten werden nicht exportiert da sie abhängig von dem Projekt in dem das i-Device importiert werden.

    Kannst du sagen welche SW die im Einsatz haben? "Nicht gekoppelt" klingt für mich nach TIA Portal, dort dann einfach mal auf nicht gekoppelt klicken und die PN Schnittstelle des Controllers auswählen dann ist es gekoppelt, man kann Name und IP passend vergeben und es sollte laufen.

    Gruß
    Christoph

  3. #3
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    56
    Danke
    17
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Christoph,

    das ist ja gerade das Problem: Sie können keine IP einstellen, da die Option dafür ausgegraut ist. Die Software ist dem Screenshot nach den ich habe eindeutig STEP7. Der Text "nicht gekoppelt" ist auch nicht klickbar. Es ist ein reines Label in dem Eigenschaftsfenster des Devices nachdem es in das Projekt importiert wurde. Ich habe das Bild vom Kunden einfach mal angehängt, da sieht man es besser drauf. Da gibt's kaum etwas was man überhaupt einstellen könnte.
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Scalance S612 als Router konfigurieren
    Von GuybrushThreepwood im Forum PC- und Netzwerktechnik
    Antworten: 7
    Letzter Beitrag: 16.11.2016, 10:36
  2. S7 1212 als Profinet IO Device
    Von RobiHerb im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 15.02.2013, 15:49
  3. S7-1200 als i-device?
    Von Holzler im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 29.08.2012, 19:51
  4. S7-315-2PN/DP als IO-Device
    Von König im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 08.08.2011, 08:50
  5. cp 343-lean konfigurieren - aber wie??
    Von andyecht im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 11.01.2007, 13:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •