Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: CP 343-1 als I-Device konfigurieren

  1. #1
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Leute,

    ich bin absoluter Neuling was Profinet angeht. Ein Kunde von uns möchte gerne 2 SPSen via Profinet kommunizieren lassen, wobei eine SPS von uns betreut wird, die andere von einem anderen Fremdhersteller. Der Kunde hat hierzu gewünscht, dass es über einen zusätzlichen CP an unserer SPS laufen soll, der sich dann in das bestehende Profinet-Netz einfügt.

    Leider schaffe ich es trotz Vorgehen wie von Siemens beschrieben bisher nicht, den CP in STEP7 so zu konfigurieren, dass die resultierende GSD Datei im Projekt der anderen Firma nutzbar ist. Das Hauptproblem: Sie können dem Teilnehmer keine IP-Adresse zuweisen, und obwohl das Device bei mir als vernetzt und mit Adresse versehen ist, steht in deren HWConfig nachher, dass das Gerät nicht vernetzt sei ("nicht gekoppelt"). Der Button "Ethernet" ist zudem ausgegraut.

    Folgende habe ich beim Anlegen des I-Devices gemacht:
    1. CP 343-1 in unser Rack gezogen
    2. Objekteigenschaften von X1 -> I-Device angehakt
    3. Dort auch Applikationstransferbereiche angelegt
    4. Unter "Allgemein->Schnittstelle->Eigenschaften" ein neues Netz angelegt, mit selbem Namen und selber S7-Subnetz-ID wie in der anderen Steuerung
    5. IP und korrekte Maske vergeben
    6. Gerätename eingetragen
    7. Alles gespeichert und übersetzt
    8. I-Device GSD Datei exportiert


    Ich habe mir die GSD Datei auch mal im Editor angeschaut. Dort taucht die IP-Adresse überhaupt nicht auf!! Wie bekomme ich das dann überhaupt konfiguriert? Die Anleitungen von Siemens sind hier, finde ich, auch ziemlich schwerfällig formuliert und etwas knapp.

    Vielen Dank im Voraus!
    Zitieren Zitieren CP 343-1 als I-Device konfigurieren  

  2. #2
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.773
    Danke
    30
    Erhielt 907 Danke für 788 Beiträge

    Standard

    Hallo,

    IP Adresse wird beim i-Device gar nicht exportiert, aus dem einfachen Grund das nicht das Device Gerät bestimmt welche IP es hat sondern der Controller.
    Sie müssten also in dem Engineering der anderen Steuerung eine IP und einen Namen für das Device festlegen.
    Genauso mit dem Netzwerk. Solche Daten werden nicht exportiert da sie abhängig von dem Projekt in dem das i-Device importiert werden.

    Kannst du sagen welche SW die im Einsatz haben? "Nicht gekoppelt" klingt für mich nach TIA Portal, dort dann einfach mal auf nicht gekoppelt klicken und die PN Schnittstelle des Controllers auswählen dann ist es gekoppelt, man kann Name und IP passend vergeben und es sollte laufen.

    Gruß
    Christoph

  3. #3
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Christoph,

    das ist ja gerade das Problem: Sie können keine IP einstellen, da die Option dafür ausgegraut ist. Die Software ist dem Screenshot nach den ich habe eindeutig STEP7. Der Text "nicht gekoppelt" ist auch nicht klickbar. Es ist ein reines Label in dem Eigenschaftsfenster des Devices nachdem es in das Projekt importiert wurde. Ich habe das Bild vom Kunden einfach mal angehängt, da sieht man es besser drauf. Da gibt's kaum etwas was man überhaupt einstellen könnte.
    Angehängte Grafiken Angehängte Grafiken

  4. #4
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Problem besteht leider noch immer, und die Informationslage zu I-Devices ist irgendwie recht dünn. Ist das SO exotisch, dass hier keiner mit etwas Erfahrung ausgestattet ist? Wie kommunizieren SPSen sonst über Profinet?

  5. #5
    Registriert seit
    25.02.2016
    Beiträge
    270
    Danke
    17
    Erhielt 49 Danke für 46 Beiträge

    Standard

    Hallo Medium

    Die beiden SPS liegen schon im gleichen sup Netz oder?

    Köntest du mal die ips hier online Stellen mit SUB Maske?

    Die ip der Partner sps ist auch nirgends doppelt vergeben?

  6. Folgender Benutzer sagt Danke zu Wincctia für den nützlichen Beitrag:

    Medium (28.05.2017)

  7. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.019
    Danke
    900
    Erhielt 3.241 Danke für 2.619 Beiträge

    Standard

    Hallo Medium,

    wenn Du in Deiner HW Konfig dem CP343-1 (dem I-Device) eine IP-Adresse zugewiesen hast, dann kann der IO-Controller dem CP343-1 (logischerweise) gar keine IP-Adresse zuweisen.

    Wenn bei Euch der fremde IO-Controller Eurem CP343-1 eine IP-Adresse zuweisen soll, dann mußt Du in Deiner HW Konfig den CP343-1 lediglich mit dem Ethernet des IO-Controllers vernetzen und einen PROFINET-Gerätename geben und (vermutlich) einstellen "IP-Adresse auf anderem Weg einstellen". In dem Fall kannst Du den CP343-1 allerdings für fast nichts anderes mehr benutzen, z.B. keine Verbindungen projektieren.

    Ist der CP343-1 ausschließlich wegen der PROFINET-IO-Kommunikation zu dem anderen System eingebaut worden? Dann würde ich einen PN/PN-Koppler oder einen CP343-1 LEAN empfehlen, die kosten nämlich nur die Hälfte eines CP343-1. (ca. 600,- EUR Ersparnis). Der PN/PN-Koppler ist außerdem einfacher zu projektieren und trennt die Netzwerke besser, weil er nur die projektierte PNIO-Kommunikation durchläßt.

    PS: das "Gekoppelt mit:" dient dazu, anzugeben welche Station das I-Device ist, wenn IO-Controller und I-Device im selben Step7-Projekt projektiert werden. Dann brauchen die Transferbereiche zwischen IO-Controller und I-Device nur einmal eingegeben werden. In dem Fall wird keine GSD/xml-Datei verwendet.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Medium (28.05.2017)

  9. #7
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Wincctia Beitrag anzeigen
    Hallo Medium

    Die beiden SPS liegen schon im gleichen sup Netz oder?

    Köntest du mal die ips hier online Stellen mit SUB Maske?

    Die ip der Partner sps ist auch nirgends doppelt vergeben?
    Hallo!
    Diese Dinge sind alle sichergestellt. Wir haben in der Vergangenheit PROFINET->SNMP Gateways für diese Aufgabe benutzt, die aber leider sehr instabil laufen. Die IPs der ausgebauten Gateways nutzen wir nun für die CPs. Die Subnetzmasken sind auch korrekt. (Alle Teilnehmer sind im selben Private Class C Netz mit FF.FF.FF.00 Subnetz.)


    Zitat Zitat von PN/DP Beitrag anzeigen
    Hallo Medium,

    wenn Du in Deiner HW Konfig dem CP343-1 (dem I-Device) eine IP-Adresse zugewiesen hast, dann kann der IO-Controller dem CP343-1 (logischerweise) gar keine IP-Adresse zuweisen.
    Das war der von mir eigentlich gewollte Weg: Die GSD-nutzende Partei sollte diese im Idealfall einfach importieren, in seine HWConfig einpflegen, und ohne große Konfiguration nutzen können. Das war zumindest die Hoffnung. Ich habe letztens jedoch mal die GSD-Dateien die ich erzeugen lasse in einem Texteditor angesehen: In dieser ist NIRGENDS die von mir vergebene IP hinterlegt! Nicht dezimal, nicht in Hex, nicht als irgendwas. Egal was ich einstelle, der GSD-Nutzer kann meine Einstellung überhaupt nicht mitbekommen. Das hat mich dann doch SEHR irritiert.

    Wenn bei Euch der fremde IO-Controller Eurem CP343-1 eine IP-Adresse zuweisen soll, dann mußt Du in Deiner HW Konfig den CP343-1 lediglich mit dem Ethernet des IO-Controllers vernetzen
    Das ist insofern ein Problem, als dass Controller und CPs in unterschiedlichen Projekten projektiert sind. Von unterschiedlichen Firmen. Deshalb ja das "Geraffel" mit den GSD-Dateien zum Austausch der gemeinsamen Schnittstelle. Wenn alles in einem Projekt wäre, wären die ja überflüssig.

    und einen PROFINET-Gerätename geben und (vermutlich) einstellen "IP-Adresse auf anderem Weg einstellen". In dem Fall kannst Du den CP343-1 allerdings für fast nichts anderes mehr benutzen, z.B. keine Verbindungen projektieren.
    Name ist vergeben. Ich habe auch mal den Namen und die ID des bestehenden Netzes im Fremdprojekt auch in meinem Projekt vergeben und den CP damit verbunden. Dies hatte keinen Effekt, und diese Infos tauchten ebenfalls nicht in den GSD-Dateien auf, wenn in einem Texteditor betrachtet. (Dass die CPs dann für andere Zwecke nicht mehr nutzbar sind ist okay. Sie wurden speziell und nur für diesen Zweck angeschafft.)

    Dann würde ich einen PN/PN-Koppler oder einen CP343-1 LEAN empfehlen, die kosten nämlich nur die Hälfte eines CP343-1. (ca. 600,- EUR Ersparnis).
    Die CPs wurden durch den Kunden beigestellt und sind bereits angeschafft und eingebaut. Daran kann ich nichts mehr ändern. Aber ein vollwertiger CP343-1 sollte ja durchaus auch gehen.

    PS: das "Gekoppelt mit:" dient dazu, anzugeben welche Station das I-Device ist, wenn IO-Controller und I-Device im selben Step7-Projekt projektiert werden. Dann brauchen die Transferbereiche zwischen IO-Controller und I-Device nur einmal eingegeben werden. In dem Fall wird keine GSD/xml-Datei verwendet.
    Okay, gut zu wissen. Dennoch bin ich sehr irritiert davon, dass meine Netzwerkeinstellungen in den GSDs nicht auftauchen, und der GSD-Nutzer diese nicht einstellen kann. Irgendwo her müssen diese Infos doch kommen... hab mir das ganze wohl zu einfach vorgestellt.


    Danke euch beiden!!
    Geändert von Medium (28.05.2017 um 01:54 Uhr)

  10. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.019
    Danke
    900
    Erhielt 3.241 Danke für 2.619 Beiträge

    Standard

    Es ist eigentlich nicht verwunderlich, daß in der GSD-Datei keine IP-Adresse enthalten ist, weil wenn der IO-Controller die IP-Adresse zuweisen soll, dann wird die gewünschte IP-Adresse im Projekt des IO-Controllers eingegeben, und wenn er die IP-Adresse nicht zuweisen soll, dann braucht er sie auch nicht wissen.

    Ich habe so eine GSD/xml-Datei noch nicht näher angeschaut, doch anscheinend ist es auch nicht nötig, daß das vernetzte Ethernet beim I-Device den selben Name und selbe S7-Subnetz-ID wie beim IO-Controller hat. In den Anleitungen zur Projektierung von I-Devices steht auch nirgends, daß das vernetzte Netz bestimmte Einstellungen (Name und S7-Subnetz-ID) haben muß. Bei PROFINET-IO ist sowieso kein Routing möglich. Das I-Device muß lediglich anhand des Gerätenamens vom IO-Controller (per DCP-Protokoll) gefunden werden.


    Habt Ihr eigentlich mal ausprobiert ob Eure PROFINET-IO-Verbindung funktionert? Wenn HW Konfig in beiden Projekten keine Fehler meldet dann steht dem Test nichts im Wege.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Medium (29.05.2017)

  12. #9
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von PN/DP Beitrag anzeigen
    Es ist eigentlich nicht verwunderlich, daß in der GSD-Datei keine IP-Adresse enthalten ist, weil wenn der IO-Controller die IP-Adresse zuweisen soll, dann wird die gewünschte IP-Adresse im Projekt des IO-Controllers eingegeben, und wenn er die IP-Adresse nicht zuweisen soll, dann braucht er sie auch nicht wissen.
    Das war ja meine Verwirrung: Der Controller sollte die IP nicht zuweisen, sondern meine Voreinstellung übernehmen. Ich hätte angenommen, dass wenn er sie übernimmt, sie irgendwo in dem Fremdprojekt auftauchen müsste. (Alleine schon zur Prüfung möglicher Konflikte innerhalb des Projektes.)

    [...] anscheinend ist es auch nicht nötig, daß das vernetzte Ethernet beim I-Device den selben Name und selbe S7-Subnetz-ID wie beim IO-Controller hat. In den Anleitungen zur Projektierung von I-Devices steht auch nirgends, daß das vernetzte Netz bestimmte Einstellungen (Name und S7-Subnetz-ID) haben muß. Bei PROFINET-IO ist sowieso kein Routing möglich.
    Gesehen habe ich das auch nicht. Da jedoch die meisten Beispiele sowohl Controller als auch CP im selben Projekt zeigen, und somit theoretisch alle gegenseitigen Daten haben, war dies ein Versuch von mir.

    Das I-Device muß lediglich anhand des Gerätenamens vom IO-Controller (per DCP-Protokoll) gefunden werden.
    DAS wäre natürlich die Lösung! Ich bin bisher davon ausgegangen, dass - wie in den meisten IP-basierten Netzen - die IP der definierende Faktor eines Kommunikationspartners ist. Wenn der bloße Name schon ausreicht, dann müsste es ja eigentlich klappen.

    Habt Ihr eigentlich mal ausprobiert ob Eure PROFINET-IO-Verbindung funktionert? Wenn HW Konfig in beiden Projekten keine Fehler meldet dann steht dem Test nichts im Wege.
    Bisher nicht. Der Kunde ist etwas weiter weg, und hatte erst ein paar Umbauten zu erledigen. Ich werde voraussichtlich am kommenden Freitag dort sein, und dann mal schauen ob wir positiv oder negativ überrascht werden

    Besten Dank! Mit dieser Info fahre ich gleich etwas "beschwingter" zum Kunden!

Ähnliche Themen

  1. Scalance S612 als Router konfigurieren
    Von GuybrushThreepwood im Forum PC- und Netzwerktechnik
    Antworten: 7
    Letzter Beitrag: 16.11.2016, 10:36
  2. S7 1212 als Profinet IO Device
    Von RobiHerb im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 15.02.2013, 15:49
  3. S7-1200 als i-device?
    Von Holzler im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 29.08.2012, 19:51
  4. S7-315-2PN/DP als IO-Device
    Von König im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 08.08.2011, 08:50
  5. cp 343-lean konfigurieren - aber wie??
    Von andyecht im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 11.01.2007, 13:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •