Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Profibus Problem mit S7 1200 und Anybus Communicator

  1. #1
    Join Date
    14.05.2019
    Posts
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin Moin und danke für die Aufnahme


    Ich habe ein Problem mit der Datenübertragung einer S7 1200 und einem Anybus Communicator via Profibus.
    Der Communicator (Slave) ist in einem Generator verbaut, welcher eine Probe induktiv erwärmen soll.


    Ich habe das Ganze mit einem GSD File projektiert, E/A Module eingefügt und Variablen angelegt. Soweit so gut.

    Das erste komische was mir aufgefallen ist, war das die Adressen bei 0 Anfangen sollten, jedoch die E/A Module des GSD Files nur bei 1 Anfangen können (Adresse 0 angeblich belegt, auch wenn nicht ersichtlich ist durch was).

    Ich habe also die erste Adresse übersprungen (dieser Wert ist vorerst unwichtig) und beim nächsten Angefangen, anschließend alle weiteren hinzugefügt.
    Nur wenn ich die Werte der Variablen anschaue, sind die Werte stets um 1 Word bzw. 2 Byte verschoben, obwohl die Adressen eigentlich stimmen. Ich habe eine Liste der E/A Adressen von der Firma mitgeteilt bekommen, d.h. darauf (sollte) ich mich eigentlich verlassen können, dass diese stimmen.
    Ich habe den Communicator auch direkt an den PC angeschlossen und konnte die Werte auslesen, wodurch ich mich auch vergewissern konnte, dass die Werte nach der Profibusübertragung (abgesehen von der Verschiebung) dieselben sind. Die Verschiebung ist jedoch wirklich erst nach dem Profibus vorhanden, nicht bei direkter Verbindung.
    Und abschließend ist es leider so, dass die Werte für mich auch absolut kein Sinn ergeben. Beispielsweise habe ich die Variable „Timer“ beobachtet, den Timer kann ich direkt am Generator einstellen, weiß daher welchen Realwert es sein sollte und sehe auch das sich die Variable im TIA Portal verändert, also ich beobachte nicht die Falsche. Ich mach am besten einfach mal ein Beispiel:


    Variable „Timer“, Adresse 12 bis 15 (4 Byte)

    Realwert: 0:00 Variable: 000 000 000 000 (dezimal)
    Realwert: 0:01 Variable: 061 204 204 207 (dezimal)
    Realwert: 0:02 Variable: 062 076 204 206 (dezimal)
    Realwert: 0:03 Variable: 062 153 153 154 (dezimal)

    Die Sprünge der jeweiligen Sekunden sind auch nicht identisch, über ein Bereich von einigen Minuten betragen sie 64 pro Sekunde, dann plötzlich 128… Und wieso die erste Startadresse von 1 Sekunde so aussieht (Siehe Beispiel) verstehe ich auch nicht. Ich kann mir auch beim besten Willen nicht vorstellen, dass es so gewollt ist das man den gesamten Verlauf von allen Möglichkeiten durchgehen muss und jede Variablenwert den „Realwert“ zuweisen muss, das wäre doch ein absolut ungerechtfertigter Zeitaufwand oder?




    Ich wäre wirklich mega dankbar, wenn hier vielleicht jemand etwas damit anfangen kann und ggf. sagen kann wo ich falsch liege. Wenn ich was vergessen haben sollte oder unverständlich dargestellt habe könnt ihr mir das gerne mitteilen, ich werde es dann nachtragen

    Achja die jeweiligen Hersteller habe ich auch schon angeschrieben, leider verweisen die untereinander immer auch eine andere Partei, was es mir nicht wirklich leichter macht

    Vielen Dank schonmal und ein schönen Tag allen!
    Reply With Quote Reply With Quote Profibus Problem mit S7 1200 und Anybus Communicator  

  2. #2
    Join Date
    23.07.2009
    Location
    Österreich
    Posts
    2,459
    Danke
    490
    Erhielt 733 Danke für 554 Beiträge

    Default

    Wie beobachtest du das? Der Wert 061 204 204 207 (dezimal) geht sich doch gar nicht in 32Bit (4 Byte Real) aus?
    Vielleicht postest du mal einen Screenshot von deiner Slave-Konfigration inkl. Module bzw. wie die andere Seite in der Anybus-Config-Software aussieht.



    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  3. Folgender Benutzer sagt Danke zu RONIN für den nützlichen Beitrag:

    MarcelKIT (15.05.2019)

  4. #3
    Join Date
    22.06.2009
    Location
    Sassnitz
    Posts
    13,563
    Danke
    1,090
    Erhielt 4,005 Danke für 3,237 Beiträge

    Default

    Quote Originally Posted by MarcelKIT View Post
    Realwert: 0:00 Variable: 000 000 000 000 (dezimal) = 16#/0x 00000000 = 0.0
    Realwert: 0:01 Variable: 061 204 204 207 (dezimal) = 16#/0x 3DCCCCCF = 0.10000002
    Realwert: 0:02 Variable: 062 076 204 206 (dezimal) = 16#/0x 3E4CCCCE = 0.20000002
    Realwert: 0:03 Variable: 062 153 153 154 (dezimal) = 16#/0x 3E99999A = 0.3
    Alles gut. Du beobachtest das Bitmuster von REAL-Werten. Wenn Du schon weißt daß die Werte REAL sein sollen, warum beobachtest Du die Werte dann nicht einfach mal im REAL-Format? Beobachten von Kommunikation oder überhaupt von unverständlichen Werten sollte man immer mal in verschiedenen Formaten tun, bevorzugt zuerst mal in HEX anschauen.
    Wie die Bitmuster von REAL-Werten aussehen kannst Du hier nachschauen:
    IEEE-754 Konverter für Fließkommazahlen


    Dein Problem mit "Verschiebung" verstehe ich nicht. Kannst Du das nochmal kürzer erklären?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. Folgende 2 Benutzer sagen Danke zu PN/DP für den nützlichen Beitrag:

    MarcelKIT (15.05.2019),RONIN (15.05.2019)

  6. #4
    Join Date
    23.07.2009
    Location
    Österreich
    Posts
    2,459
    Danke
    490
    Erhielt 733 Danke für 554 Beiträge

    Default

    Ahh.. jetzt hat es bei mir auch klick gemacht...

    16#3DCCCCCF ist eigentlich 1036831951 dez.
    Aber wenn der TE die einzelnen Bytes dezimal beobachtet dann kommt eben für 16#3D (061), für 16#CC (204dez) usw. raus.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  7. Folgender Benutzer sagt Danke zu RONIN für den nützlichen Beitrag:

    MarcelKIT (15.05.2019)

  8. #5
    MarcelKIT is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.05.2019
    Posts
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Default

    Das mit den REAL Zahlen ist ein super Tipp, so macht das ja tatsächlich Sinn

    Im Anhang habe ich ich mal ein Bild wo die Variablentabelle Zeigt im TIA Portal, und 2 Screenshots vom Anybus Tool, jeweils einmal in Dez und einmal in hex angezeigt. Jeweils auf 0,1sec eingestellt.

    Die richtigen Bytes hab ich eingerahmt (hoffe man erkennt es).

    Wird wohl auch ein blöder Fehler meinerseits seien, aber ich komm nicht drauf ^^
    Attached Images Attached Images

  9. #6
    Join Date
    23.07.2009
    Location
    Österreich
    Posts
    2,459
    Danke
    490
    Erhielt 733 Danke für 554 Beiträge

    Default

    Wenn ich dich richtig verstehe geht es jetzt nur mehr darum warum die Adressen verschoben sind, oder?
    Wenn du derzeit z.B. ID46 im Anzeigeformat REAL beobachten würdest müsstest du ja schon 0.1 sehen.

    Die EA-Adressen auf der SPS sind von der Konfiguration des Profibus-Slaves in der Hardwarekonfig der SPS ab.
    Zeig uns doch mal einen Screenshot wie der Anybus (vor allem sine Ein-Ausgangsmodule) dort konfiguriert ist.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  10. #7
    MarcelKIT is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.05.2019
    Posts
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Default

    Genau, ich habe vorhin zum testen mal die Adressen alle um 2 addiert, und tatsächlich werden jetzt alle richtig angezeigt! Ist zwar getrickst, aber dank eurer Hilfe bin ich schonmal ein gutes Stück weiter
    Ich kann mir gut vorstellen dass das damit zusammenhängt das ich Adresse 0 nicht belegen konnte/durfte und dahher die ersten zwei Adressen übersprungen habe in den E/A Modulen des Slaves, praktisch CMD0 welche von 0-1 geht weggelassen und stattdessen mit CMD1 von 2-3 angefangen

    Aber ich lade gleich den Screenshot hoch, mach grad noch kurz Mittagspause zuende

  11. #8
    Join Date
    23.07.2009
    Location
    Österreich
    Posts
    2,459
    Danke
    490
    Erhielt 733 Danke für 554 Beiträge

    Default

    Könnte mir auch gut vorstellen dass der Anybus auf den Bytes 0 und 1 irgendwelche Statusinformation mit schickt.
    Sind die ersten Bytes leer ist da was drin...
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  12. #9
    MarcelKIT is offline Neuer Benutzer
    Themenstarter
    Join Date
    14.05.2019
    Posts
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Default

    Nein er zeigt zwar die Bemerkung an das Adresse 0 belegt wäre, aber es ist nirgends aufgeführt was dann darauf vergeben sein soll. Die 1 wäre gegangen, ich habe aber das erste gesamt Modul (Byte 0 und 1) weggelassen da es nicht benötigt wird und (so mein damaliger Gedanke) dann die anderen Adressen nicht verschoben sind.

    Aber ich denke so kann ich fürs erste mit arbeiten, muss es nur dokumentieren das es nicht irgendwann mal für verwirrung sorgt xD

    Hier ist einmal die Variablen Liste, wie es nun dort aussieht (Werte Stimmen ja jetzt) und noch ein Bild der E/A Module:
    Attached Images Attached Images

  13. #10
    Join Date
    22.06.2009
    Location
    Sassnitz
    Posts
    13,563
    Danke
    1,090
    Erhielt 4,005 Danke für 3,237 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ist die Gerätekonfig fehlerfrei "komplett" übersetzt und in die S7-1200 CPU geladen? Sicher?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Similar Threads

  1. E&H RMS621 mit HMS Anybus Communicator Profibus
    By manne79 in forum Feldbusse
    Replies: 1
    Last Post: 07.07.2016, 22:29
  2. Replies: 16
    Last Post: 03.06.2016, 09:15
  3. Anybus Communicator Konfiguration
    By bycar in forum Feldbusse
    Replies: 6
    Last Post: 24.05.2012, 20:08
  4. Replies: 1
    Last Post: 18.04.2012, 09:35
  5. Anybus Communicator for Profibus HMS
    By elektrohippi in forum Simatic
    Replies: 3
    Last Post: 14.11.2010, 18:44

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •