Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Systemzeit OP170B / Pro-Tool

  1. #1
    Registriert seit
    18.07.2006
    Beiträge
    68
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,

    ich habe das Problem das bei meinem OP 170B bei jedem Spannungsverlust die Systemzeit gelöscht wird, und ich sie neu stellen muss. Wenn ich nur die CPU Zeit im Panel anzeige, habe ich das Problem, dass immer noch in der Störmeldeanzeige die falsche Systemzeit des OP`s angezeigt wird.
    Wie kann ich dies beheben bzw. umgehen ?????
    Ist es möglich die Systemzeit des OP's mit der Uhrzeit der CPU ( S7-400 ) zu stellen ????

    Vielen Dank
    Daniel
    Zitieren Zitieren Systemzeit OP170B / Pro-Tool  

  2. #2
    Registriert seit
    03.11.2006
    Beiträge
    370
    Danke
    2
    Erhielt 75 Danke für 67 Beiträge

  3. #3
    Registriert seit
    18.07.2006
    Beiträge
    68
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ich habe das Siemens Projekt Uhrzeit lesen und schreiben gezogen -->
    ( Time_WinCE_Pro-Tool_A2 ).
    Dies ist ein fertiges beispiel Projekt von Siemens. Dies habe ich mit der Runtime von Pro-Tool mal getestet. jetzt das Problem --->.....
    Die Zeit von Panel nach SPS synchronisieren funktioniert einwandfrei.
    Wenn ich aber von der SPS nach Systemzeit OP 170B synchronisiere, wird mit Fehlermeldung auf dem Panel abgebrochen. Ich kann aber sehen, dass der Baustein den Steuerauftrag 14 und 15 abschickt. Wie es aussieht wird es nur nicht vom OP angenommen. Die Fehlermeldung vom OP lautet....
    ...Datum / Uhrzeit konnte nicht gesetzt werden Fehlercode 1314,1 bzw.1314.2.....
    Wer kann mir weiterhelfen.

    Gruss Daniel
    Zitieren Zitieren Systemzeit / OP 170B synchronisieren  

  4. #4
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Idee

    Hi,
    es ist wegen unterschiedliche Formatierung der Bereiche.
    So gehts:

    Code:
    CALL  "READ_CLK"
           RET_VAL:=#dt_error
           CDT    :=#date_time
     
          CALL  "DT_DAY"
           IN     :=#date_time
           RET_VAL:=#WoTag
     
          L     LW    22
          T     "DB_Daten_TP170B".DatumUhrzeitSPS.JahrMonat
          L     LW    24
          T     "DB_Daten_TP170B".DatumUhrzeitSPS.TagStunde
          L     LW    26
          T     "DB_Daten_TP170B".DatumUhrzeitSPS.MinuteSekunde
          L     #WoTag
          T     "DB_Daten_TP170B".DatumUhrzeitSPS.Res_WoTag
    Die Lokalvariable "date_time" fängt bei Adresse 22.0 an, WoTag ist integer Adr.:30.0.


    Der TP syncronisiert sich selber.
    Gruss: Vladi
    Geändert von vladi (05.12.2006 um 17:03 Uhr)
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Uhrzeit  

  5. #5
    Registriert seit
    18.07.2006
    Beiträge
    68
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ich glaube wir reden nicht von dem selben Baustein. In dem, den ich meine wird die Zuweisung indirekt ausgewertet.

    http://support.automation.siemens.co...odeid=24079347

    LAR1 P##DateTime // DateTime= Stat-Adresse 22 / Date_and_Time

    L LB 2
    T B [AR1,P#0.0] // Year
    L LB 3
    T B [AR1,P#1.0] // Month
    L LB 4
    T B [AR1,P#2.0] // Day
    L LB 5
    T B [AR1,P#3.0] // Hours
    L LB 6
    T B [AR1,P#4.0] // Minutes
    L LB 7
    T B [AR1,P#5.0] // Seconds
    L LB 9
    T B [AR1,P#7.0] // Day of week

    Was mich auch wundert, ist das der Baustein ja eigentlich getestet sein soll
    Kann es daran liegen, das es nur nicht mit dem Runtime Test im Pro-Tool funktioniert???

    Gruss Daniel

  6. #6
    Registriert seit
    18.07.2006
    Beiträge
    68
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe den Fehler gefunden !!!!
    Der Test geht auch nur mit Panel. Im Runtime-Test von Pro-Tool kann die Systemzeit nicht geändert werden. Habe es mit OP getestet, und alles OK.

    Viel dank,

    Gruss Daniel
    Zitieren Zitieren Synchronisation OP <--> SPS  

Ähnliche Themen

  1. systemzeit auf op7
    Von linuxluder im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 25.11.2007, 17:39
  2. S7 200 und OP170B
    Von BastiMG im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 18.09.2007, 13:12
  3. Op170b
    Von M-Arens im Forum HMI
    Antworten: 1
    Letzter Beitrag: 25.07.2006, 12:38
  4. Systemzeit S7
    Von stricky im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 27.04.2006, 09:39
  5. Op170b
    Von Bond 007 im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 17.04.2006, 20:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •