Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 6 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 52

Thema: HF7 für WinCC flexible 2k5 sp1 und RT 2k5 sp1

  1. #11
    Avatar von rs-plc-aa
    rs-plc-aa ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.11.2004
    Beiträge
    697
    Danke
    69
    Erhielt 64 Danke für 48 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Hallo Siemens, RS und UG,

    ...Meine sporadischen Spezial-Effekte mit der Grafik sind mit HF7 zu permanenten Spezial-Effekten geworden! Das nenne ich einen Fortschritt! Dadurch habe ich die Ursache endlich finden können. Ich musste zwar ca. 21.893 Grafiken nachbearbeiten, aber egal, es ist erledigt...
    Gruß, Onkel
    Kannst du das etwas genauer erläutern ?
    Was für "Spezial-Effekte" meinst du da - und wie hast du sie behoben ?

    Korrektur meinerseits zum Thema dotNET:

    Natürlich kann mann auch das mitgelieferte verwenden (wenn man das HF7 Setup vorher manuell entpackt kommt man ja ran)

    Nur ist das mitgelieferte für die englische Windows Version bestimmt...
    ... kann gehen weiss ich aber nicht - und nahm wie immer NICHT das mitgelieferte.

    Wichtig ist vor allem das mit dem Dienst -> der sollte fertig sein bevor das HF7 Setup ausgeführt wird...
    RS (rs-plc-aa)
    ______________________________________________
    Morgen ist Heute Gestern...
    ______________________________________________
    Installierst du noch - oder Arbeitest du schon ?
    ______________________________________________

  2. #12
    Registriert seit
    06.10.2003
    Beiträge
    3.412
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo RS,

    Zitat Zitat von rs-plc-aa Beitrag anzeigen
    Kannst du das etwas genauer erläutern ?
    Was für "Spezial-Effekte" meinst du da - und wie hast du sie behoben ?..
    Ich könnte mich natürlich eben so gut auch gleich bei Siemens als Onkel Dagobert vorstellen, aber was soll's. Dann darf ich halt hier nicht mehr so viel schimpfen .


    In meinen RT-Projekten verwende ich viele selbsterstellte Grafiken mit transparentem Hintergrund. Diese sind eingesetzt in Grafiklisten und als einzelne Grafiken in Bildbausteinen. Kreiert wurden die Bildchen mit Paint.Net im *.png-Format. Der Hintergrund wurde transparent belassen, so wie es mit Paint.Net im genannten Format machbar ist. Transparenz ist nicht mit jedem Format möglich, nahm ich an, nachdem ich ein bisschen recherchiert hatte.

    Zustand vor HF7:
    Als ich mit dem transparenten Kram anfing, testete ich natürlich erst einmal die Möglichkeiten. Ich also, Grafik gebastelt und in einer Grafikliste verwendet - ging schon einmal nicht. Man kann beim Einfügen nicht die Option "transparent" anwählen (auch mit HF7 nicht möglich - funktioniert trotzdem). Dann habe ich einen anderen Weg gesucht. Ich fügte die einzelnen Bilder direkt als Grafik ein, legte sie übereinander und machte sie einzeln über die Eigenschaften sichtbar bzw. unsichtbar, was auch mit der Transparenz funktionierte. Welche Transparent-Farbe ich beim Einfügen wählte, hatte keinen Einfluss. Irgendwann später, als ich schon ettliche Stunden und Tage investiert hatte, erschienen einige Grafiken urplötzlich nicht mehr transparent, sondern rechteckig mit weissen Hintergrund.

    Nun begann das Rätselraten. Mit Unterstützung von Siemens kamen wir dann darauf dass sich dieser Effekt beheben lässt, wenn man die Grafiken noch einmal bearbeitet, wie z.Bsp. verschieben und dieses wieder rückgängig machen. Dann funktionierte es nach dem Generieren meist wieder. Jedoch nicht für lange Zeit! Nach Änderungen und mehrmaligem Generieren trat der Fehler immer wieder auf. Es waren immer nur einige der Grafiken betroffen. An den Grafiken selbst wurde nichts verändert. Irgendwelche nachvollziehbare Zusammenhänge gab es nicht, völlig unklar das ganze.

    Wochen später erhielt ich von Siemens die Mitteilung dass Flexible nicht jede Farbe transparent darstellen kann. Ich sollte die Grafiken mit der Transparent-Farbe einfügen, die als Voreinstellung vorgegeben ist (255;0;255). Da meine png-Grafiken ohnehin einen "farblosen" Hintergrund hatten und da es ja mal funktionierte und dann mal wieder nicht, hatte ich erst einmal garnichts unternommen. Zu diesem Zeitpunkt gab es auch keinen dringenden Handlungsbedarf, es war eh zu spät, die Anlagen liefen bereits beim Kunden.


    Zustand mit HF7:
    Der oben beschriebene Effekt trat nun permanent auf. Die Grafikhintergründe waren nun alle zuverlässig nichttransparent. Nach wenigen Versuchen war es klar. Die Hintergründe dürfen beim Erstellen der Grafik nicht transparent sein, sondern müssen die o.g. Farbe bekommen (255;0;255)! Ob es nun auch mit beliebigen Formaten oder mit anderen Farben funktioniert, habe ich nicht getestet.


    Das Abartige war, dass der Effekt sporadisch auftrat. Der Ursache auf den Grund zu gehen, war so gut wie aussichtslos. Auswirkungen von Änderungen kamen u.U. erst Tage später zum Vorschein.


    HF7 läuft bei mir bis jetzt ohne Probleme.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  3. #13
    Registriert seit
    27.02.2007
    Beiträge
    27
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Daumen runter

    Hallo zusammen

    habe nun auch das Hotfix 7 installiert, nach dem ich reichlich positive Kritik gelesen habe - und ärger mich schwarz. Komme mir i.M. vor wie Beta-Tester.

    Heute 1,5h verloren, weil ich das Zeichnen einer Linie mit ESC abgebrochen habe. Resultat: WinCC hat sich ohne Vorwarnung verabschiedet.

    Konvertieren nach Version 2005 getestet ( läuft noch auf meinem Notebook; und das bleibt auch vorerst so!! ): aus den Grafiklisten sind die Standardwerte verschwunden !! Angelegt hatte ich 4 Grafiken mit den Wertigkeiten 0 - 4, wobei 0 (graues Feld) der Standard war.

    Nach dem Absturz kam (ganz Windows-like) das Meldungsfenster mit der Absturzursache, leider war der Senden-Button grau hinterlegt, sprich nicht bedienbar. Habe das Ganze dann kopiert und an Winflexible.quality geschickt.

    Bananen-Hotfix ?!?!? Reift beim Kunden!

    Überlege ernsthaft, ob ich das Ganze mit 2K5 SP1 HF6 wieder überbügel.

    // STRG-S im 2-Minutentakt ist notwendig; zumindest bei meiner Installation, sammel gerade die Sachen, die nicht funktionieren; werde die dann hier posten. Bin mal gespannt, was der Support sagt.
    Geändert von Shadow (06.03.2007 um 11:26 Uhr) Grund: // Zusatz
    Gruß
    Peter
    --------------------------------------------------------
    Win XP SP2, Pentium(R) 3GHz, 2GB RAM - WinCC flex 2007
    --------------------------------------------------------
    Fehler macht jeder. Aber für die richtig dicken Probleme braucht man einen Computer!
    Zitieren Zitieren HF7 - ... und bis jetzt nur Ärger  

  4. #14
    Avatar von rs-plc-aa
    rs-plc-aa ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.11.2004
    Beiträge
    697
    Danke
    69
    Erhielt 64 Danke für 48 Beiträge

    Standard

    Hallo,

    @ Onkel Dagobert:

    vielen Dank für das detaillierte Aufzeigen - so bleibt keine weitere Frage offen...
    Höchstens an Siemens selbst in Bezug auf welchen Bildeditor die wohl als "Referenz" zugrunde gelegt haben der die Anforderungen von flexible erfüllt bzw. umgekehrt.
    (Ich selbst verwende übrigens auch Paint.net)

    Ist sowieso ein wenig suspekt was unter "Einstellungen" -> "OLE-Einstellungen" alles für Formate <angeboten> werden bei denen ich mir beim besten willen nicht vorstellen kann daß diese eingefügt werden können - bei manchen probier ich es besser gar nicht ...

    @ Shadow:

    Bei dir ist wenn dann bei der Installation des HF7 was schief gegangen...

    Am HF7 selbst kanns nicht liegen da es bei anderen diese Probleme nicht gibt.
    Ich würde dir empfehlen sofort dein Image zurückzusichern welches du ja VOR der Installation eines JEDEN Updates für SIMATIC Software erstellt hast, und dann einen neuen Versuch starten.

    Hattest du das dotNET Framework v2 vor der Installation schon drauf - oder hast du es mit dem Setup mit "erledigen lassen" ?

    Die Antwort wäre vielleicht gar nicht so uninteressant...
    RS (rs-plc-aa)
    ______________________________________________
    Morgen ist Heute Gestern...
    ______________________________________________
    Installierst du noch - oder Arbeitest du schon ?
    ______________________________________________

  5. #15
    Registriert seit
    27.02.2007
    Beiträge
    27
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Zitat Zitat von rs-plc-aa Beitrag anzeigen
    Hallo,

    @ Onkel Dagobert:

    vielen Dank für das detaillierte Aufzeigen - so bleibt keine weitere Frage offen...
    Höchstens an Siemens selbst in Bezug auf welchen Bildeditor die wohl als "Referenz" zugrunde gelegt haben der die Anforderungen von flexible erfüllt bzw. umgekehrt.
    (Ich selbst verwende übrigens auch Paint.net)

    Ist sowieso ein wenig suspekt was unter "Einstellungen" -> "OLE-Einstellungen" alles für Formate <angeboten> werden bei denen ich mir beim besten willen nicht vorstellen kann daß diese eingefügt werden können - bei manchen probier ich es besser gar nicht ...

    @ Shadow:

    Bei dir ist wenn dann bei der Installation des HF7 was schief gegangen...

    Am HF7 selbst kanns nicht liegen da es bei anderen diese Probleme nicht gibt.
    Ich würde dir empfehlen sofort dein Image zurückzusichern welches du ja VOR der Installation eines JEDEN Updates für SIMATIC Software erstellt hast, und dann einen neuen Versuch starten.

    Hattest du das dotNET Framework v2 vor der Installation schon drauf - oder hast du es mit dem Setup mit "erledigen lassen" ?

    Die Antwort wäre vielleicht gar nicht so uninteressant...
    Moin
    habe das beiliegende dotNET installiert, quasi nach Installationsanleitung.
    Frage mich als "normaler" Anwender, warum ich das nicht tun sollte. Schließlich hat die Weltfirma Siemens dies Paket dabeigelegt - und dann sollte es auch die Qualitätssicherung durchlaufen haben. Soviel zur Theorie.
    Zum Thema Image zurücksichern - unsere Arbeitsstationen werden automatisch gesichert. Muß allerdings warten bis Chef Nr.2, der auch unser Admin ist, wieder im Hause weilt. Dann schau'n wir mal.

    Ich weiß schon warum ich auf eine 2.Partition für Siemens-Software bestanden habe. Keine gräbt sich so tief ins System.

    Alles wird gut... (...immer nur 5 Minuten ärgern)
    Gruß
    Peter
    --------------------------------------------------------
    Win XP SP2, Pentium(R) 3GHz, 2GB RAM - WinCC flex 2007
    --------------------------------------------------------
    Fehler macht jeder. Aber für die richtig dicken Probleme braucht man einen Computer!

  6. #16
    Avatar von rs-plc-aa
    rs-plc-aa ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.11.2004
    Beiträge
    697
    Danke
    69
    Erhielt 64 Danke für 48 Beiträge

    Standard

    Hallo,

    dann lies (@Shadow) doch bitte noch mal den Eröffnungsbeitrag zum Thema.

    Hier wird darauf hingewiesen daß es Probleme geben KÖNNTE (nicht MUSS) wenn man irgendwas mit flexible rumfummelt und im Hintergrund eine noch nicht ganz abgeschlossene Installation von dotNET v2 schlummert.

    Daher einfach der Tip: dotNET zuerst einzeln installieren (ob du es aus dem HF extrahierst oder das passende zu deiner Windows-Sprachversion! von MS runterlädst [wurde auch schon beschrieben] - musst du wissen),
    dann einen Neustart machen (obwohl u.U. keine Aufforderung dafür kommt), und nach dem Neustart den Taskmanager öffnen und den Prozess "mscorsvw.exe" suchen und so lange keine Aktion am PC machen bis der Prozess verschwunden ist --->>> erst dann ist die Installation vom Framework VOLLSTÄNDIG ABGESCHLOSSEN !

    Danach kannst du dann den HF draufknallen.

    Diese Vorgehensweise kann aber natürlich nur gewählt werden wenn das Setup zum ersten mal gestartet wird.
    Einen verkorksten Fehlversuch kriegt man so definitiv NICHT wieder flott !
    Daher die ständigen Hinweise mit den Images - Für manche Sachen hat man nur einen Versuch und wenn der schiefgeht kann man sich sämtliche Reparaturversuche sparen.

    @all:
    Deswegen habe ich ja den Beitrag überhaupt unmittelbar nach veröffentlichung gleich hier aufgemacht weil ich mir schon dachte daß mit einführung des dotNET v2 Probleme auftauchen werden - speziell bei denen eben die es noch nicht drauf hatten.

    Ich weiß schon warum ich auf eine 2.Partition für Siemens-Software bestanden habe. Keine gräbt sich so tief ins System.
    Vergiß es einfach...
    Außer die zweite Partition enthält ein separates Betriebssystem.
    RS (rs-plc-aa)
    ______________________________________________
    Morgen ist Heute Gestern...
    ______________________________________________
    Installierst du noch - oder Arbeitest du schon ?
    ______________________________________________

  7. #17
    Registriert seit
    27.02.2007
    Beiträge
    27
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Standard

    // 2.Partition/Betriebssystem

    ...so ist es!
    Gruß
    Peter
    --------------------------------------------------------
    Win XP SP2, Pentium(R) 3GHz, 2GB RAM - WinCC flex 2007
    --------------------------------------------------------
    Fehler macht jeder. Aber für die richtig dicken Probleme braucht man einen Computer!

  8. #18
    Avatar von rs-plc-aa
    rs-plc-aa ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.11.2004
    Beiträge
    697
    Danke
    69
    Erhielt 64 Danke für 48 Beiträge

    Standard

    Hallo,

    @Shadow:
    Und, hast du noch mal einen "neuen" Versuch gestartet ?
    RS (rs-plc-aa)
    ______________________________________________
    Morgen ist Heute Gestern...
    ______________________________________________
    Installierst du noch - oder Arbeitest du schon ?
    ______________________________________________

  9. #19
    Registriert seit
    27.02.2007
    Beiträge
    27
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Standard

    @rs-plc-aa

    ....nein! Werde ich wohl diese Woche auch nicht mehr zu kommen. Arbeite jetzt erst mal mit NB und HF6 weiter. Termine, Termine...

    Thema erstmal abschließen - bei Neuigkeiten melde ich mich wieder.
    Gruß
    Peter
    --------------------------------------------------------
    Win XP SP2, Pentium(R) 3GHz, 2GB RAM - WinCC flex 2007
    --------------------------------------------------------
    Fehler macht jeder. Aber für die richtig dicken Probleme braucht man einen Computer!

  10. #20
    Avatar von rs-plc-aa
    rs-plc-aa ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.11.2004
    Beiträge
    697
    Danke
    69
    Erhielt 64 Danke für 48 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    @Shadow: Alles klar...


    Das Thema bleibt (natürlich) offen - es gibt ja vielleicht noch mehr die das interessiert oder selbst noch vor der Installation stehen.
    Die profitieren von den Erfahrungen (um das geht´s hier ja...)

    Also alles über HF7 Setup / Bugs hier rein !
    RS (rs-plc-aa)
    ______________________________________________
    Morgen ist Heute Gestern...
    ______________________________________________
    Installierst du noch - oder Arbeitest du schon ?
    ______________________________________________

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 09.09.2011, 14:16
  2. Antworten: 0
    Letzter Beitrag: 14.05.2010, 08:11
  3. Antworten: 7
    Letzter Beitrag: 15.05.2008, 01:06
  4. Antworten: 1
    Letzter Beitrag: 01.06.2007, 13:39
  5. Antworten: 2
    Letzter Beitrag: 16.05.2005, 10:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •