Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: OP177B verstellt selbstständig Profibusadresse

  1. #1
    Registriert seit
    09.03.2006
    Beiträge
    137
    Danke
    19
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich stelle im OP177B unter "Control Panel / S7-Transfer Settings" den Profibus mit Adresse 4 ein, übernehme die Einstellungen mit OK und starte die Runtime wieder. Gehe ich dann wieder zurück in die Einstellungen ist unter S7-Transfer Settings der MPI mit Adresse 1 angewählt. Meine Einstellungen werden nicht gespeichert.

    Die Anlage lief jetzt ca. 4 Wochen, musste aber heute wegen einer Änderung das Projekt neu übertragen. Das hat auch geklappt. Nur danach war die Verbindung auf MPI verstellt.

    Kennt jemand das Problem? Was kann ich tun? Bin über jeden Tipp dankbar.

    Gruß HarryH
    Geändert von HarryH (19.04.2007 um 10:28 Uhr)
    Zitieren Zitieren OP177B verstellt selbstständig Profibusadresse  

  2. #2
    Registriert seit
    31.10.2003
    Beiträge
    265
    Danke
    23
    Erhielt 37 Danke für 31 Beiträge

    Standard

    Hallo,
    ist denn in deinem Programm die Profibus-Schnittstelle parametriert?
    Wenn dort das OP auf MPI parametriert ist, denke ich nicht, das du das am Gerät nachträglich ändern kannst.
    Gruß Andre

  3. #3
    Avatar von HarryH
    HarryH ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.03.2006
    Beiträge
    137
    Danke
    19
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo,

    ja genau das war das Problem. Die Projektierte Adresse war falsch. So wurde die Adresse beim Starten den Runtime immer wieder auf die projektierte falsche Adresse umgeschaltet.

    Danke für den Hinweis.

    Gruß HarryH

  4. #4
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das Problem ist, dass auf CE-Panels beim Hochlauf der Runtime die in der Systemsteuerung eingestellte MPI/Profibus-Einstellung überschrieben wird, und zwar durch die Einstellung in der Projektierung.

    Abhilfe:
    Runtime beenden --> Systemsteuerung starten --> MPI/Profibus-Einstellung ändern & speichern --> Systemsteuerung beenden. Das Panel behält diese Einstellung nun bis zum nächsten Start der Runtime.

    Das bedeutet: jetzt NICHT auf "Start", sondern auf "Transfer" zu gehen. Dadurch wird das Panel in den Transfer-Modus geschaltet, und kann über die manuelle MPI/Profibus-Einstellung geladen werden.

    mfg
    Maxl
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

Ähnliche Themen

  1. profibusadresse bei Beckhoff EL6731
    Von Bensen83 im Forum CODESYS und IEC61131
    Antworten: 8
    Letzter Beitrag: 02.08.2011, 15:00
  2. SPS Verstellt Systemzeit
    Von Bensen83 im Forum HMI
    Antworten: 3
    Letzter Beitrag: 22.05.2011, 20:51
  3. CPU Uhr verstellt sich immer ?
    Von Deep Blue im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 24.03.2009, 09:27
  4. TP177A Baudrate verstellt sich
    Von ottopaul im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 07.12.2006, 23:35
  5. selbstständig
    Von Jelly im Forum Stammtisch
    Antworten: 32
    Letzter Beitrag: 04.10.2006, 00:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •